summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 08:07:25 +0800
committerSukanka2022-06-06 08:07:25 +0800
commitaf6ecd9b255df5df690b6c6e73a24da1701b0918 (patch)
tree6df0c9cffa7a3d66de6283ed8e9a942ee6bcfe9f
downloadaur-af6ecd9b255df5df690b6c6e73a24da1701b0918.tar.gz
add r-diffgeneanalysis
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c34b05900ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = r-diffgeneanalysis
+ pkgdesc = Performs differential gene expression Analysis
+ pkgver = 1.78.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/diffGeneAnalysis
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-minpack.lm
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/diffGeneAnalysis_1.78.0.tar.gz
+ sha256sums = 117293bd175585e5d91cf643c796bd854681ee4c3053139890cd299935a9a29e
+
+pkgname = r-diffgeneanalysis
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91e4149554dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=diffGeneAnalysis
+_pkgver=1.78.0
+pkgname=r-${_pkgname,,}
+pkgver=1.78.0
+pkgrel=1
+pkgdesc='Performs differential gene expression Analysis'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-minpack.lm
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('117293bd175585e5d91cf643c796bd854681ee4c3053139890cd299935a9a29e')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: