summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-09 12:01:17 +0200
committerMaxime Gauduin2015-06-09 12:01:17 +0200
commitafa23f9248096340af5ddaad5048e5d72cc8f0c8 (patch)
tree76b172c5d64038137fdd8ac94c85dd4b124229fd
downloadaur-afa23f9248096340af5ddaad5048e5d72cc8f0c8.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--MKPKG8
-rw-r--r--PKGBUILD45
-rw-r--r--gsignond-plugin-lastfm.install13
4 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..afbb94a018d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gsignond-plugin-lastfm-bzr
+ pkgdesc = LastFM plugin for gSSO
+ pkgver = r7
+ pkgrel = 1
+ url = https://launchpad.net/gsignond-plugin-lastfm
+ install = gsignond-plugin-lastfm.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = bzr
+ makedepends = cmake
+ makedepends = vala
+ depends = switchboard-plug-online-accounts-bzr
+ provides = gsignond-plugin-lastfm
+ conflicts = gsignond-plugin-lastfm
+ source = bzr+lp:gsignond-plugin-lastfm
+ sha256sums = SKIP
+
+pkgname = gsignond-plugin-lastfm-bzr
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..e16ca51db736
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,8 @@
+pkgname=('gsignond-plugin-lastfm-bzr')
+builddeps=('libgsignon-glib' 'gsignond' 'gsignond-plugin-oauth-git'
+ 'gsignond-plugin-sasl-git' 'granite-bzr' 'switchboard-bzr'
+ 'webkit2gtk2.4' 'switchboard-plug-online-accounts-bzr')
+
+check_bzr $packagedir/$pkgname/${pkgname%-*}
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aafa4b034353
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=gsignond-plugin-lastfm-bzr
+pkgver=r7
+pkgrel=1
+pkgdesc='LastFM plugin for gSSO'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/gsignond-plugin-lastfm'
+license=('GPL3')
+depends=('switchboard-plug-online-accounts-bzr')
+makedepends=('bzr' 'cmake' 'vala')
+provides=('gsignond-plugin-lastfm')
+conflicts=('gsignond-plugin-lastfm')
+install='gsignond-plugin-lastfm.install'
+source=('bzr+lp:gsignond-plugin-lastfm')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd gsignond-plugin-lastfm
+
+ echo "r$(bzr revno)"
+}
+
+build() {
+ cd gsignond-plugin-lastfm
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build && cd build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib'
+ make
+}
+
+package() {
+ cd gsignond-plugin-lastfm/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/gsignond-plugin-lastfm.install b/gsignond-plugin-lastfm.install
new file mode 100644
index 000000000000..44851fff35c3
--- /dev/null
+++ b/gsignond-plugin-lastfm.install
@@ -0,0 +1,13 @@
+post_install() {
+ gtk-update-icon-cache -ftq /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim: ts=2 sw=2 et: