summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2017-03-03 22:45:26 +0800
committerJingbei Li2017-03-03 22:45:26 +0800
commitafadcf311447a92c30311eac424ce144dc0ce1b5 (patch)
treea995059126de51bd491218d996a87693765b98da
parent8d862a2c47a37f12226712932588c177459941d8 (diff)
downloadaur-afadcf311447a92c30311eac424ce144dc0ce1b5.tar.gz
add provides conflicts and git
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d289117f7ea8..6687262d8482 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Feb 27 18:15:18 UTC 2017
+# Fri Mar 3 14:45:19 UTC 2017
pkgbase = python-theano-git
pkgdesc = Definition and optimized evaluation of mathematical expressions on Numpy arrays.
- pkgver = 0.9.0rc1.r59.183b5f1a4
+ pkgver = 0.9.0rc2.r16.674f8d514
pkgrel = 1
url = http://www.deeplearning.net/software/theano/
arch = any
@@ -13,6 +13,7 @@ pkgbase = python-theano-git
checkdepends = python2-nose-parameterized
makedepends = python-distribute
makedepends = python2-distribute
+ makedepends = git
depends = python
depends = python-numpy
depends = python2
@@ -37,8 +38,12 @@ pkgbase = python-theano-git
pkgname = python-theano-git
depends = python
depends = python-numpy
+ provides = python-theano
+ conflicts = python-theano
pkgname = python2-theano-git
depends = python2
depends = python2-numpy
+ provides = python2-theano
+ conflicts = python2-theano
diff --git a/PKGBUILD b/PKGBUILD
index c114513f3ce2..dd6a62ab8e1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase="python-theano-git"
pkgname=("python-theano-git" "python2-theano-git")
_pkgname="Theano"
-pkgver=0.9.0rc1.r59.183b5f1a4
+pkgver=0.9.0rc2.r16.674f8d514
pkgrel=1
pkgdesc='Definition and optimized evaluation of mathematical expressions on Numpy arrays.'
arch=('any')
@@ -12,7 +12,7 @@ url='http://www.deeplearning.net/software/theano/'
license=('BSD')
depends=('python' 'python-numpy'
'python2' 'python2-numpy')
-makedepends=('python-distribute' 'python2-distribute')
+makedepends=('python-distribute' 'python2-distribute' 'git')
checkdepends=('python-nose' 'python-nose-parameterized' 'python2-nose' 'python2-nose-parameterized')
optdepends=('python-sympy: Recommended'
'python-scipy: Recommended'
@@ -69,6 +69,8 @@ build() {
package_python2-theano-git() {
depends=('python2' 'python2-numpy')
+ provides=('python2-theano')
+ conflicts=('python2-theano')
cd "$srcdir/${_pkgname}-py2"
python2 setup.py install --root="$pkgdir"/ --optimize=1
mv "${pkgdir}/usr/bin/theano-cache" "${pkgdir}/usr/bin/theano2-cache"
@@ -79,6 +81,8 @@ package_python2-theano-git() {
package_python-theano-git() {
depends=('python' 'python-numpy')
+ provides=('python-theano')
+ conflicts=('python-theano')
cd "$srcdir/${_pkgname}"
python setup.py install --root="$pkgdir"/ --optimize=1
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-theano/LICENSE.txt"