summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDustin Falgout2016-08-24 06:01:32 -0500
committerDustin Falgout2016-08-24 06:01:32 -0500
commitafeddbb626f11b917988d5a5af85946cb7b0f36b (patch)
treea0e330b951998b1cab2675dc9050c08eec97ec37
parentf1f6ae1601621b4ef68bc1614deccc68b674de4a (diff)
downloadaur-afeddbb626f11b917988d5a5af85946cb7b0f36b.tar.gz
finished PKGBUILD
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD54
-rw-r--r--placeholder0
-rw-r--r--trailbot-client.desktop9
4 files changed, 78 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b383be72b32..b54332eede92 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,29 @@
# Generated by mksrcinfo v8
-# Wed Aug 24 08:41:23 UTC 2016
+# Wed Aug 24 11:00:07 UTC 2016
pkgbase = trailbot-client
- pkgver = 0.0.0.1a1
+ pkgdesc = Trailbot desktop app for managing watchers, policies, and file events.
+ pkgver = 0.2.0
pkgrel = 1
+ url = https://github.com/trailbot/client
arch = x86_64
+ groups = server
+ groups = security
license = MIT
- source = placeholder
- md5sums = d41d8cd98f00b204e9800998ecf8427e
+ license = custom:chromium
+ makedepends = npm
+ makedepends = git
+ makedepends = python2
+ depends = gtk2
+ depends = nss
+ depends = alsa-lib
+ depends = libnotify
+ depends = gconf
+ depends = libxtst
+ depends = libxss
+ source = https://github.com/trailbot/trailbot-client/archive/v0.2.0.tar.gz
+ source = trailbot-client.desktop
+ md5sums = f0c089b3ea68a92c5bf5fc6201e18d56
+ md5sums = ee6b7367c8ce8d6a6cd3e145eb89adc9
pkgname = trailbot-client
diff --git a/PKGBUILD b/PKGBUILD
index 3498e1dc1e4b..413eb81bf53c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,55 @@
# Maintainer: Dustin Falgout <dustin@antergos.com>
pkgname=trailbot-client
-pkgver=0.0.0.1a1
+pkgver=0.2.0
pkgrel=1
-arch=(x86_64)
-license=(MIT)
-source=(placeholder)
+pkgdesc='Trailbot desktop app for managing watchers, policies, and file events.'
+arch=('x86_64')
+url='https://github.com/trailbot/client'
+license=('MIT' 'custom:chromium')
+groups=('server' 'security')
+depends=('gtk2' 'nss' 'alsa-lib' 'libnotify' 'gconf' 'libxtst' 'libxss')
+makedepends=('npm' 'git' 'python2')
+source=("https://github.com/trailbot/${pkgname}/archive/v${pkgver}.tar.gz"
+ "${pkgname}.desktop")
+md5sums=('f0c089b3ea68a92c5bf5fc6201e18d56'
+ 'ee6b7367c8ce8d6a6cd3e145eb89adc9')
+
+
+build() {
+ local HOME
+ HOME="${srcdir}"
+
+ cd "${srcdir}/client-${pkgver}"
+ sed -i 's|--all|--platform=linux --arch=x64|g' package.json
+
+ npm install removeNPMAbsolutePaths --sav-dev
+ npm install
+ npm run package
+ node node_modules/remove*/bin/remove* .
+}
+
package() {
- cd "${srcdir}/placeholder" ${pkgdir}
+ cd "${srcdir}/client-${pkgver}"
+
+ mkdir -p \
+ "${pkgdir}"/usr/bin \
+ "${pkgdir}"/usr/share/{applications,licenses,pixmaps} \
+ "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ cp ../"${pkgname}.desktop" "${pkgdir}/usr/share/applications"
+
+ cp -R "${pkgname}-linux-x64" "${pkgdir}/usr/share/${pkgname}"
+
+ cd "${pkgdir}/usr/share/${pkgname}"
+
+ cp -t "${pkgdir}/usr/share/licenses/${pkgname}" \
+ LICENSE \
+ LICENSES.chromium.html
+
+ ln -s "/usr/share/${pkgname}/resources/app/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ ln -s "/usr/share/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
}
-md5sums=('d41d8cd98f00b204e9800998ecf8427e')
+
+# -*- mode: bash;-*-
diff --git a/placeholder b/placeholder
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/placeholder
+++ /dev/null
diff --git a/trailbot-client.desktop b/trailbot-client.desktop
new file mode 100644
index 000000000000..daf8aaa4b9d4
--- /dev/null
+++ b/trailbot-client.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.0
+Name=Trailbot Client
+StartupNotify=true
+Exec=trailbot-client %U
+Terminal=false
+Icon=trailbot
+Type=Application
+Categories=System;Security;Monitor;