summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2020-12-09 19:48:22 -0500
committerfrealgagu2020-12-09 19:48:22 -0500
commitb007c1c7b82c8f87f6f26b2f282cdd0307b9079e (patch)
tree9eaa5e0a0fb99a9d48828c4dbd4504c571c9bcc0
parent13bce1b8c4115435d4cbe605363d6f2ab4dc3d14 (diff)
downloadaur-b007c1c7b82c8f87f6f26b2f282cdd0307b9079e.tar.gz
Adding menu_lan patch.
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD62
-rw-r--r--menu_lan.patch15
4 files changed, 66 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67484019d9ee..90ef87d17a6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = tuxmath
- pkgdesc = An arcade game that helps kids practice their math facts
+ pkgdesc = An educational math tutorial game starring Tux, the Linux Penguin
pkgver = 2.0.3
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/tux4kids/tuxmath/
arch = i686
arch = x86_64
- license = GPL
license = custom:OFL
- license = custom
- makedepends = make
+ license = GPL
depends = t4kcommon
options = !docs
- source = https://github.com/tux4kids/tuxmath/archive/upstream/2.0.3.tar.gz
+ source = tuxmath-2.0.3.tar.gz::https://github.com/tux4kids/tuxmath/archive/upstream/2.0.3.tar.gz
+ source = menu_lan.patch
sha256sums = ab91bd6df17eb9377e5608701030bd32110a3588933bf0e4c26b5697fb2a4698
+ sha256sums = f6dad4cb620bf11ad9608dd95190ae6cafc78f0345fd92d8fb43a2a427dbb0df
pkgname = tuxmath
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6bcc0d60805a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+tuxmath-*.pkg.tar.zst
+tuxmath-*.pkg.tar.xz
+tuxmath-*.tar.gz
+tuxmath-*.log
+PKGBUILD-namcap.log
+tuxmath-upstream-*/
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 1399ea26a86f..3bf477b38453 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Alexandre Moine < nobrakal at moine dot org >
+# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
+# Contributor: Alexandre Moine < nobrakal at moine dot org >
# Contributor: Tasos Latsas < tlatsas2000 at gmail dot com >
# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
# Contributor: arjan <arjan@archlinux.org>
@@ -7,42 +8,53 @@
pkgname=tuxmath
pkgver=2.0.3
-pkgrel=3
-pkgdesc="An arcade game that helps kids practice their math facts"
-arch=('i686' 'x86_64')
-url="https://github.com/tux4kids/tuxmath/"
-license=('GPL' 'custom:OFL' 'custom')
-depends=('t4kcommon')
-makedepends=('make')
-options=('!docs')
-source=(https://github.com/tux4kids/$pkgname/archive/upstream/$pkgver.tar.gz)
-sha256sums=('ab91bd6df17eb9377e5608701030bd32110a3588933bf0e4c26b5697fb2a4698')
+pkgrel=4
+pkgdesc="An educational math tutorial game starring Tux, the Linux Penguin"
+arch=("i686" "x86_64")
+url="https://github.com/tux4kids/${pkgname}/"
+license=("custom:OFL" "GPL")
+depends=("t4kcommon")
+options=(!docs)
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/tux4kids/${pkgname}/archive/upstream/${pkgver}.tar.gz"
+ "menu_lan.patch"
+)
+sha256sums=(
+ "ab91bd6df17eb9377e5608701030bd32110a3588933bf0e4c26b5697fb2a4698"
+ "f6dad4cb620bf11ad9608dd95190ae6cafc78f0345fd92d8fb43a2a427dbb0df"
+)
+
+prepare() {
+ cd "${srcdir}/${pkgname}-upstream-${pkgver}"
+
+ patch -Np1 -i "${srcdir}/menu_lan.patch"
+}
build() {
- cd "$srcdir/${pkgname}-upstream-$pkgver"
+ cd "${srcdir}/${pkgname}-upstream-${pkgver}"
- ./configure --prefix=/usr
+ ./configure \
+ --prefix=/usr \
+ --localstatedir=/usr/share/games \
+ --sysconfdir=/etc \
make
}
package() {
- cd "$srcdir/${pkgname}-upstream-$pkgver"
+ cd "${srcdir}/${pkgname}-upstream-${pkgver}"
- make DESTDIR=$pkgdir install
+ make DESTDIR="${pkgdir}" install
# install .desktop file and icons
- mkdir -p $pkgdir/usr/share/{applications,pixmaps}
- install -D -m644 tuxmath.desktop $pkgdir/usr/share/applications/$pkgname.desktop
- install -D -m644 data/images/icons/icon.png $pkgdir/usr/share/pixmaps/$pkgname.png
+ install -dm755 "${pkgdir}/usr/share/"{applications,pixmaps}
+ install -Dm644 "${srcdir}/${pkgname}-upstream-${pkgver}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "${srcdir}/${pkgname}-upstream-${pkgver}/data/images/icons/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
# Install doc
- mkdir -p $pkgdir/usr/share/doc/$pkgname
- install -D -m644 doc/README \
- $pkgdir/usr/share/doc/$pkgname/README
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}-upstream-${pkgver}/doc/README" "${pkgdir}/usr/share/doc/${pkgname}/README"
# install licenses
- install -D -m644 doc/OFL \
- $pkgdir/usr/share/licenses/$pkgname/OFL
- install -D -m644 doc/README_DATA_LICENSES \
- $pkgdir/usr/share/licenses/$pkgname/DATA_LICENSES
+ install -Dm644 "${srcdir}/${pkgname}-upstream-${pkgver}/doc/OFL" "${pkgdir}/usr/share/licenses/${pkgname}/OFL"
+ install -Dm644 "${srcdir}/${pkgname}-upstream-${pkgver}/doc/README_DATA_LICENSES" "${pkgdir}/usr/share/licenses/${pkgname}/DATA_LICENSES"
}
diff --git a/menu_lan.patch b/menu_lan.patch
new file mode 100644
index 000000000000..d533c07821e0
--- /dev/null
+++ b/menu_lan.patch
@@ -0,0 +1,15 @@
+diff --git a/src/menu_lan.c b/src/menu_lan.c
+index 001ed23..265084e 100644
+--- a/src/menu_lan.c
++++ b/src/menu_lan.c
+@@ -35,10 +35,6 @@ along with this program. If not, see <http://www.gnu.org/licenses/>. */
+ #include "network.h"
+ #include "menu_lan.h"
+
+-
+-/* lan_player_type now defined in network.h */
+-lan_player_type lan_player_info[MAX_CLIENTS];
+-
+ /* Local function prototypes: ------------------- */
+ void draw_player_table(void);
+