summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFFY002018-07-02 01:35:29 +0100
committerFFY002018-07-02 01:35:29 +0100
commitb00815f18db26d304d981b420fdc28ea2a5f050f (patch)
tree9c1f69f35d6b80f970c79afe942d15bb335b8af9
parent7950b440139696f338d3c8dcdda7ec3d71ca7f6b (diff)
downloadaur-b00815f18db26d304d981b420fdc28ea2a5f050f.tar.gz
pkgbuild: add quotes to $pkgdir
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD23
2 files changed, 28 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb059ce9ef3c..be972ade1205 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,31 @@
pkgbase = mitmproxy-git
- pkgdesc = An interactive TLS-capable intercepting HTTP proxy for penetration testers and software developers
- pkgver = 3.0.1.r246.a4a48a96
+ pkgdesc = An interactive TLS-capable intercepting HTTP proxy.
+ pkgver = 4.0.0.r79.3cd37652
pkgrel = 1
url = https://mitmproxy.org/
arch = any
license = MIT
- depends = openssl
+ depends = python-blinker
depends = python-brotlipy
- depends = python-certifi
+ depends = python-click
+ depends = python-cryptography
+ depends = python-h11
depends = python-h2
+ depends = python-hyperframe
+ depends = python-kaitaistruct
depends = python-ldap3
- depends = python-pyopenssl
+ depends = python-passlib
depends = python-pyasn1
- depends = python-imaging
- depends = python-hyperframe
- depends = python-lxml
- depends = python-flask
+ depends = python-pyopenssl
+ depends = python-pyparsing
+ depends = python-pyperclip
depends = python-requests
- depends = python-passlib
- depends = python-urwid
- depends = python-configargparse
+ depends = python-ruamel-yaml
+ depends = python-setuptools
+ depends = python-sortedcontainers
depends = python-tornado
+ depends = python-urwid
depends = python-wsproto
- depends = python-kaitaistruct
- depends = python-pyperclip>=1.5.8
- depends = python-blinker>=1.3
provides = mitmproxy
conflicts = mitmproxy
source = git+https://github.com/mitmproxy/mitmproxy.git
diff --git a/PKGBUILD b/PKGBUILD
index b8a6b34b58c6..aea5bfe05116 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
# Maintainer: FFY00 <filipe.lains@gmail.com>
-
pkgname=mitmproxy-git
-pkgver=3.0.1.r246.a4a48a96
+_pkgname=${pkgname%-git}
+pkgver=4.0.0.r79.3cd37652
pkgrel=1
-pkgdesc="An interactive TLS-capable intercepting HTTP proxy for penetration testers and software developers"
+pkgdesc="An interactive TLS-capable intercepting HTTP proxy."
arch=('any')
url="https://mitmproxy.org/"
license=('MIT')
depends=(
- 'openssl' 'python-brotlipy' 'python-certifi' 'python-h2' 'python-ldap3'
- 'python-pyopenssl' 'python-pyasn1' 'python-imaging' 'python-hyperframe'
- 'python-lxml' 'python-flask' 'python-requests' 'python-passlib' 'python-urwid'
- 'python-configargparse' 'python-tornado' 'python-wsproto' 'python-kaitaistruct'
- 'python-pyperclip>=1.5.8' 'python-blinker>=1.3')
+ 'python-blinker' 'python-brotlipy' 'python-click' 'python-cryptography' 'python-h11'
+ 'python-h2' 'python-hyperframe' 'python-kaitaistruct' 'python-ldap3' 'python-passlib'
+ 'python-pyasn1' 'python-pyopenssl' 'python-pyparsing' 'python-pyperclip' 'python-requests'
+ 'python-ruamel-yaml' 'python-setuptools' 'python-sortedcontainers' 'python-tornado'
+ 'python-urwid' 'python-wsproto'
+)
conflicts=('mitmproxy')
provides=('mitmproxy')
source=("git+https://github.com/mitmproxy/mitmproxy.git")
sha1sums=('SKIP')
pkgver() {
- cd "$srcdir/mitmproxy"
+ cd "$srcdir"/$_pkgname
git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g;s/\.rc./rc/g'
}
package() {
- cd "$srcdir/mitmproxy"
- python setup.py install --root=$pkgdir
+ cd "$srcdir"/$_pkgname
+ python setup.py install --root="$pkgdir"
}