summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Oelmueller2021-04-04 20:12:47 +0200
committerChris Oelmueller2021-04-04 20:40:17 +0200
commitb01248f4af2c01f18225dad348ca07f364d9f09a (patch)
tree8e0969e86ec81eaaccdb1b92d5f5fe4c21a81286
parent0d13ad4dbacb0f555961e2fd5f24688deca18043 (diff)
downloadaur-b01248f4af2c01f18225dad348ca07f364d9f09a.tar.gz
fife-git: Update swig4 patch to latest HEAD
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--swig4.patch2
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d7fe0431bfe..725f35bcd02b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fife-git
pkgdesc = The mission of the FIFE project is to create a cross platform game creation framework
- pkgver = 0.4.2.r25.gc29d418a
+ pkgver = 0.4.2.r29.g78c07b9a
pkgrel = 1
url = http://www.fifengine.net/
arch = i686
@@ -31,9 +31,9 @@ pkgbase = fife-git
source = git+https://github.com/fifengine/fifengine.git
source = swig4.patch
md5sums = SKIP
- md5sums = 05b0425ae3a94a36b9227f51c09c23aa
+ md5sums = 1e915710aea0a9c63a93f13c979e3a7a
sha1sums = SKIP
- sha1sums = 0302be0b353e6aa69a81a8e8c872239ecbcab1d0
+ sha1sums = f010025945fb392e9d5b89ebd118c049a60eee30
pkgname = fife-git
diff --git a/PKGBUILD b/PKGBUILD
index 2cf51ec25d94..f5f0f0480161 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ provides=("fife" "fife-svn")
conflicts=("fife" "fife-svn")
pkgdesc="The mission of the FIFE project is to create a cross platform game creation framework"
url="http://www.fifengine.net/"
-pkgver=0.4.2.r25.gc29d418a
+pkgver=0.4.2.r29.g78c07b9a
pkgrel=1
arch=('i686' 'x86_64')
license=('LGPL')
@@ -19,9 +19,9 @@ makedepends=('cmake' 'git' 'swig>=4')
source=(git+https://github.com/fifengine/fifengine.git
"swig4.patch")
md5sums=('SKIP'
- '05b0425ae3a94a36b9227f51c09c23aa')
+ '1e915710aea0a9c63a93f13c979e3a7a')
sha1sums=('SKIP'
- '0302be0b353e6aa69a81a8e8c872239ecbcab1d0')
+ 'f010025945fb392e9d5b89ebd118c049a60eee30')
pkgver() {
diff --git a/swig4.patch b/swig4.patch
index d2318e71aa80..1c57e2dc7b0a 100644
--- a/swig4.patch
+++ b/swig4.patch
@@ -15,7 +15,7 @@ index 126322ce0..25c695630 100644
find_package(PythonLibs ${PYTHON_VERSION_STRING} EXACT)
include_directories(${PYTHON_INCLUDE_PATH})
-- set(CMAKE_SWIG_FLAGS -modern -fastdispatch -dirvtable -nosafecstrings -noproxydel -fastproxy -fastinit -fastunpack -fastquery -modernargs -nobuildnone -keyword -w511 -w473 -w404 -w314)
+- set(CMAKE_SWIG_FLAGS -modern -fastdispatch -dirvtable -noproxydel -fastproxy -fastinit -fastunpack -fastquery -modernargs -keyword -w511 -w473 -w404 -w314)
+ set(CMAKE_SWIG_FLAGS -fastdispatch -dirvtable -fastproxy -keyword -w511 -w473 -w404 -w314)
set_source_files_properties("${PROJECT_BINARY_DIR}/fife.i" PROPERTIES CPLUSPLUS ON)