summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Martin2016-07-17 16:47:22 -0500
committerAndrew Martin2016-07-17 16:47:22 -0500
commitb0599d1820781f749d3f12cff49b2c98a954fb76 (patch)
treea35ad93cf23b5fda4ec4ef76f47f75c2de16cc8f
parent39937e98478a45912fb38cd45ec1d981084a5a80 (diff)
downloadaur-b0599d1820781f749d3f12cff49b2c98a954fb76.tar.gz
fixed problem preventing post_install() from executing, which resulted in a SIGTRAP on run
-rw-r--r--PKGBUILD14
-rw-r--r--photomatix.install11
2 files changed, 13 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b639144b1941..d60f9ae31b10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=photomatix
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Professional HDR Creation Program"
url="http://hdrsoft.com/download/photomatix-linux.html"
arch=('x86_64')
@@ -10,6 +10,7 @@ license=('custom')
depends=('libtiff' 'openexr' 'gtkmm3')
source=("http://hdrsoft.com/download/linux/PhotomatixLinux_Ubuntu_16.04.deb")
sha1sums=('28a56527b8e2f463b96653a348034e7b1db02c93')
+install="photomatix.install"
package() {
# extract the deb file's data.tar.gz archive
@@ -25,14 +26,3 @@ package() {
mv ${srcdir}/usr/bin ${pkgdir}/usr/
chmod 755 ${pkgdir}/usr/bin
}
-
-post_install() {
- cp /usr/share/photomatix/apps.photomatix.gschema.xml /usr/share/glib-2.0/schemas/
- glib-compile-schemas /usr/share/glib-2.0/schemas/
- chmod a+r /usr/share/glib-2.0/schemas/gschemas.compiled
- chmod 0755 /usr/bin/photomatix
-}
-
-post_upgrade() {
- post_install
-}
diff --git a/photomatix.install b/photomatix.install
new file mode 100644
index 000000000000..2d7f38cbc3f7
--- /dev/null
+++ b/photomatix.install
@@ -0,0 +1,11 @@
+post_install() {
+ sudo cp /usr/share/photomatix/apps.photomatix.gschema.xml /usr/share/glib-2.0/schemas/
+ sudo glib-compile-schemas /usr/share/glib-2.0/schemas/
+ sudo chmod a+r /usr/share/glib-2.0/schemas/gschemas.compiled
+
+ sudo chmod 0755 /usr/bin/photomatix
+}
+
+post_upgrade() {
+ post_install
+}