summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPlaton Ryzhikov2019-10-24 20:36:14 +0300
committerPlaton Ryzhikov2019-10-24 20:36:14 +0300
commitb078f757fa5ebc9137c603e0c0a6e6b8649a343c (patch)
tree576bc5f71a0c3c1481ec7969e42b53ddf2a2b5e4
downloadaur-b078f757fa5ebc9137c603e0c0a6e6b8649a343c.tar.gz
Initial commit
-rw-r--r--.SRCINFO80
-rw-r--r--PKGBUILD180
-rw-r--r--cups-1.6.2-statedir.patch12
-rw-r--r--cups-no-export-ssllibs.patch12
-rw-r--r--cups.install20
-rw-r--r--cups.logrotate5
-rw-r--r--cups.pam3
-rw-r--r--cups.sysusers2
-rw-r--r--guid.patch42
9 files changed, 356 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7c7cf2bcd19
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,80 @@
+pkgbase = cups-noudev
+ pkgver = 2.3.0
+ pkgrel = 3
+ url = https://www.cups.org/
+ arch = x86_64
+ license = Apache
+ license = custom
+ makedepends = libtiff
+ makedepends = libpng
+ makedepends = acl
+ makedepends = pam
+ makedepends = xdg-utils
+ makedepends = krb5
+ makedepends = gnutls
+ makedepends = cups-filters
+ makedepends = bc
+ makedepends = colord
+ makedepends = xinetd
+ makedepends = gzip
+ makedepends = autoconf
+ makedepends = libusb
+ makedepends = avahi
+ makedepends = hicolor-icon-theme
+ makedepends = inetutils
+ makedepends = libpaper
+ makedepends = valgrind
+ source = https://github.com/apple/cups/releases/download/v2.3.0/cups-2.3.0-source.tar.gz
+ source = https://github.com/apple/cups/releases/download/v2.3.0/cups-2.3.0-source.tar.gz.sig
+ source = cups.logrotate
+ source = cups.pam
+ source = cups.sysusers
+ source = cups-no-export-ssllibs.patch
+ source = cups-1.6.2-statedir.patch
+ source = guid.patch
+ validpgpkeys = 3737FD0D0E63B30172440D2DDBA3A7AB08D76223
+ validpgpkeys = 45D083946E3035282B3CCA9AF434104235DA97EB
+ validpgpkeys = 845464660B686AAB36540B6F999559A027815955
+ sha256sums = acaf0229cf008ea8f06353ffd1bbd62d71dbe88990dd3330650ef87edb95a1a5
+ sha256sums = SKIP
+ sha256sums = d87fa0f0b5ec677aae34668f260333db17ce303aa1a752cba5f8e72623d9acf9
+ sha256sums = 57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5
+ sha256sums = 06173dfaea37bdd9b39b3e09aba98c34ae7112a2f521db45a688907d8848caa2
+ sha256sums = ff3eb0782af0405f5dafe89e04b1b4ea7a49afc5496860d724343bd04f375832
+ sha256sums = 23349c96f2f7aeb7d48e3bcd35a969f5d5ac8f55a032b0cfaa0a03d7e37ea9af
+ sha256sums = d4537526c1e075866ae22ad263da000fc2a592d36c26b79a459a1cfdade2bb2d
+
+pkgname = libcups-noudev
+ pkgdesc = The CUPS Printing System - client libraries and headers
+ depends = gnutls
+ depends = libtiff>=4.0.0
+ depends = libpng>=1.5.7
+ depends = krb5
+ depends = avahi
+ depends = libusb
+ provides = libcups=2.3.0
+ conflicts = libcups
+
+pkgname = cups-noudev
+ pkgdesc = The CUPS Printing System - daemon package
+ install = cups.install
+ depends = acl
+ depends = pam
+ depends = libcups>=2.3.0
+ depends = cups-filters
+ depends = bc
+ depends = libpaper
+ depends = hicolor-icon-theme
+ optdepends = xdg-utils: xdg .desktop file support
+ optdepends = colord: for ICC color profile support
+ provides = cups=2.3.0
+ conflicts = cups
+ backup = etc/cups/cupsd.conf
+ backup = etc/cups/snmp.conf
+ backup = etc/cups/printers.conf
+ backup = etc/cups/classes.conf
+ backup = etc/cups/cups-files.conf
+ backup = etc/cups/subscriptions.conf
+ backup = etc/logrotate.d/cups
+ backup = etc/pam.d/cups
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55ca9a772ee0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,180 @@
+# Maintainer: Platon Ryzhikov <ihummer63@yandex.ru>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# noudev:
+# -remove udev and dbus from dependencies
+# -remove dbus from configuration
+# -add --enable-libusb
+# -fix backends permissions (only USB is done by now)
+# report noudev-specific bugs to https://forum.artixlinux.org/index.php/topic,530.0.html
+
+_pkgbase="cups"
+pkgbase="cups-noudev"
+pkgname=('libcups-noudev' 'cups-noudev')
+pkgver=2.3.0
+pkgrel=3
+arch=('x86_64')
+license=('Apache' 'custom')
+url="https://www.cups.org/"
+makedepends=('libtiff' 'libpng' 'acl' 'pam' 'xdg-utils' 'krb5' 'gnutls'
+ 'cups-filters' 'bc' 'colord' 'xinetd' 'gzip' 'autoconf' 'libusb'
+ 'avahi' 'hicolor-icon-theme' 'inetutils' 'libpaper' 'valgrind')
+source=(https://github.com/apple/cups/releases/download/v${pkgver}/cups-${pkgver}-source.tar.gz{,.sig}
+ cups.logrotate
+ cups.pam
+ cups.sysusers
+ # improve build and linking
+ cups-no-export-ssllibs.patch
+ cups-1.6.2-statedir.patch
+ # bugfixes
+ guid.patch)
+sha256sums=('acaf0229cf008ea8f06353ffd1bbd62d71dbe88990dd3330650ef87edb95a1a5'
+ 'SKIP'
+ 'd87fa0f0b5ec677aae34668f260333db17ce303aa1a752cba5f8e72623d9acf9'
+ '57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5'
+ '06173dfaea37bdd9b39b3e09aba98c34ae7112a2f521db45a688907d8848caa2'
+ 'ff3eb0782af0405f5dafe89e04b1b4ea7a49afc5496860d724343bd04f375832'
+ '23349c96f2f7aeb7d48e3bcd35a969f5d5ac8f55a032b0cfaa0a03d7e37ea9af'
+ 'd4537526c1e075866ae22ad263da000fc2a592d36c26b79a459a1cfdade2bb2d')
+validpgpkeys=('3737FD0D0E63B30172440D2DDBA3A7AB08D76223') # CUPS.org (CUPS.org PGP key) <security@cups.org>
+validpgpkeys+=('45D083946E3035282B3CCA9AF434104235DA97EB') # "CUPS.org <security@cups.org>"
+validpgpkeys+=('845464660B686AAB36540B6F999559A027815955') # "Michael R Sweet <michael.r.sweet@gmail.com>"
+
+prepare() {
+
+ cd ${_pkgbase}-${pkgver}
+
+ # improve build and linking
+ # Do not export SSL libs in cups-config
+ patch -Np1 -i ${srcdir}/cups-no-export-ssllibs.patch
+ # move /var/run -> /run for pid file
+ patch -Np1 -i ${srcdir}/cups-1.6.2-statedir.patch
+
+ # FS#56818 - https://github.com/apple/cups/issues/5236
+ patch -Np1 -i ${srcdir}/guid.patch
+
+ # set MaxLogSize to 0 to prevent using cups internal log rotation
+ sed -i -e '5i\ ' conf/cupsd.conf.in
+ sed -i -e '6i# Disable cups internal logging - use logrotate instead' conf/cupsd.conf.in
+ sed -i -e '7iMaxLogSize 0' conf/cupsd.conf.in
+
+ # Rebuild configure script for not zipping man-pages.
+ aclocal -I config-scripts
+ autoconf -I config-scripts
+}
+
+build() {
+ cd ${_pkgbase}-${pkgver}
+
+ # use fixed cups user (id 209) since sysusers adds "lp" group without a fixed id
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --sbindir=/usr/bin \
+ --libdir=/usr/lib \
+ --with-logdir=/var/log/cups \
+ --with-docdir=/usr/share/cups/doc \
+ --with-exe-file-perm=0755 \
+ --with-cups-user=209 \
+ --with-cups-group=209 \
+ --enable-pam=yes \
+ --enable-raw-printing \
+ --disable-dbus \
+ --with-dbusdir=no \
+ --enable-ssl=yes \
+ --enable-threads \
+ --enable-avahi\
+ --enable-libpaper \
+ --with-php=/usr/bin/php-cgi \
+ --disable-systemd \
+ --enable-libusb \
+ --with-optim="$CFLAGS" #--help
+ make
+}
+
+check() {
+ cd ${_pkgbase}-${pkgver}
+ #make -k check || /bin/true
+}
+
+package_libcups-noudev() {
+pkgdesc="The CUPS Printing System - client libraries and headers"
+depends=('gnutls' 'libtiff>=4.0.0' 'libpng>=1.5.7' 'krb5' 'avahi' 'libusb')
+provides=("libcups=${pkgver}")
+conflicts=("libcups")
+ cd ${_pkgbase}-${pkgver}
+ make BUILDROOT=${pkgdir} install-headers install-libs
+ # put this into the libs pkg to make other software find the libs(no pkg-config file included)
+ mkdir -p ${pkgdir}/usr/bin
+ install -m755 ${srcdir}/${_pkgbase}-${pkgver}/cups-config ${pkgdir}/usr/bin/cups-config
+
+ # add license + exception
+ install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" {LICENSE,NOTICE}
+
+ # fix usb backend permissions
+ chmod 700 ${pkgdir}/usr/lib/cups/backend/usb
+}
+
+package_cups-noudev() {
+pkgdesc="The CUPS Printing System - daemon package"
+install=cups.install
+backup=(etc/cups/cupsd.conf
+ etc/cups/snmp.conf
+ etc/cups/printers.conf
+ etc/cups/classes.conf
+ etc/cups/cups-files.conf
+ etc/cups/subscriptions.conf
+ etc/logrotate.d/cups
+ etc/pam.d/cups)
+depends=('acl' 'pam' "libcups>=${pkgver}" 'cups-filters' 'bc'
+ 'libpaper' 'hicolor-icon-theme')
+optdepends=('xdg-utils: xdg .desktop file support'
+ 'colord: for ICC color profile support')
+provides=("cups=${pkgver}")
+conflicts=("cups")
+ cd ${_pkgbase}-${pkgver}
+ make BUILDROOT=${pkgdir} install-data install-exec
+
+ # this one we ship in the libcups pkg
+ rm -f ${pkgdir}/usr/bin/cups-config
+
+ # kill the sysv stuff
+ rm -rf ${pkgdir}/etc/rc*.d
+ rm -rf ${pkgdir}/etc/init.d
+ install -D -m644 ../cups.logrotate ${pkgdir}/etc/logrotate.d/cups
+ install -D -m644 ../cups.pam ${pkgdir}/etc/pam.d/cups
+
+ # fix perms on /var/spool and /etc
+ chmod 755 ${pkgdir}/var/spool
+ chmod 755 ${pkgdir}/etc
+
+ # use cups group FS#36769
+ install -Dm644 "$srcdir"/cups.sysusers "${pkgdir}/usr/lib/sysusers.d/$pkgname.conf"
+ sed -i "s:#User 209:User 209:" ${pkgdir}/etc/cups/cups-files.conf{,.default}
+ sed -i "s:#Group 209:Group 209:" ${pkgdir}/etc/cups/cups-files.conf{,.default}
+
+ # install ssl directory where to store the certs, solves some samba issues
+ install -dm700 -g 209 ${pkgdir}/etc/cups/ssl
+ # remove directory from package, it will be recreated at each server start
+ rm -rf ${pkgdir}/run
+
+ # install some more configuration files that will get filled by cupsd
+ touch ${pkgdir}/etc/cups/printers.conf
+ touch ${pkgdir}/etc/cups/classes.conf
+ touch ${pkgdir}/etc/cups/subscriptions.conf
+ chgrp -R 209 ${pkgdir}/etc/cups
+
+ # fix .desktop file
+ sed -i 's|^Exec=htmlview http://localhost:631/|Exec=xdg-open http://localhost:631/|g' ${pkgdir}/usr/share/applications/cups.desktop
+
+ # compress some driver files, adopted from Fedora
+ find ${pkgdir}/usr/share/cups/model -name "*.ppd" | xargs gzip -n9f
+
+ # remove client.conf man page
+ rm -f ${pkgdir}/usr/share/man/man5/client.conf.5
+
+ # comment out all conversion rules which use any of the removed filters that are now part of cups-filters
+ perl -p -i -e 's:^(.*\s+bannertops\s*)$:#\1:' $pkgdir/usr/share/cups/mime/mime.convs
+
+ # comment out unnecessary PageLogFormat entry
+ sed -i -e 's:PageLogFormat:#PageLogFormat:' $pkgdir/etc/cups/cupsd.conf*
+}
diff --git a/cups-1.6.2-statedir.patch b/cups-1.6.2-statedir.patch
new file mode 100644
index 000000000000..c44ebed07c50
--- /dev/null
+++ b/cups-1.6.2-statedir.patch
@@ -0,0 +1,12 @@
+diff -ruN cups-1.6.2.orig/config-scripts/cups-directories.m4 cups-1.6.2/config-scripts/cups-directories.m4
+--- cups-1.6.2.orig/config-scripts/cups-directories.m4 2012-10-01 03:55:23.000000000 +0200
++++ cups-1.6.2/config-scripts/cups-directories.m4 2013-04-02 00:11:41.000000000 +0200
+@@ -420,7 +420,7 @@
+ ;;
+ *)
+ # All others
+- CUPS_STATEDIR="$localstatedir/run/cups"
++ CUPS_STATEDIR="/run/cups"
+ ;;
+ esac])
+ AC_DEFINE_UNQUOTED(CUPS_STATEDIR, "$CUPS_STATEDIR")
diff --git a/cups-no-export-ssllibs.patch b/cups-no-export-ssllibs.patch
new file mode 100644
index 000000000000..e227bd182390
--- /dev/null
+++ b/cups-no-export-ssllibs.patch
@@ -0,0 +1,12 @@
+diff -up cups-1.5b1/config-scripts/cups-ssl.m4.no-export-ssllibs cups-1.5b1/config-scripts/cups-ssl.m4
+--- cups-1.6.2/config-scripts/cups-ssl.m4.no-export-ssllibs 2011-05-11 02:52:08.000000000 +0200
++++ cups-1.6.2/config-scripts/cups-ssl.m4 2011-05-23 17:47:27.000000000 +0200
+@@ -180,7 +180,7 @@
+ AC_SUBST(SSLFLAGS)
+ AC_SUBST(SSLLIBS)
+
+-EXPORT_SSLLIBS="$SSLLIBS"
++EXPORT_SSLLIBS=""
+ AC_SUBST(EXPORT_SSLLIBS)
+
+ dnl
diff --git a/cups.install b/cups.install
new file mode 100644
index 000000000000..c83a437ea8c3
--- /dev/null
+++ b/cups.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo ">> If you use an HTTPS connection to CUPS, the first time you access"
+ echo ">> the interface it may take a very long time before the site comes up."
+ echo ">> This is because the first request triggers the generation of the CUPS"
+ echo ">> SSL certificates which can be a very time-consuming job."
+}
+
+post_upgrade() {
+ # FS#56818 - make sure we change the ownership to the new cups group
+ if [[ $(vercmp 2.2.6-3 $2) = 1 ]]; then
+ chgrp -R 209 /etc/cups
+ echo "Cups daemon is now running under \"cups\" user+group."
+ echo "Please make sure to enable the new user+group change in"
+ echo "/etc/cups/cups-files.conf or merge changes from"
+ echo "/etc/cups/cups-files.conf.default. After a service restart"
+ echo "make sure /etc/cups and all files within are owned by"
+ echo "cups group - run \"chgrp -R cups /etc/cups\"."
+ fi
+}
+
diff --git a/cups.logrotate b/cups.logrotate
new file mode 100644
index 000000000000..19e12101be2b
--- /dev/null
+++ b/cups.logrotate
@@ -0,0 +1,5 @@
+/var/log/cups/*_log {
+ missingok
+ notifempty
+ sharedscripts
+}
diff --git a/cups.pam b/cups.pam
new file mode 100644
index 000000000000..53724d1f86a7
--- /dev/null
+++ b/cups.pam
@@ -0,0 +1,3 @@
+auth required pam_unix.so
+account required pam_unix.so
+session required pam_unix.so
diff --git a/cups.sysusers b/cups.sysusers
new file mode 100644
index 000000000000..4ab9d5905968
--- /dev/null
+++ b/cups.sysusers
@@ -0,0 +1,2 @@
+u cups 209 "cups helper user"
+m cups lp
diff --git a/guid.patch b/guid.patch
new file mode 100644
index 000000000000..ce28e024f3fd
--- /dev/null
+++ b/guid.patch
@@ -0,0 +1,42 @@
+diff --git a/scheduler/cups-exec.c b/scheduler/cups-exec.c
+index aab43a797..46c549075 100644
+--- a/scheduler/cups-exec.c
++++ b/scheduler/cups-exec.c
+@@ -133,8 +133,13 @@ main(int argc, /* I - Number of command-line args */
+ if (setgid(gid))
+ exit(errno + 100);
+
+- if (setgroups(1, &gid))
++#include <pwd.h>
++ struct passwd * pwd = getpwuid(uid);
++ if(initgroups(pwd->pw_name,pwd->pw_gid))
++ {
++ fprintf(stderr, "DEBUG: initgroups failed\n");
+ exit(errno + 100);
++ }
+
+ if (uid && setuid(uid))
+ exit(errno + 100);
+diff --git a/scheduler/util.c b/scheduler/util.c
+index 19ebf069b..4638562bd 100644
+--- a/scheduler/util.c
++++ b/scheduler/util.c
+@@ -300,7 +300,16 @@ cupsdPipeCommand(int *pid, /* O - Process ID or 0 on error */
+ */
+
+ if (!getuid() && user)
+- setuid(user); /* Run as restricted user */
++ {
++#include <pwd.h>
++ struct passwd * pwd = getpwuid(user);
++ if(initgroups(pwd->pw_name,pwd->pw_gid))
++ {
++ fprintf(stderr, "DEBUG: initgroups failed\n");
++ exit(errno + 100);
++ }
++ setuid(user); /* Run as restricted user */
++ }
+
+ if ((fd = open("/dev/null", O_RDONLY)) > 0)
+ {
+