summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Ascher2016-07-18 00:11:29 +0200
committerThomas Ascher2016-07-18 00:11:29 +0200
commitb0873d343cc30954f984853cb95c83cc3d7340d8 (patch)
treeba51dc98fd20d2800fce04e1c24c23b83a30012f
downloadaur-b0873d343cc30954f984853cb95c83cc3d7340d8.tar.gz
initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
-rw-r--r--systempreferences.install11
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..648adbcf1467
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = systempreferences
+ pkgdesc = An application which allows to manage the settings of many aspects of the gnustep environment and its applications.
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = http://www.gnustep.org/experience/systempreferences.html
+ install = systempreferences.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gcc-objc
+ makedepends = gnustep-make
+ depends = gnustep-base
+ depends = gnustep-gui
+ source = ftp://ftp.gnustep.org/pub/gnustep/usr-apps/SystemPreferences-1.1.0.tar.gz
+ source = systempreferences.install
+ sha256sums = c7dffa3b33949e26c319aa2adbda8e9168e51d2f1a0790d5ec0d609a915ec8e0
+ sha256sums = f703f8de14eb277dc72cc837086fbd55f5d772049a44200686c8ae76348f6614
+
+pkgname = systempreferences
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59fc7240eec4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Thomas Ascher <thomas.ascher@gmx.at>
+# Contributor: Thomas Ascher <thomas.ascher@gmx.at>
+pkgname=systempreferences
+_pkgname=SystemPreferences
+pkgrel=1
+pkgver=1.1.0
+pkgdesc="An application which allows to manage the settings of many aspects of the gnustep environment and its applications."
+arch=('i686' 'x86_64')
+url="http://www.gnustep.org/experience/$pkgname.html"
+license=('GPL')
+install=$pkgname.install
+depends=('gnustep-base'
+ 'gnustep-gui')
+makedepends=('gcc-objc'
+ 'gnustep-make')
+source=("ftp://ftp.gnustep.org/pub/gnustep/usr-apps/$_pkgname-$pkgver.tar.gz"
+ "$pkgname.install")
+sha256sums=('c7dffa3b33949e26c319aa2adbda8e9168e51d2f1a0790d5ec0d609a915ec8e0'
+ 'f703f8de14eb277dc72cc837086fbd55f5d772049a44200686c8ae76348f6614')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" \
+ "$pkgdir/usr/share/applications/$_pkgname.desktop"
+}
diff --git a/systempreferences.install b/systempreferences.install
new file mode 100644
index 000000000000..2eaa60550d51
--- /dev/null
+++ b/systempreferences.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}