summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyhardhan Risson Ulvestad-LaReve2021-08-17 22:06:30 -0700
committerKyhardhan Risson Ulvestad-LaReve2021-08-17 22:06:30 -0700
commitb0a8d803bd48e188f957acd751cd781e23bfc192 (patch)
treef67c735454bb52548d74700d7e9440364e282a14
parentca4eeb4a5c98dab5bffb8e0803d1dcf718b1a792 (diff)
downloadaur-b0a8d803bd48e188f957acd751cd781e23bfc192.tar.gz
Update from version 1.1.0 to 1.3.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abe4d21da775..73e5f1ae1aab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = wlcs
pkgdesc = Canonical's protocol-conformance-verifying test suite for Wayland compositor implementations.
- pkgver = 1.1.0
+ pkgver = 1.3.0
pkgrel = 1
url = https://github.com/MirServer/wlcs
arch = x86_64
arch = i686
+ arch = aarch64
license = GPL
makedepends = git
makedepends = cmake
@@ -14,8 +15,7 @@ pkgbase = wlcs
depends = gtest
depends = boost-libs
depends = wayland
- source = https://github.com/MirServer/wlcs/releases/download/v1.1.0/wlcs-1.1.0.tar.xz
- sha256sums = 7238dd4a0fece16b7eb21db90722795fb68f20e0fcfc82ab01bce5b63ca415d1
+ source = git+https://github.com/MirServer/wlcs.git
+ sha256sums = SKIP
pkgname = wlcs
-
diff --git a/PKGBUILD b/PKGBUILD
index e14e3204dcba..0570c36e1f45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,23 @@
+# Maintainer: thyTwilightGoth <https://aur.archlinux.org/account/thyTwilightGoth>
+# Contributor: Pedro <https://aur.archlinux.org/account/PedroHLC>
+
pkgname=wlcs
-pkgver=1.1.0
-_tardirname=1.0.0
+pkgver=1.3.0
pkgrel=1
pkgdesc="Canonical's protocol-conformance-verifying test suite for Wayland compositor implementations."
url='https://github.com/MirServer/wlcs'
-arch=(x86_64 i686)
+arch=(x86_64 i686 aarch64)
license=(GPL)
depends=(gtest boost-libs wayland)
makedepends=(git cmake boost gmock wayland-protocols)
optdepends=()
-source=("https://github.com/MirServer/wlcs/releases/download/v${pkgver}/wlcs-${pkgver}.tar.xz")
-sha256sums=('7238dd4a0fece16b7eb21db90722795fb68f20e0fcfc82ab01bce5b63ca415d1')
+source=("git+https://github.com/MirServer/wlcs.git")
+sha256sums=('SKIP')
BUILD_DIR=build
build() {
- cd "${pkgname}-${_tardirname}"
+ cd "${pkgname}}"
mkdir -p "${BUILD_DIR}"
cd "${BUILD_DIR}"
cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr -DCMAKE_INSTALL_LIBDIR="lib/" ..
@@ -23,7 +25,7 @@ build() {
}
package() {
- cd "${pkgname}-${_tardirname}/${BUILD_DIR}"
+ cd "${pkgname}/${BUILD_DIR}"
make DESTDIR="${pkgdir}/" install
}