summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Burgos2022-06-28 11:33:21 -0600
committerSam Burgos2022-06-28 11:33:21 -0600
commitb0bb79db6240e1c824afc62a66786b3f836e1903 (patch)
tree926f8853496f6185d5e85b1c704e4171f5100dc8
parentd02e28292443ceba80b67583bac29b66a6f80892 (diff)
downloadaur-b0bb79db6240e1c824afc62a66786b3f836e1903.tar.gz
updated version to point to Linux Mint repositories
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD38
-rw-r--r--linuxmint_gcal_new_calendar_page.patch12
-rw-r--r--linuxmint_gcal_window.patch21
4 files changed, 11 insertions, 72 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f0e2c297f0f..60b05f5372cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = gnome-calendar-linuxmint
- pkgdesc = Simple and beautiful calendar application designed to perfectly fit the GNOME desktop. With Linux Mint patches
+ pkgdesc = Simple and beautiful calendar application designed to perfectly fit the GNOME desktop. (Package from Linux Mint repos)
pkgver = 41.2
pkgrel = 1
- url = https://wiki.gnome.org/Apps/Calendar
+ url = http://packages.linuxmint.com/pool/upstream/g/gnome-calendar
arch = x86_64
groups = gnome
license = GPL
@@ -20,11 +20,7 @@ pkgbase = gnome-calendar-linuxmint
optdepends = evolution: ICS file import
provides = gnome-calendar
conflicts = gnome-calendar
- source = git+https://gitlab.gnome.org/GNOME/gnome-calendar.git#commit=deb9ff18302457b91fb8013f98880c8e3a548c19
- source = linuxmint_gcal_window.patch
- source = linuxmint_gcal_new_calendar_page.patch
- sha256sums = SKIP
- sha256sums = 8ee8805a0d185b9458016c7855f789f849982c68f9c42407504d3144696d825c
- sha256sums = c935e126d9201c37f4b33460ae834c6c4a18c71fd06c2d768480b559a8a92e5f
+ source = gnome-calendar-linuxmint_41.2.tar.xz::http://packages.linuxmint.com/pool/upstream/g/gnome-calendar/gnome-calendar_41.2+mint1+vanessa.tar.xz
+ sha256sums = ebd29c6b19ccc370e4b024247ab9aa925766a7782ddda8076076964c89ffb06f
pkgname = gnome-calendar-linuxmint
diff --git a/PKGBUILD b/PKGBUILD
index 9f34957b2f44..3ce5625d16d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,11 @@
pkgname=gnome-calendar-linuxmint
_pkgname=gnome-calendar
pkgver=41.2
+_pkgver=mint1+vanessa
pkgrel=1
-pkgdesc='Simple and beautiful calendar application designed to perfectly fit the GNOME desktop. With Linux Mint patches'
+pkgdesc='Simple and beautiful calendar application designed to perfectly fit the GNOME desktop. (Package from Linux Mint repos)'
arch=(x86_64)
-url=https://wiki.gnome.org/Apps/Calendar
+url="http://packages.linuxmint.com/pool/upstream/g/${_pkgname}"
license=(GPL)
depends=(
evolution-data-server
@@ -29,39 +30,14 @@ makedepends=(
provides=(${_pkgname})
conflicts=(${_pkgname})
groups=(gnome)
-_commit=deb9ff18302457b91fb8013f98880c8e3a548c19 # tags/41.2^0
-source=(
- "git+https://gitlab.gnome.org/GNOME/gnome-calendar.git#commit=$_commit"
- "linuxmint_gcal_window.patch"
- "linuxmint_gcal_new_calendar_page.patch"
-)
-sha256sums=('SKIP'
- '8ee8805a0d185b9458016c7855f789f849982c68f9c42407504d3144696d825c'
- 'c935e126d9201c37f4b33460ae834c6c4a18c71fd06c2d768480b559a8a92e5f')
-
-pkgver() {
- cd $_pkgname
- git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
-}
-
-prepare() {
- cd $_pkgname
+source=("${pkgname}_${pkgver}.tar.xz::${url}/${_pkgname}_${pkgver}+${_pkgver}.tar.xz")
+sha256sums=('ebd29c6b19ccc370e4b024247ab9aa925766a7782ddda8076076964c89ffb06f')
+
- # Replace GNOME Control Center internal call with Cinnamon Settings (cinnamon-settings online-accounts)
- # Set window icon name
- patch -Np0 -i ../linuxmint_gcal_window.patch
-
- # Replace GNOME Web Description link label with cinnamon-settings online-accounts
- patch -Np0 -i ../linuxmint_gcal_new_calendar_page.patch
-}
build() {
arch-meson $_pkgname build
- meson compile -C build
-}
-
-check() {
- meson test -C build --print-errorlogs
+ meson compile -C meson.build
}
package() {
diff --git a/linuxmint_gcal_new_calendar_page.patch b/linuxmint_gcal_new_calendar_page.patch
deleted file mode 100644
index d7985e7aeff3..000000000000
--- a/linuxmint_gcal_new_calendar_page.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/gui/calendar-management/gcal-new-calendar-page.c
-+++ src/gui/calendar-management/gcal-new-calendar-page.c
-@@ -493,7 +493,7 @@
- {
- GDBusConnection *connection = g_application_get_dbus_connection (g_application_get_default ());
-
-- gcal_utils_launch_online_accounts_panel (connection, NULL, NULL);
-+ g_spawn_command_line_async ("cinnamon-settings online-accounts", NULL);
- }
-
-
-
diff --git a/linuxmint_gcal_window.patch b/linuxmint_gcal_window.patch
deleted file mode 100644
index 50526ae0e7ab..000000000000
--- a/linuxmint_gcal_window.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/gui/gcal-window.c
-+++ src/gui/gcal-window.c
-@@ -486,7 +486,7 @@
- {
- GApplication *application = g_application_get_default ();
-
-- gcal_utils_launch_online_accounts_panel (g_application_get_dbus_connection (application), NULL, NULL);
-+ g_spawn_command_line_async ("cinnamon-settings online-accounts", NULL);
- }
-
- static void
-@@ -1221,6 +1221,8 @@
- gcal_window_add_accelerator (app, "win.change-view(2)", "<Ctrl>3");
- gcal_window_add_accelerator (app, "app.quit", "<Ctrl>q");
- gcal_window_add_accelerator (app, "win.new-event", "<Ctrl>n");
-+
-+ gtk_window_set_icon_name (self, "org.gnome.Calendar");
- }
-
- /**
-