summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlfredo Ramos2017-06-08 10:56:06 -0500
committerAlfredo Ramos2017-06-08 10:56:06 -0500
commitb0cdec5348cd27af79abda15994b0fddb990fb9e (patch)
tree53796f54540ff966a564a441b8b3fa14c81ed42f
parent3bb19c5b8ca0d3c126a7925d8a61b5df4335b228 (diff)
downloadaur-b0cdec5348cd27af79abda15994b0fddb990fb9e.tar.gz
Fix PythonQt detection
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
-rw-r--r--fix_pythonqt.patch24
3 files changed, 40 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2891e1e3f3dd..3eed3211538f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = screencloud-git
pkgdesc = An easy to use screenshot sharing tool. Development version.
pkgver = 1.3.1.3.g74724ca
- pkgrel = 3
+ pkgrel = 4
url = https://screencloud.net/
arch = i686
arch = x86_64
@@ -20,7 +20,9 @@ pkgbase = screencloud-git
provides = screencloud=1.3.1.3.g74724ca
conflicts = screencloud
source = git+https://github.com/olav-st/screencloud.git
+ source = fix_pythonqt.patch
sha512sums = SKIP
+ sha512sums = f953f57e21db580c299f48fb1b02452ee7bd612701ead112ad05a42a531fe07e3207569135ec91a8895b57481607ccfd429aa7fa4336b122d7bcf71f1b88f316
pkgname = screencloud-git
diff --git a/PKGBUILD b/PKGBUILD
index 840b0b14bd86..1831f2e265bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=screencloud
pkgname=${_pkgname}-git
pkgver=1.3.1.3.g74724ca
-pkgrel=3
+pkgrel=4
pkgdesc='An easy to use screenshot sharing tool. Development version.'
arch=('i686' 'x86_64')
url='https://screencloud.net/'
@@ -20,8 +20,14 @@ makedepends=('cmake' 'git' 'qt5-tools')
provides=("${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
-source=("git+https://github.com/olav-st/${_pkgname}.git")
-sha512sums=('SKIP')
+source=(
+ "git+https://github.com/olav-st/${_pkgname}.git"
+ 'fix_pythonqt.patch'
+)
+sha512sums=(
+ 'SKIP'
+ 'f953f57e21db580c299f48fb1b02452ee7bd612701ead112ad05a42a531fe07e3207569135ec91a8895b57481607ccfd429aa7fa4336b122d7bcf71f1b88f316'
+)
pkgver() {
# Updating package version
@@ -32,6 +38,10 @@ pkgver() {
prepare() {
# Create build directory
mkdir -p "${srcdir}"/build
+
+ # Fix PythonQt detection
+ cd "${srcdir}"/${_pkgname}
+ patch -Np1 < ../fix_pythonqt.patch
}
build() {
diff --git a/fix_pythonqt.patch b/fix_pythonqt.patch
new file mode 100644
index 000000000000..3fdc483460cb
--- /dev/null
+++ b/fix_pythonqt.patch
@@ -0,0 +1,24 @@
+diff -uprNEBZ --suppress-blank-empty a/cmake/modules/FindPythonQt.cmake b/cmake/modules/FindPythonQt.cmake
+--- a/cmake/modules/FindPythonQt.cmake 2017-06-08 10:41:37.661363000 -0500
++++ b/cmake/modules/FindPythonQt.cmake 2017-06-08 10:43:09.778030233 -0500
+@@ -5,7 +5,7 @@
+
+ find_path(PYTHONQT_INSTALL_DIR include/PythonQt/PythonQt.h DOC "Directory where PythonQt was installed.")
+ find_path(PYTHONQT_INCLUDE_DIR PythonQt.h "${PYTHONQT_INSTALL_DIR}/include/PythonQt" DOC "Path to the PythonQt include directory")
+-find_library(PYTHONQT_LIBRARY NAMES PythonQt QtPython PATHS "${PYTHONQT_INSTALL_DIR}/lib" DOC "The PythonQt library.")
++find_library(PYTHONQT_LIBRARY NAMES PythonQt QtPython PythonQt-Qt5-Python3 PATHS "${PYTHONQT_INSTALL_DIR}/lib" DOC "The PythonQt library.")
+
+ mark_as_advanced(PYTHONQT_INSTALL_DIR)
+ mark_as_advanced(PYTHONQT_INCLUDE_DIR)
+diff -uprNEBZ --suppress-blank-empty a/cmake/modules/FindPythonQt_QtAll.cmake b/cmake/modules/FindPythonQt_QtAll.cmake
+--- a/cmake/modules/FindPythonQt_QtAll.cmake 2017-06-08 10:41:37.661363000 -0500
++++ b/cmake/modules/FindPythonQt_QtAll.cmake 2017-06-08 10:44:16.514697198 -0500
+@@ -6,7 +6,7 @@
+
+ find_path(PYTHONQT_QTALL_INSTALL_DIR NAMES include/PythonQt/PythonQt_QtAll.h include/PythonQt/extensions/PythonQt_QtAll/PythonQt_QtAll.h DOC "Directory where PythonQt_QtAll.h was installed.")
+ find_path(PYTHONQT_QTALL_INCLUDE_DIR PythonQt_QtAll.h PATHS "${PYTHONQT_QTALL_INSTALL_DIR}/include/PythonQt" "${PYTHONQT_QTALL_INSTALL_DIR}/include/PythonQt/extensions/PythonQt_QtAll" ${CMAKE_INCLUDE_PATH} ${CMAKE_INSTALL_PREFIX}/include ${CMAKE_INSTALL_PREFIX}/include/PythonQt ${CMAKE_INSTALL_PREFIX}/include/PythonQt/extensions/PythonQt_QtAll DOC "Path to the PythonQt_QtAll include directory")
+-find_library(PYTHONQT_QTALL_LIBRARY NAMES PythonQt_QtAll QtPython_QtAll PATHS "${PYTHONQT_QTALL_INSTALL_DIR}/extensions/PythonQt_QtAll" DOC "The PythonQt_QtAll library.")
++find_library(PYTHONQT_QTALL_LIBRARY NAMES PythonQt_QtAll QtPython_QtAll PythonQt_QtAll-Qt5-Python3 PATHS "${PYTHONQT_QTALL_INSTALL_DIR}/extensions/PythonQt_QtAll" DOC "The PythonQt_QtAll library.")
+
+ mark_as_advanced(PYTHONQT_QTALL_INSTALL_DIR)
+ mark_as_advanced(PYTHONQT_QTALL_INCLUDE_DIR)