summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2019-11-03 22:53:05 -0500
committerChris Severance2019-11-03 22:53:05 -0500
commitb0d380c7da5cfae6d9b0b5d5edc7a674c8d074ee (patch)
treea903c2413d5430d4b04c19b67d831be93aa26c6c
parentdf925d3e8925a193f4a241cab5ddc517cff985fd (diff)
downloadaur-b0d380c7da5cfae6d9b0b5d5edc7a674c8d074ee.tar.gz
autu: Update to 2.2.1-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 15 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c538e0db28e..13a9d9f1e398 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,17 @@
# Generated by mksrcinfo v8
-# Thu Jul 13 20:23:14 UTC 2017
+# Mon Nov 4 03:53:05 UTC 2019
pkgbase = iscan-plugin-gt-x820
pkgdesc = iscan plugin for Epson Colorio GT-X820 Perfection V600 Photo scanners
- pkgver = 2.2.0_1
+ pkgver = 2.2.1
pkgrel = 1
url = http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
install = gt-x820.install
- arch = i686
arch = x86_64
license = custom
depends = iscan>=2.21
- source = http://support.epson.net/linux/src/scanner/iscan/iscan-data_1.36.0-1.dsc
- sha256sums = 07a7cd6ec4b6618222cef71d2d76268e785b816b12038133d787e79ee98ebba0
- source_i686 = https://download2.ebz.epson.net/iscan/plugin/gt-x820/rpm/x86/iscan-gt-x820-bundle-1.0.1.x86.rpm.tar.gz
- sha256sums_i686 = 87c009a6ff4fa33c46a0990d92152dc63f3261958eb168b4b7a69828554512ce
- source_x86_64 = https://download2.ebz.epson.net/iscan/plugin/gt-x820/rpm/x64/iscan-gt-x820-bundle-1.0.1.x64.rpm.tar.gz
- sha256sums_x86_64 = 4f053966fb14f1b4e2e8b593891c02ec10c20cd22f941852609658d90082f4a9
+ source = https://download2.ebz.epson.net/iscan/plugin/gt-x820/rpm/x64/iscan-gt-x820-bundle-2.30.4.x64.rpm.tar.gz
+ md5sums = aeed0eb08f5e529ff6fd8e8908312e82
+ sha256sums = 3412ad0a6821e6e36091087e69c6e7d2506c002e51522db9b33066475cefa682
pkgname = iscan-plugin-gt-x820
diff --git a/PKGBUILD b/PKGBUILD
index 109755ba9d21..dfad041a8aae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,26 @@
# Contributor: untitled
# Contributor: mh00h
# Contributor: Frank Phillips <frankalso[at]gmail[dot]com>
+# Contributor: Mr.Elendig
set -u
pkgname='iscan-plugin-gt-x820'
-pkgver='2.2.0_1'; _bundlever='1.0.1'
+pkgver='2.2.1'; _bundlever='2.30.4'
pkgrel='1'
pkgdesc='iscan plugin for Epson Colorio GT-X820 Perfection V600 Photo scanners'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX'
license=('custom')
depends=('iscan>=2.21')
install='gt-x820.install'
-declare -gA _archf=([i686]='x86' [x86_64]='x64')
-source=('http://support.epson.net/linux/src/scanner/iscan/iscan-data_1.36.0-1.dsc') # dummy file to fill source array
-source_x86_64=("https://download2.ebz.epson.net/iscan/plugin/gt-x820/rpm/x64/iscan-gt-x820-bundle-${_bundlever}.x64.rpm.tar.gz")
-source_i686=("https://download2.ebz.epson.net/iscan/plugin/gt-x820/rpm/x86/iscan-gt-x820-bundle-${_bundlever}.x86.rpm.tar.gz")
-sha256sums=('07a7cd6ec4b6618222cef71d2d76268e785b816b12038133d787e79ee98ebba0')
-sha256sums_i686=('87c009a6ff4fa33c46a0990d92152dc63f3261958eb168b4b7a69828554512ce')
-sha256sums_x86_64=('4f053966fb14f1b4e2e8b593891c02ec10c20cd22f941852609658d90082f4a9')
+source=("https://download2.ebz.epson.net/iscan/plugin/gt-x820/rpm/x64/iscan-gt-x820-bundle-${_bundlever}.x64.rpm.tar.gz")
+md5sums=('aeed0eb08f5e529ff6fd8e8908312e82')
+sha256sums=('3412ad0a6821e6e36091087e69c6e7d2506c002e51522db9b33066475cefa682')
prepare() {
set -u
- cd "iscan-gt-x820-bundle-${_bundlever}.${_archf[${CARCH}]}.rpm/plugins"
- declare -A _arch=([i686]='i386' [x86_64]='x86_64')
- bsdtar -xf "iscan-plugin-gt-x820-${pkgver//_/-}.${_arch[${CARCH}]}.rpm"
+ cd "iscan-gt-x820-bundle-${_bundlever}.x64.rpm/plugins"
+ bsdtar -xf "iscan-plugin-gt-x820-${pkgver}-1.x86_64.rpm"
if [ -d "usr/lib64" ]; then
mv 'usr/lib64' 'usr/lib'
fi
@@ -35,9 +31,9 @@ prepare() {
package() {
set -u
- cd "iscan-gt-x820-bundle-${_bundlever}.${_archf[${CARCH}]}.rpm/plugins"
+ cd "iscan-gt-x820-bundle-${_bundlever}.x64.rpm/plugins"
mv 'usr' "${pkgdir}"
- install -Dpm644 "${pkgdir}/usr/share/doc/${pkgname}-${pkgver%%_*}"/* -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dpm644 "${pkgdir}/usr/share/doc/${pkgname}-${pkgver}"/* -t "${pkgdir}/usr/share/licenses/${pkgname}/"
rm -r "${pkgdir}/usr/share/doc"
set +u
}