summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTiago Nascimento2019-07-09 07:58:23 +0000
committerTiago Nascimento2019-07-09 07:58:23 +0000
commitb0f7e95ff694c274dd484763234126b480b6f0c1 (patch)
tree2b929c3b8d6e875f95ad896379c0515a85f04a27
downloadaur-b0f7e95ff694c274dd484763234126b480b6f0c1.tar.gz
created package for lalrpop syntax on vim
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb8cf59ba409
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vim-lalrpop-git
+ pkgdesc = LALRPOP Vim plugin with minimal syntax-highlighting functionality.
+ pkgver = r2.7073eec
+ pkgrel = 1
+ url = https://github.com/qnighy/lalrpop.vim
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ license = APACHE
+ makedepends = git
+ depends = vim
+ depends = vim-rust-git
+ provides = vim-lalrpop
+ conflicts = vim-lalrpop
+ source = git+https://github.com/qnighy/vim-lalrpop.git
+ md5sums = SKIP
+
+pkgname = vim-lalrpop-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9e9a960074f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: xtheosirian <https://aur.archlinux.org/account/xtheosirian>
+
+pkgname=vim-lalrpop-git
+pkgver=r2.7073eec
+pkgrel=1
+pkgdesc="LALRPOP Vim plugin with minimal syntax-highlighting functionality."
+arch=('any')
+url='https://github.com/qnighy/lalrpop.vim'
+license=('MIT' 'APACHE')
+depends=('vim' 'vim-rust-git')
+makedepends=('git')
+conflicts=('vim-lalrpop')
+provides=('vim-lalrpop')
+groups=('vim-plugins')
+source=("git+https://github.com/qnighy/${pkgname%-git}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${pkgname%-git}"
+ _installpath="${pkgdir}/usr/share/vim/vimfiles"
+ mkdir -p "${_installpath}"
+ cp -r ftdetect syntax "${_installpath}"
+ install -D -m644 LICENSE-MIT "$pkgdir/usr/share/licenses/$pkgname/LICENSE-MIT"
+ install -D -m644 LICENSE-APACHE "$pkgdir/usr/share/licenses/$pkgname/LICENSE-APACHE"
+}