summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2020-11-13 23:54:58 +1100
committerPumpkinCheshire2020-11-13 23:54:58 +1100
commitb11999f07b27f280c0b0c3290e9df9e96e252eab (patch)
tree8e15d758600104c3503d6b58f4218f1b17786541
parente417f3c030b24b3cf448d27419a8232d56d05006 (diff)
downloadaur-b11999f07b27f280c0b0c3290e9df9e96e252eab.tar.gz
bumping to 2.0.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aeae19854dfe..d82a89d5ad86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
-# Generated by mksrcinfo v8
-# Wed Apr 27 04:51:27 UTC 2016
pkgbase = python-lda
- pkgdesc = Topic modeling with latent Dirichlet allocation
- pkgver = 1.0.3
- pkgrel = 2
- url = https://github.com/ariddell/lda/
+ pkgdesc = Topic modeling with latent Dirichlet allocation using Gibbs sampling
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/lda-project/lda
arch = i686
arch = x86_64
- license = MPLv2
+ license = custom:MPLv2
makedepends = python-setuptools
depends = python
depends = python-numpy
depends = python-pbr
- source = http://pypi.python.org/packages/source/l/lda/lda-1.0.3.tar.gz
- md5sums = 17efa4f18d1aa5b08997db709d7ab068
+ source = https://files.pythonhosted.org/packages/source/l/lda/lda-2.0.0.tar.gz
+ sha256sums = d8d7c0bc42208902a9e34261b76793a84f59e6c69cfd7ca12ce982cdaf7c3020
pkgname = python-lda
diff --git a/PKGBUILD b/PKGBUILD
index 9b2e7b564722..6a0e819db952 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
-# Maintainer wicastC <wicastchen at hotmail dot com>
+# Maintainer: pumpkincheshire <sollyonzou@gmail.com>
+# Contributor wicastC <wicastchen at hotmail dot com>
pkgname=python-lda
_name=lda
-pkgver=1.0.3
-pkgrel=2
-pkgdesc="Topic modeling with latent Dirichlet allocation"
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Topic modeling with latent Dirichlet allocation using Gibbs sampling"
arch=("i686" "x86_64")
-url="https://github.com/ariddell/lda/"
-license=(MPLv2)
+url="https://github.com/lda-project/lda"
+license=('custom:MPLv2')
depends=("python" "python-numpy" "python-pbr")
makedepends=("python-setuptools")
-source=("http://pypi.python.org/packages/source/l/${_name}/${_name}-${pkgver}.tar.gz")
-md5sums=("17efa4f18d1aa5b08997db709d7ab068")
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('d8d7c0bc42208902a9e34261b76793a84f59e6c69cfd7ca12ce982cdaf7c3020')
build() {
- cd "${srcdir}/${_name}-${pkgver}"
+ cd "$_name-$pkgver"
python setup.py build
}
package() {
- msg "Install..."
- cd "${srcdir}/${_name}-${pkgver}"
- python setup.py install --root="${pkgdir}" || return 1
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ # install -Dm644 $scrdir/README* "${pkgdir}/usr/share/doc/${pkgname}/README"
}