summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2022-07-20 21:08:25 +0200
committerMario Finelli2022-07-20 21:08:25 +0200
commitb1576e51613a89ec07b7c53e31789fd78d46b040 (patch)
treecb25ed3eec1f9b3615487a18b3da629aa05a1616
parentc75f0eb17062ddcb14b3c3f1dbd96a301de3a97f (diff)
downloadaur-b1576e51613a89ec07b7c53e31789fd78d46b040.tar.gz
upgpkg: helm-gcs 0.3.22-1
upstream release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d087d968463c..d97ef27aa5ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = helm-gcs
pkgdesc = Helm plugin to manage chart repositories on GCS
- pkgver = 0.3.21
+ pkgver = 0.3.22
pkgrel = 1
url = https://github.com/hayorov/helm-gcs
install = helm-gcs.install
@@ -9,7 +9,7 @@ pkgbase = helm-gcs
makedepends = go
depends = bash
depends = helm
- source = https://github.com/hayorov/helm-gcs/archive/0.3.21/helm-gcs-0.3.21.tar.gz
- sha256sums = 8faa8afdc68b87397fe31b1700a4370919f15d732106fd10bdfa8722f6752768
+ source = https://github.com/hayorov/helm-gcs/archive/0.3.22/helm-gcs-0.3.22.tar.gz
+ sha256sums = 3a9938e11813d57cadbdff987470a00aa113eed82238a0267e1838a833c544e8
pkgname = helm-gcs
diff --git a/PKGBUILD b/PKGBUILD
index 6c056f3cd35f..4aab616ede9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mario Finelli <mario at finel dot li>
pkgname=helm-gcs
-pkgver=0.3.21
+pkgver=0.3.22
pkgrel=1
pkgdesc="Helm plugin to manage chart repositories on GCS"
arch=(x86_64)
@@ -11,17 +11,18 @@ install=helm-gcs.install
depends=(bash helm)
makedepends=(go)
source=("https://github.com/hayorov/helm-gcs/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('8faa8afdc68b87397fe31b1700a4370919f15d732106fd10bdfa8722f6752768')
+sha256sums=('3a9938e11813d57cadbdff987470a00aa113eed82238a0267e1838a833c544e8')
prepare() {
cd "${pkgname}-${pkgver}"
- go mod tidy # upstream released a dirty mod file; remove on next release
+ export GOPATH="${srcdir}/gopath"
go mod download
sed -i '/^hooks:$/Q' plugin.yaml
}
build() {
cd "${pkgname}-${pkgver}"
+ export GOPATH="${srcdir}/gopath"
export CGO_LDFLAGS="$LDFLAGS"
export CGO_CFLAGS="$CFLAGS"
export CGO_CPPFLAGS="$CPPFLAGS"