summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-11-14 01:31:53 +0100
committerDaniel Peukert2023-11-14 01:31:53 +0100
commitb16a44703df138edd830a2db31f8adc1b3cf318e (patch)
tree6e88cb72124e8d3a42e999a0d1eee2d6eff57574
parenta9d902a542721190a801adf89e57a6880db830de (diff)
downloadaur-b16a44703df138edd830a2db31f8adc1b3cf318e.tar.gz
Fix dolphin-emu-git build
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD8
3 files changed, 21 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4069fd6072aa..65d46a4a8ee3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dolphin-emu-git
pkgdesc = A Gamecube / Wii emulator
- pkgver = 5.0.r20135.gc67cd65b53
+ pkgver = 5.0.r20339.g87c27936fc
pkgrel = 1
url = https://dolphin-emu.org
arch = x86_64
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..004b0a3a8706 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index 05900e374211..d8240e3e16da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ _mainpkgname="$_projectname-emu"
_noguipkgname="$_projectname-emu-nogui"
pkgbase="$_mainpkgname-git"
pkgname=("$pkgbase" "$_noguipkgname-git")
-pkgver='5.0.r20135.gc67cd65b53'
+pkgver='5.0.r20339.g87c27936fc'
pkgrel='1'
pkgdesc='A Gamecube / Wii emulator'
_pkgdescappend=' - git version'
@@ -72,10 +72,14 @@ pkgver() {
}
build() {
+ cd "$srcdir/$_sourcedirectory/"
+
+ # Consider symbols in dependencies of directly specified dynamic libraries as available to fix the build
+ export LDFLAGS="-Wl,--copy-dt-needed-entries"
+
# CMAKE_BUILD_TYPE - the dolphin-emu package in the repos uses 'None' for some reason, so we use it as well
# USE_SYSTEM_LIBS - we want to use system libs where possible
# USE_SYSTEM_LIBMGBA - the current version of mgba in the repos is not compatible with Dolphin
- cd "$srcdir/$_sourcedirectory/"
cmake -S '.' -B 'build/' -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX='/usr' \