summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAman Gupta2023-10-17 14:03:57 +0530
committerAman Gupta2023-10-17 14:03:57 +0530
commitb18a965d8acb20c18777fee74db6f68249abfc85 (patch)
tree2790ddb2b24f891c082e6b911e0a0b0cb58282d2
parent0b53a3f5955e4a2e2c114d69501a4097f1d5e97c (diff)
downloadaur-b18a965d8acb20c18777fee74db6f68249abfc85.tar.gz
v1.21.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 689e9abbd241..092cc1eb25b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = micropython
pkgdesc = Python3 for microcontrollers, with stdlib. (UNIX version)
- pkgver = 1.20.0
+ pkgver = 1.21.0
pkgrel = 1
url = http://micropython.org/
arch = i686
@@ -13,10 +13,10 @@ pkgbase = micropython
depends = libffi
depends = mbedtls
options = !emptydirs
- source = https://micropython.org/resources/source/micropython-1.20.0.tar.xz
- source = mlib-1.20.0.tgz::https://github.com/micropython/micropython-lib/archive/v1.20.0.tar.gz
- md5sums = 5e2b9cc096899229071df13fd60c2c00
- md5sums = 46c70ff75634957954d0b2d199e47f22
+ source = https://micropython.org/resources/source/micropython-1.21.0.tar.xz
+ source = mlib-1.21.0.tgz::https://github.com/micropython/micropython-lib/archive/v1.21.0.tar.gz
+ md5sums = 7f3ec4862c47f83883868c8b7fdbff40
+ md5sums = 2b5a111d61611786fade0059fcfef203
pkgname = micropython
diff --git a/PKGBUILD b/PKGBUILD
index bcf019f9e649..1088885dc7a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Aman Gupta <aman.iv0012@gmail.com>
pkgbase=micropython
pkgname=(micropython micropython-lib)
-pkgver=1.20.0
-_libver=1.20.0
+pkgver=1.21.0
+_libver=1.21.0
pkgrel=1
pkgdesc="Python3 for microcontrollers, with stdlib. (UNIX version)"
arch=('i686' 'x86_64')
@@ -14,8 +14,8 @@ options=('!emptydirs')
# They finally have a real release, without all the submodule garbage.
source=("https://micropython.org/resources/source/micropython-$pkgver.tar.xz"
"mlib-$_libver.tgz::https://github.com/micropython/micropython-lib/archive/v$_libver.tar.gz")
-md5sums=('5e2b9cc096899229071df13fd60c2c00'
- '46c70ff75634957954d0b2d199e47f22')
+md5sums=('7f3ec4862c47f83883868c8b7fdbff40'
+ '2b5a111d61611786fade0059fcfef203')
# todo:
# fix 'imported as namespace package' warnings from stdlib