summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiachen Yang2015-08-10 19:23:35 +0900
committerJiachen Yang2015-08-10 19:23:35 +0900
commitb1a2a911ef58b5ceca906d04018caac39da0aebf (patch)
tree1aa2c2548e59251bf12677da68f3ae625fd4fd7c
downloadaur-b1a2a911ef58b5ceca906d04018caac39da0aebf.tar.gz
takeover glmark2
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD26
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51dcdab9909e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = glmark2
+ pkgdesc = OpenGL (ES) 2.0 benchmark
+ pkgver = 2014.03
+ pkgrel = 1
+ url = https://launchpad.net/glmark2
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = zlib
+ license = custom
+ depends = libjpeg-turbo
+ depends = libpng12
+ depends = libx11
+ depends = libxcb
+ depends = libgl
+ depends = python2
+ source = https://launchpad.net/glmark2/trunk/2014.03/+download/glmark2-2014.03.tar.gz
+ md5sums = 739859cf57d4c8a23452c43e84f66e56
+
+pkgname = glmark2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00ec206cd944
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: farseerfc <farseerfc@gmail.com>
+
+pkgname=glmark2
+pkgver=2014.03
+pkgrel=1
+pkgdesc="OpenGL (ES) 2.0 benchmark"
+arch=('i686' 'x86_64')
+url="https://launchpad.net/glmark2"
+license=('GPL' 'zlib' 'custom')
+groups=()
+depends=('libjpeg-turbo' 'libpng12' 'libx11' 'libxcb' 'libgl' 'python2')
+makedepends=()
+optdepends=()
+source=(https://launchpad.net/glmark2/trunk/$pkgver/+download/$pkgname-$pkgver.tar.gz)
+md5sums=('739859cf57d4c8a23452c43e84f66e56')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 ./waf configure --prefix=/usr --with-flavors x11-gl,x11-glesv2
+ python2 ./waf
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 ./waf install --destdir="$pkgdir/"
+}