summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Riegert2021-06-18 20:08:31 -0400
committerMichael Riegert2021-06-18 20:08:31 -0400
commitb1d93c656cef82713cf50abae7c7221293032a5b (patch)
tree4c2edd33f03aa7a2f670bbedb361455a84da22b8
parentc14dd5e33b98d9681eb0784bc8c92d9ba734d659 (diff)
downloadaur-b1d93c656cef82713cf50abae7c7221293032a5b.tar.gz
add inkscape dependency
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 064e86d091ce..6dedda6d13ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nextcloud-client-git
pkgdesc = Nextloud client for linux
- pkgver = 3.2.2.959e450d6
+ pkgver = 3.2.2.636e7159c
pkgrel = 1
url = https://nextcloud.com/
arch = i686
@@ -23,6 +23,7 @@ pkgbase = nextcloud-client-git
depends = qt5-graphicaleffects
depends = qt5-quickcontrols2
depends = qt5-websockets
+ depends = inkscape
optdepends = kio: integration with Dolphin
optdepends = nemo-python: integration with Nemo
optdepends = python-nautilus: integration with Nautilus
diff --git a/PKGBUILD b/PKGBUILD
index 52ad7a9d40d3..59412f875b72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=nextcloud-client-git
_name=${pkgname/\-git/}
-pkgver=3.2.2.959e450d6
+pkgver=3.2.2.636e7159c
pkgrel=1
pkgdesc="Nextloud client for linux"
arch=('i686' 'x86_64')
url="https://nextcloud.com/"
license=('GPL2')
depends=(openssl sqlite qtkeychain qt5-svg qt5-webengine xdg-utils qt5-webkit
- libcloudproviders qt5-graphicaleffects qt5-quickcontrols2 qt5-websockets)
+ libcloudproviders qt5-graphicaleffects qt5-quickcontrols2 qt5-websockets inkscape)
makedepends=(doxygen extra-cmake-modules python-sphinx qt5-tools git cmocka)
optdepends=(
'kio: integration with Dolphin'
@@ -25,12 +25,12 @@ source=("${_name}::git+https://github.com/nextcloud/desktop.git")
sha256sums=('SKIP')
pkgver() {
- cd ${_name}
+ cd ${srcdir}/${_name}
echo $(git describe --tags $(git rev-list --tags --max-count=1) | sed 's/v//g;s/-/./g').$(git rev-parse --short HEAD)
}
prepare() {
- cd ${_name}
+ cd ${srcdir}/${_name}
if [[ -n "${_version}" ]]; then
git checkout "v${_version}"
fi
@@ -39,7 +39,7 @@ prepare() {
}
build() {
- cd ${_name}/build
+ cd ${srcdir}/${_name}/build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_BUILD_TYPE="Release" \