summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlsf2021-10-10 12:41:32 +0200
committerlsf2021-10-10 12:41:32 +0200
commitb1e30b9cf5ca00ea9d05a550aaf2e70cb0f537c0 (patch)
treee82d35901bb22257ae288aa3556e6b3055c0e3e8
parentb87c666acdd1b4f6e7cd26f81da0927ca55e654c (diff)
downloadaur-b1e30b9cf5ca00ea9d05a550aaf2e70cb0f537c0.tar.gz
fix prococ-gen-go/-grpc install
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc21259a430c..24e37909bc19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = opensnitch-git
pkgdesc = A GNU/Linux port of the Little Snitch application firewall
- pkgver = 1.4.0.r3.c66d5d6
+ pkgver = 1.4.0.r20.9ef64da
pkgrel = 1
url = https://github.com/evilsocket/opensnitch
install = opensnitch.install
diff --git a/PKGBUILD b/PKGBUILD
index 463f1ce74f62..c353b504fd07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: lsf
# Contributor: Adam Hose <adis@blad.is>
pkgname=opensnitch-git
-pkgver=1.4.0.r3.c66d5d6
+pkgver=1.4.0.r20.9ef64da
pkgrel=1
pkgdesc="A GNU/Linux port of the Little Snitch application firewall"
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
@@ -38,7 +38,6 @@ prepare() {
build() {
cd "$srcdir/${pkgname%-git}"
- pushd proto
export GOPATH="$srcdir/gopath"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
@@ -46,7 +45,9 @@ build() {
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=mod"
export PATH=${PATH}:${GOPATH}/bin
- go get github.com/golang/protobuf/protoc-gen-go
+ go install github.com/golang/protobuf/protoc-gen-go@latest
+ go install google.golang.org/grpc/cmd/protoc-gen-go-grpc@latest
+ pushd proto
make
popd