summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThePuzzlemaker2020-04-04 18:57:59 -0500
committerThePuzzlemaker2020-04-04 18:57:59 -0500
commitb1f53c1d6f1d66dc9193d19571e24a4ca71bd51d (patch)
tree759db70889ecbf4d03367f8b049b1c2774d9d9f0
parentca8f7ded878a64f9e6bba93a042440fa80ff2a73 (diff)
downloadaur-b1f53c1d6f1d66dc9193d19571e24a4ca71bd51d.tar.gz
Initial adoption commit
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD29
2 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a3a3ae499d0..b6ce5a646a5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zmqpp-git
- pkgdesc = ZMQPP's latest version
- pkgver = 1
+ pkgdesc = ZMQPP's git 'develop' branch
+ pkgver = 4.2.git040420
pkgrel = 1
url = https://github.com/zeromq/zmqpp
arch = x86_64
@@ -8,7 +8,8 @@ pkgbase = zmqpp-git
depends = libsodium
depends = zeromq
provides = libzmqpp
- source = git+https://github.com/zeromq/zmqpp#commit=7f099a8dba534661c69db32e31e13f06f34ad6bc
+ conflicts = zmqpp
+ source = git+https://github.com/zeromq/zmqpp#commit=85ae96020f2376c53d2176e04e88e8e51021b748
md5sums = SKIP
pkgname = zmqpp-git
diff --git a/PKGBUILD b/PKGBUILD
index 44485da9c991..cd6bdf5faf96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,39 @@
-# Maintainer: Yuhanun Citgez <y dot citgez at student dot utwente dot nl>
+# Maintainer: ThePuzzlemaker <tpzker at thepuzzlemaker dot info>
pkgname=zmqpp-git
-pkgver=1
+pkgver=4.2.git040420
pkgrel=1
-commit_hash=7f099a8dba534661c69db32e31e13f06f34ad6bc
-pkgdesc="ZMQPP's latest version"
+commit_hash=85ae96020f2376c53d2176e04e88e8e51021b748
+pkgdesc="ZMQPP's git 'develop' branch"
arch=('x86_64')
url='https://github.com/zeromq/zmqpp'
licence=('MIT')
depends=('libsodium' 'zeromq')
makedepends=('make')
provides=('libzmqpp')
+conflicts=("zmqpp")
source=("git+$url#commit=$commit_hash")
md5sums=('SKIP')
prepare() {
cd zmqpp
git submodule update --init --recursive
+ PKGDIR_ESCAPE=$(echo "${pkgdir}" | sed 's/\//\\\//g')
+ sed -i "s/\/usr\/local/${PKGDIR_ESCAPE}\/usr/g" Makefile
}
build() {
cd zmqpp
make
+ make client
}
-# check() {
-# make check
-# }
-
package() {
- cd zmqpp/build/max-g++
- mkdir -p "${pkgdir}"/opt/zmqpp-git
- install -Dm666 libzmqpp.a "${pkgdir}/opt/zmqpp-git/libzmqpp.a"
-
- mkdir -p "${pkgdir}/usr/lib"
- ln -s /opt/zmqpp-git/libzmqpp.a "${pkgdir}/usr/lib/libzmqpp.a"
+ cd zmqpp
+ make install
+ # basic fix to #237, I sent a PR to fix it in the makefile
+ cd "${pkgdir}/usr"
+ mv bin zmqpp
+ mkdir -p bin
+ mv zmqpp bin
}