summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKookies2021-08-09 16:31:47 -0600
committerKookies2021-08-09 16:31:47 -0600
commitb205975b45297d5f51f2d22885ba81f7aed23f99 (patch)
tree49e9351bcf0f84f106b3e99eb4932e5399f13756
downloadaur-b205975b45297d5f51f2d22885ba81f7aed23f99.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07af77c482c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nfs2iso2nfs-git
+ pkgdesc = convert nfs files to iso and back (git version)
+ pkgver = v0.5.6
+ pkgrel = 1
+ url = https://github.com/FIX94/nfs2iso2nfs
+ arch = x86_64
+ license = unknown
+ makedepends = git
+ depends = mono
+ provides = nfs2iso2nfs
+ conflicts = nfs2iso2nfs
+ source = git+https://github.com/FIX94/nfs2iso2nfs.git
+ md5sums = SKIP
+
+pkgname = nfs2iso2nfs-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16f980560ecd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Kookies <kookies@tutamail.com>
+
+pkgname=nfs2iso2nfs-git
+_gitname="nfs2iso2nfs"
+pkgver=v0.5.6
+pkgrel=1
+pkgdesc="convert nfs files to iso and back (git version)"
+arch=('x86_64')
+url="https://github.com/FIX94/nfs2iso2nfs"
+license=('unknown')
+depends=('mono')
+makedepends=('git')
+provides=("$_gitname")
+conflicts=("$_gitname")
+source=('git+https://github.com/FIX94/nfs2iso2nfs.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ git describe --tags
+}
+
+build() {
+ cd $_gitname
+ mcs Program.cs -out:$_gitname
+}
+
+package() {
+ cd $_gitname
+ install -Dm755 $_gitname "${pkgdir}/usr/bin/$_gitname"
+}