summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2021-05-17 06:19:40 +0000
committerBalló György2021-05-17 06:19:40 +0000
commitb23001cdf211eb4051c65ffa2b82c851d07fe8a3 (patch)
tree354f57a7b25a9c83517557ea5600ebde224f98e0
parent58c31b366c82885d278dde66b6a899cf108814da (diff)
downloadaur-b23001cdf211eb4051c65ffa2b82c851d07fe8a3.tar.gz
Cleanup and update
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
2 files changed, 19 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee07dc7e0029..668a57f6c339 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,18 @@
pkgbase = jammr
- pkgdesc = jammr lets you play with musicians over the internet
- pkgver = 1.2.8
+ pkgdesc = Lets you jam together online. It is possible to play jam sessions with musicians around the world over the internet
+ pkgver = 1.3.1
pkgrel = 1
url = https://www.jammr.net/
- arch = i686
arch = x86_64
license = GPL2
- makedepends = qt5-base
- makedepends = portmidi
- depends = libvorbis
+ depends = hicolor-icon-theme
depends = libogg
- depends = libstdc++296
+ depends = libvorbis
depends = portaudio
depends = portmidi
- depends = qt5-base
- options = !emptydirs
- source = https://github.com/wahjam/wahjam/archive/jammr-1.2.8.tar.gz
- sha512sums = 1172681298275118bd58a469d57df07fb080d43b7e7bc6712a1061ae1d21520b6e9cb99e6671b6590f3721a3c8aaecb5c1869a37e92a4a64a161bb3289657ce0
+ depends = qtkeychain-qt5
+ source = https://github.com/wahjam/wahjam/archive/1.3.1/jammr-1.3.1.tar.gz
+ sha256sums = 0544dd31ecd12ebcbf36069a46f686e626f2e1f6f1f1195097a2f13f1e4e8ded
pkgname = jammr
diff --git a/PKGBUILD b/PKGBUILD
index e14031cab317..dc5936b37f2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,23 @@
# Maintainer: Augustin deMayo <gus.demayo@gmail.com>
pkgname=jammr
-pkgver=1.2.8
+pkgver=1.3.1
pkgrel=1
-pkgdesc="jammr lets you play with musicians over the internet"
-arch=("i686" "x86_64")
-url="https://www.jammr.net/"
-license=("GPL2")
-depends=("libvorbis" "libogg" "libstdc++296" "portaudio" "portmidi" "qt5-base")
-makedepends=("qt5-base" "portmidi")
-options=("!emptydirs")
-source=("https://github.com/wahjam/wahjam/archive/${pkgname}-${pkgver}.tar.gz")
-sha512sums=('1172681298275118bd58a469d57df07fb080d43b7e7bc6712a1061ae1d21520b6e9cb99e6671b6590f3721a3c8aaecb5c1869a37e92a4a64a161bb3289657ce0')
+pkgdesc="Lets you jam together online. It is possible to play jam sessions with musicians around the world over the internet"
+arch=('x86_64')
+url='https://www.jammr.net/'
+license=('GPL2')
+depends=('hicolor-icon-theme' 'libogg' 'libvorbis' 'portaudio' 'portmidi' 'qtkeychain-qt5')
+source=("https://github.com/wahjam/wahjam/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('0544dd31ecd12ebcbf36069a46f686e626f2e1f6f1f1195097a2f13f1e4e8ded')
build() {
- cd wahjam-jammr-${pkgver}
-
- qmake-qt5 QTCLIENT_TARGET=jammr \
- JAMMR_API_URL="https://jammr.net/api/" \
- JAMMR_REGISTER_URL="https://jammr.net/accounts/register/" \
- JAMMR_UPGRADE_URL="https://jammr.net/pricing.html" \
- JAMMR_UPDATE_URL="https://jammr.net/static/latest-linux.txt" \
- JAMMR_DOWNLOAD_URL="https://jammr.net/download.html" \
- VERSION=${pkgver} \
- APPNAME=jammr \
- ORGNAME=jammr \
- ORGDOMAIN=jammr.net \
- USE_LIBPORTTIME=1
+ cd wahjam-$pkgver
+ qmake-qt5 CONFIG+='jammr qtclient'
make
}
package() {
- mkdir -p $pkgdir/usr/bin
- mkdir -p $pkgdir/usr/share/icons
- mkdir -p $pkgdir/usr/share/applications
- cd $srcdir/wahjam-jammr-${pkgver}
- cp -r qtclient/jammr $pkgdir/usr/bin/jammr
- cp -r debian/jammr.svg $pkgdir/usr/share/icons
- cp -r debian/jammr.desktop $pkgdir/usr/share/applications
- chmod -R 755 $pkgdir/usr/bin/jammr
- chmod -R 755 $pkgdir/usr/share/applications/jammr.desktop
+ cd wahjam-$pkgver
+ make INSTALL_ROOT="$pkgdir/usr" install
}