summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Engel2019-09-11 23:21:25 +0200
committerMarkus Engel2019-09-11 23:21:25 +0200
commitb244f36c150a613dda72b838f8824b08c40ca4f1 (patch)
tree045d5f2c4433a4acbeebc2077371420da5ef9320
downloadaur-b244f36c150a613dda72b838f8824b08c40ca4f1.tar.gz
Initial commit.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31cbd9ae2199
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vlc-plugin-ytdl-git
+ pkgdesc = VLC plugin for youtube-dl
+ pkgver = 0.r1.6d5fdda82
+ pkgrel = 1
+ url = https://git.remlab.net/gitweb/?p=vlc-plugin-ytdl.git;a=blob;f=README
+ arch = any
+ license = LGPL
+ makedepends = git
+ depends = youtube-dl
+ depends = vlc
+ provides = vlc-plugin-ytdl
+ conflicts = vlc-plugin-ytdl
+ options = !strip
+ source = git+https://git.remlab.net/git/vlc-plugin-ytdl.git
+ sha256sums = SKIP
+
+pkgname = vlc-plugin-ytdl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a81ff47bdd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Markus Engel <markus_aur@familie-engel.online>
+
+pkgname=vlc-plugin-ytdl-git
+pkgver=0.r1.6d5fdda82
+pkgrel=1
+pkgdesc='VLC plugin for youtube-dl'
+arch=('any')
+url='https://git.remlab.net/gitweb/?p=vlc-plugin-ytdl.git;a=blob;f=README'
+license=('LGPL')
+depends=('youtube-dl' 'vlc')
+makedepends=('git')
+provides=('vlc-plugin-ytdl')
+conflicts=('vlc-plugin-ytdl')
+options=('!strip')
+source=('git+https://git.remlab.net/git/vlc-plugin-ytdl.git')
+sha256sums=('SKIP')
+
+build() {
+ cd vlc-plugin-ytdl
+ make
+}
+
+package() {
+ cd vlc-plugin-ytdl
+
+ install -dm 755 "$pkgdir"/usr/lib/vlc/plugins/access
+ cp -dr --no-preserve='ownership' libytdl_plugin.so "$pkgdir"/usr/lib/vlc/plugins/access/
+}
+