summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2024-04-16 21:01:48 +0800
committerYour Name2024-04-16 21:01:48 +0800
commitb24629ca01ac9f276d0e711d333af81efb443e08 (patch)
tree14a2708cc580963183a6eb1089d47bb786c88b87
parentfd281907c4610d2f20ba25e52043312f925cb0f0 (diff)
downloadaur-b24629ca01ac9f276d0e711d333af81efb443e08.tar.gz
Update to version 0.13
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD27
2 files changed, 15 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7e9f91beae5..6a13da2ef0ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = python-fast-histogram
pkgdesc = Fast 1D and 2D histogram functions in Python
- pkgver = 0.11
+ pkgver = 0.13
pkgrel = 1
url = https://github.com/astrofrog/fast-histogram
arch = i686
arch = x86_64
- license = BSD
+ license = BSD-2-Clause
checkdepends = python-pytest
checkdepends = python-hypothesis
makedepends = python-setuptools-scm
@@ -13,8 +13,8 @@ pkgbase = python-fast-histogram
makedepends = python-build
makedepends = python-installer
makedepends = python-numpy
- source = https://files.pythonhosted.org/packages/source/f/fast-histogram/fast-histogram-0.11.tar.gz
- sha256sums = 9acb6fa5b6efd928663008965da186962bdeae20e6d5bbb3b1195dfbd1d906f0
+ source = https://files.pythonhosted.org/packages/source/f/fast_histogram/fast_histogram-0.13.tar.gz
+ sha256sums = da27a74b5ad7ebaf04b4a855c2ade39a9d41fbdb6ee7f07cba159422045c7af2
pkgname = python-fast-histogram
depends = python-numpy
diff --git a/PKGBUILD b/PKGBUILD
index c3f56158fbef..6fa85a775c51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,44 +2,39 @@
# Maintainer: Ista Zahn <istazahn at gmail dot com>
pkgname=python-fast-histogram
-_pyname=fast-histogram
-pkgver=0.11
+_pyname=fast_histogram
+pkgver=0.13
pkgrel=1
pkgdesc="Fast 1D and 2D histogram functions in Python"
arch=('i686' 'x86_64')
url="https://github.com/astrofrog/fast-histogram"
-license=('BSD')
+license=('BSD-2-Clause')
makedepends=('python-setuptools-scm'
'python-wheel'
'python-build'
'python-installer'
'python-numpy')
-checkdepends=('python-pytest' 'python-hypothesis')
+checkdepends=('python-pytest'
+ 'python-hypothesis')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-sha256sums=('9acb6fa5b6efd928663008965da186962bdeae20e6d5bbb3b1195dfbd1d906f0')
+sha256sums=('da27a74b5ad7ebaf04b4a855c2ade39a9d41fbdb6ee7f07cba159422045c7af2')
get_pyver() {
python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
}
-prepare() {
- cd ${srcdir}/${_pyname}-${pkgver}
-
- sed -i -e "/oldest-supported-numpy/d" -e "/\"wheel\"/s/,/]/" pyproject.toml
-}
-
build() {
cd ${srcdir}/${_pyname}-${pkgver}
- python -m build --wheel --no-isolation
+ python -m build --wheel --no-isolation --skip-dependency-check
}
check() {
cd ${srcdir}/${_pyname}-${pkgver}
- pytest "build/lib.linux-${CARCH}-cpython-$(get_pyver)" \
- --deselect=build/lib.linux-${CARCH}-cpython-$(get_pyver)/fast_histogram/tests/test_histogram.py::test_1d_compare_with_numpy \
- --deselect=build/lib.linux-${CARCH}-cpython-$(get_pyver)/fast_histogram/tests/test_histogram.py::test_2d_compare_with_numpy \
- --deselect=build/lib.linux-${CARCH}-cpython-$(get_pyver)/fast_histogram/tests/test_histogram.py::test_dd_compare_with_numpy || warning "Tests failed" # -vv --color=yes
+ pytest || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count \
+# --deselect=build/lib.linux-${CARCH}-cpython-$(get_pyver)/fast_histogram/tests/test_histogram.py::test_1d_compare_with_numpy \
+# --deselect=build/lib.linux-${CARCH}-cpython-$(get_pyver)/fast_histogram/tests/test_histogram.py::test_2d_compare_with_numpy \
+# --deselect=build/lib.linux-${CARCH}-cpython-$(get_pyver)/fast_histogram/tests/test_histogram.py::test_dd_compare_with_numpy #|| warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count
}
package() {