summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Weiman2015-06-10 17:34:13 -0400
committerMark Weiman2015-06-10 17:34:13 -0400
commitb25553dca01c98627bb394a1e331532e592a02df (patch)
tree200c146b47768ccfa9a3b606715062cbd885b4cb
downloadaur-b25553dca01c98627bb394a1e331532e592a02df.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rwxr-xr-xPKGBUILD35
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..536354070e2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by makepkg 4.2.0
+# Fri Feb 13 02:37:05 UTC 2015
+pkgbase = steam-session-git
+ pkgdesc = Launch Steam Big Picture from your login screen
+ pkgver = 61
+ pkgrel = 1
+ url = https://github.com/thor27/steam-login/
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = xfwm4
+ depends = wmctrl
+ depends = steam
+ depends = zenity
+ provides = steam-session
+ conflicts = steam-session
+ conflicts = steam-session-kdm
+ conflicts = steam-session-kdm-git
+ source = steam-session::git+https://github.com/thor27/steam-login.git
+ sha256sums = SKIP
+
+pkgname = steam-session-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..22c937a901ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: MarkZZ <mark.weiman at markzz dot com>
+# Contributor: Alucryd <alucryd at gmail dot com>
+
+pkgname=steam-session-git
+pkgver=61
+pkgrel=1
+pkgdesc="Launch Steam Big Picture from your login screen"
+arch=('any')
+url="https://github.com/thor27/steam-login/"
+license=('GPL2')
+depends=('xfwm4' 'wmctrl' 'steam' 'zenity')
+makedepends=('git')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}" "steam-session-kdm" "steam-session-kdm-git")
+source=("${pkgname%-*}::git+https://github.com/thor27/steam-login.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}"/${pkgname%-*}
+
+ git rev-list --count HEAD
+}
+
+package() {
+ cd "${srcdir}"/${pkgname%-*}
+
+ cp -dr --no-preserve=ownership steam-login/usr "${pkgdir}"/
+
+# Fix permissions
+ find "${pkgdir}" -type d -exec chmod 755 {} +
+ find "${pkgdir}" -type f -exec chmod 644 {} +
+ chmod 755 "${pkgdir}"/usr/bin/steam-de
+}
+
+# vim: ts=2 sw=2 et: