summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeverin Glöckner2020-10-06 22:14:04 +0200
committerSeverin Glöckner2020-10-06 22:14:04 +0200
commitb25ccc109c4a42e1b5ff1474a5450f89604d2e2a (patch)
treeb465f67b49edee6b811c638e0090bca0ff79cd71
parent17ef133520ce3a9e3df2528f6e8d8e500d95c909 (diff)
downloadaur-b25ccc109c4a42e1b5ff1474a5450f89604d2e2a.tar.gz
redactoring the package
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD40
2 files changed, 23 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3207759c0d9f..ddba87fd9e8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,8 +3,13 @@ pkgbase = wesnoth-1.6
pkgver = 1.6.5+dev
pkgrel = 2
url = https://www.wesnoth.org
+ arch = i486
arch = i686
+ arch = pentium4
arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = GPL
makedepends = boost
makedepends = cmake
@@ -22,11 +27,12 @@ pkgbase = wesnoth-1.6
depends = dbus
depends = fribidi
options = !emptydirs
- options = !zipman
+ source = wesnoth-1.6-git::git+https://github.com/wesnoth/wesnoth.git#branch=1.6
source = wesnoth-1.6.desktop
source = wesnothd-1.6.tmpfiles.conf
source = wesnothd-1.6.service
source = wesnoth-1.6.appdata.xml
+ md5sums = SKIP
md5sums = 99f136647c5af1820d0132df08350965
md5sums = ec9cab718ba96b7a4c85c224f6b747c3
md5sums = 6ba3f7977da5b5ccee8382c20dd7db4d
diff --git a/PKGBUILD b/PKGBUILD
index 255c9370d632..0d624dfb661d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,43 @@
# Maintainer Severin Glöckner <severin.gloeckner@stud.htwk-leipzig.de>
# This script contains as well instructions for other Linux systems.
-# There you have to execute the commands in the functions(){…} below by hand.
+# Have a look what is done in the build() and package() functions below.
+# Execute the same command which are used there.
-# On other systems, ignore the used variables like $pkgdir, $srcdir or $startdir
+# On other systems, ignore the used variables like $pkgdir and $srcdir.
# (there $pkgdir would be the same as an undefined variable (empty),
-# and $srcdir as well as $stardir would be the place where you have your files)
+# and $srcdir would be the place where you have your files)
+
pkgname=wesnoth-1.6
pkgver=1.6.5+dev
pkgrel=2
pkgdesc="Turn-based strategy game on a fantasy world (for old replays)"
-arch=('i686' 'x86_64')
+arch=('i486' 'i686' 'pentium4' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://www.wesnoth.org"
license=('GPL')
depends=('sdl' 'sdl_image' 'sdl_mixer' 'sdl_ttf' 'sdl_net' 'boost-libs' 'zlib' 'pango' 'cairo' 'fontconfig' 'dbus' 'fribidi')
makedepends=('boost' 'cmake' 'git')
# Package names on Debian / Ubuntu / Mint:
# libsdl1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-ttf2.0-dev libsdl-net1.2-dev libboost-iostreams-dev libboost-regex-dev zlib1g-dev libpango1.0-dev libcairo2-dev libfontconfig1-dev libdbus-1-dev libfribidi-dev gettext-base cmake make pkgconf gcc g++ git
-options=('!emptydirs' '!zipman')
-source=("wesnoth-1.6.desktop"
+options=('!emptydirs')
+source=("wesnoth-1.6-git::git+https://github.com/wesnoth/wesnoth.git#branch=1.6"
+ "wesnoth-1.6.desktop"
"wesnothd-1.6.tmpfiles.conf"
"wesnothd-1.6.service"
"wesnoth-1.6.appdata.xml")
# Not finding the files? https://aur.archlinux.org/packages/wesnoth-1.6
# Rest assured, they are optional. Things like a launcher for your convenience…
-md5sums=('99f136647c5af1820d0132df08350965'
+# Except for the wesnoth download, which can also be retrieved with this command:
+# git clone https://github.com/wesnoth/wesnoth.git -b 1.6 --shallow-exclude=1.6.5 wesnoth-1.6-git
+
+md5sums=('SKIP'
+ '99f136647c5af1820d0132df08350965'
'ec9cab718ba96b7a4c85c224f6b747c3'
'6ba3f7977da5b5ccee8382c20dd7db4d'
'1018b1fae1a65d49bed1094ba0280d87')
-PKGEXT='.pkg.tar'
-
-prepare() {
- cd "$startdir"
-
- # get a shallow clone of the git repo and store it outside the srcdir
- if [ ! -d "wesnoth-1.6-git" ] ; then
- git clone https://github.com/wesnoth/wesnoth -b 1.6 --shallow-exclude=1.6.5 wesnoth-1.6-git
- msg "Git checkout done (or server timeout)"
- fi
-
- # Archlinux specific (hide the usage of the $startdir variable)
- if [ ! -e "$srcdir/wesnoth-1.6-git" ] ; then
- ln -s "$startdir/wesnoth-1.6-git" "$srcdir/wesnoth-1.6-git"
- fi
-}
build() {
# As this is an older version and not worked on anymore, it will someday break
@@ -73,6 +64,7 @@ build() {
make
}
+
# Note: the manpages are first installed to the same place which other wesnoth
# versions use and renamed afterwards, this may cause conflicts. One can change
# -DMANDIR above to specify another location.
@@ -112,5 +104,5 @@ package() {
install -D -m644 "$srcdir/wesnothd-1.6.service" "$pkgdir/usr/lib/systemd/system/wesnothd-1.6.service"
# All done, but it doesn't show up? Try that:
- # update-desktop-database
+ # sudo update-desktop-database
}