summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo Bezerra2020-08-19 22:03:41 -0300
committerRodrigo Bezerra2020-08-19 22:03:41 -0300
commitb267470848d96f8e1aa59bb7871afd8c85547c3e (patch)
tree1c299137268bc0f6c9164e882506357ef27800df
parent28b7fc2abedde738b1a40f0f2e8eab5b5c98ed49 (diff)
downloadaur-b267470848d96f8e1aa59bb7871afd8c85547c3e.tar.gz
Update to version 1.2.3
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4226a8108924..71a390aba377 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-gssdp
pkgdesc = A GObject-based API for handling resource discovery and announcement over SSDP (32-bit)
- pkgver = 1.2.2
- pkgrel = 2
+ pkgver = 1.2.3
+ pkgrel = 1
url = http://gupnp.org/
arch = x86_64
license = LGPL
@@ -12,7 +12,7 @@ pkgbase = lib32-gssdp
makedepends = vala
depends = lib32-libsoup
depends = gssdp
- source = git+https://git.gnome.org/browse/gssdp#commit=0e87f5aecb661516983767c996d1834909f6901f
+ source = git+https://git.gnome.org/browse/gssdp#commit=a4eb74313a3df17c3ac5b99f3131522e6e8bccf4
sha256sums = SKIP
pkgname = lib32-gssdp
diff --git a/PKGBUILD b/PKGBUILD
index 92c677e7f0f2..119a0a8cd90d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
_basename=gssdp
pkgname=lib32-gssdp
-pkgver=1.2.2
-pkgrel=2
+pkgver=1.2.3
+pkgrel=1
pkgdesc="A GObject-based API for handling resource discovery and announcement over SSDP (32-bit)"
arch=(x86_64)
url="http://gupnp.org/"
license=(LGPL)
depends=(lib32-libsoup gssdp)
makedepends=(git gobject-introspection lib32-gtk3 meson vala)
-_commit=0e87f5aecb661516983767c996d1834909f6901f # tags/gssdp-1.2.2^0
+_commit=a4eb74313a3df17c3ac5b99f3131522e6e8bccf4 # tags/gssdp-1.2.3^0
source=("git+https://git.gnome.org/browse/gssdp#commit=$_commit")
sha256sums=('SKIP')
@@ -24,13 +24,15 @@ build() {
export CC='gcc -m32'
export CXX='g++ -m32'
export PKG_CONFIG='/usr/bin/i686-pc-linux-gnu-pkg-config'
- export PKG_CONFIG_PATH='$PKG_CONFIG_PATH:/usr/lib32/pkgconfig/:/usr/lib/pkgconfig'
arch-meson $_basename build \
--libdir='/usr/lib32' \
- -Dgtk_doc=false
+ -Dgtk_doc=false \
+ -Dsniffer=false \
+ -Dintrospection=false \
+ -Dexamples=false
- ninja -C build
+ meson compile -C build
}
check() {
@@ -40,5 +42,5 @@ check() {
package() {
DESTDIR="$pkgdir" meson install -C build
- rm -rf "${pkgdir}"/usr/{bin,include,share}
+ rm -rf "${pkgdir}/usr/include"
}