summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Delacourt2015-06-11 22:41:21 +0200
committerGuillaume Delacourt2015-06-11 22:41:21 +0200
commitb27fb6148a16827730591e9bab6527ad6a20ef10 (patch)
tree0b065463a0be3b6d748368b1166bdabb08b36e23
downloadaur-b27fb6148a16827730591e9bab6527ad6a20ef10.tar.gz
Initial commit.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
-rw-r--r--dotrice.install20
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c286130b23b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = otf-dotrice
+ pkgdesc = A font designed to look like an old EPSON FX-80 printer.
+ pkgver = 1.001
+ pkgrel = 2
+ url = http://openfontlibrary.org/font/dotrice
+ install = dotrice.install
+ arch = any
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-fonts-encodings
+ depends = xorg-font-utils
+ source = http://openfontlibrary.org/assets/downloads/dotrice/8bbaa7a763470e5a042344fd2a6a9907/dotrice.zip
+ md5sums = 8bbaa7a763470e5a042344fd2a6a9907
+
+pkgname = otf-dotrice
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c6f0f5684ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Contributor: feufochmar <feufochmar.gd@gmail.com>
+pkgname=otf-dotrice
+pkgver=1.001
+pkgrel=2
+pkgdesc="A font designed to look like an old EPSON FX-80 printer."
+arch=('any')
+url="http://openfontlibrary.org/font/dotrice"
+license=('custom:OFL')
+depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
+install=dotrice.install
+source=("http://openfontlibrary.org/assets/downloads/dotrice/8bbaa7a763470e5a042344fd2a6a9907/dotrice.zip")
+
+package() {
+ cd "$srcdir"/hdad-dotrice-"$pkgver"
+ install -D -m644 "OFL.txt" "$pkgdir"/usr/share/licenses/$pkgname/OFL
+ mkdir -p "$pkgdir"/usr/share/fonts/OTF
+ install -m644 *.otf "$pkgdir"/usr/share/fonts/OTF/
+}
+
+md5sums=('8bbaa7a763470e5a042344fd2a6a9907')
diff --git a/dotrice.install b/dotrice.install
new file mode 100644
index 000000000000..4f5212ef22ba
--- /dev/null
+++ b/dotrice.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*