summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2020-05-24 00:15:11 +0800
committerSukanka2020-05-24 00:15:11 +0800
commitb2a642657d8a09a623b25bb520bf8c68d32014df (patch)
tree7f66bc33792b40e2fcc45fa6bcd432fe72e0552f
parent0253e74d0547ac67c542d5e435d4e11ed714583e (diff)
downloadaur-b2a642657d8a09a623b25bb520bf8c68d32014df.tar.gz
remove patch for linux5.6
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 7 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e957f8fba4c3..096a54d78874 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bbswitch-ati-git
pkgdesc = kernel module allowing to switch also AMD integrated and Nvidia dedicated graphics card on Optimus laptops (Git version)
- pkgver = 0.8.2.g9dd2270
- pkgrel = 2
+ pkgver = 0.8.4.g07b110d
+ pkgrel = 1
url = http://github.com/Bumblebee-Project/bbswitch
arch = i686
arch = x86_64
@@ -13,9 +13,7 @@ pkgbase = bbswitch-ati-git
conflicts = bbswitch-dkms
conflicts = bbswitch-git-dkms
source = bbswitch-ati-git::git+https://github.com/Bumblebee-Project/bbswitch.git#branch=develop
- source = bbswitch-v0.8-proc_ops-struct.patch
sha256sums = SKIP
- sha256sums = 3ebaf305628587fce64f64648f8ee6c1bc51e0eab855e1725538be995649a73c
pkgname = bbswitch-ati-git
diff --git a/PKGBUILD b/PKGBUILD
index f063b7e9fb38..059e534191f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,7 @@
# Maintainer: sukanka <su975853527@gmail.com>
-
-
pkgname=bbswitch-ati-git
-pkgver=0.8.2.g9dd2270
-pkgrel=2
+pkgver=0.8.4.g07b110d
+pkgrel=1
pkgdesc='kernel module allowing to switch also AMD integrated and Nvidia dedicated graphics card on Optimus laptops (Git version)'
arch=('i686' 'x86_64')
license=('GPL')
@@ -11,12 +9,10 @@ url='http://github.com/Bumblebee-Project/bbswitch'
provides=('bbswitch')
conflicts=('bbswitch' 'bbswitch-dkms' 'bbswitch-git-dkms')
makedepends=('linux-headers' 'git')
-source=("${pkgname}::git+https://github.com/Bumblebee-Project/bbswitch.git#branch=develop"
-'bbswitch-v0.8-proc_ops-struct.patch'
-)
-sha256sums=('SKIP' '3ebaf305628587fce64f64648f8ee6c1bc51e0eab855e1725538be995649a73c')
+source=("${pkgname}::git+https://github.com/Bumblebee-Project/bbswitch.git#branch=develop")
+sha256sums=('SKIP')
-pkgver () {
+pkgver() {
cd "${srcdir}/${pkgname}"
git describe --always | sed 's|-|.|g' | sed 's/v//g'
}
@@ -25,9 +21,6 @@ build() {
kernel_ver=$(cut -f1 -d'-' /usr/src/linux/version)
cpu=$( grep name /proc/cpuinfo | uniq | cut -f2 -d: | cut -f2 -d' ')
cd "${srcdir}/${pkgname}"
- if [ $kernel_ver > "5.6" ]; then
- git apply "${srcdir}"/bbswitch-v0.8-proc_ops-struct.patch
- fi
if [ "$cpu" = "AMD" ]; then
sed -i 's/PCI_VENDOR_ID_INTEL/PCI_VENDOR_ID_ATI/g' "${srcdir}/${pkgname}"/bbswitch.c
fi