summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElia Argentieri2020-02-07 15:34:13 +0100
committerElia Argentieri2020-02-07 15:36:55 +0100
commitb2bd381adae1ae460dda2194f1ad6aec051dc5d7 (patch)
treed013e6961666f20e74609d5dbbc48bf35419070c
downloadaur-b2bd381adae1ae460dda2194f1ad6aec051dc5d7.tar.gz
First commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD27
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26212f4f1593
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = efibootmgr-gui-git
+ pkgdesc = Manage EFI boot loader entries with this simple GUI
+ pkgver = 0.1.r0.g223e42f
+ pkgrel = 1
+ url = https://github.com/Elinvention/efibootmgr-gui
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python-gobject
+ depends = efibootmgr
+ depends = python3
+ provides = efibootmgr-gui
+ conflicts = efibootmgr-gui
+ source = git+https://github.com/Elinvention/efibootmgr-gui.git
+ md5sums = SKIP
+
+pkgname = efibootmgr-gui-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..184a3e19e762
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+efibootmgr-gui*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7ca980b7214
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Elia A. <elia@elinvention.ovh>
+
+_pkgname=efibootmgr-gui
+pkgname="$_pkgname-git"
+pkgver=0.1.r0.g223e42f
+pkgrel=1
+pkgdesc="Manage EFI boot loader entries with this simple GUI"
+url="https://github.com/Elinvention/efibootmgr-gui"
+license=('GPL3')
+arch=('any')
+depends=('python-gobject' 'efibootmgr' 'python3')
+makedepends=('git')
+optdepends=()
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ install -Dm644 "$srcdir/$_pkgname/efibootmgr.desktop" "$pkgdir/usr/share/applications/efibootmgr.desktop"
+ install -Dm755 "$srcdir/$_pkgname/efibootmgr_gui.py" "$pkgdir/usr/bin/efibootmgr-gui"
+}