summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2021-06-27 20:58:16 +0200
committerMichal Wojdyla2021-06-27 20:58:16 +0200
commitb2c9cf26e411c0525334bd50b8d656a2f14d348f (patch)
treef06d4d7b997d187ac5ca9be8514fd6df66457b6f
parentfa33fa134c1cfca3f8b278e8a240538869bd0527 (diff)
downloadaur-b2c9cf26e411c0525334bd50b8d656a2f14d348f.tar.gz
modernize
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD30
2 files changed, 13 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc9a36901477..2db3c5d33cb0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = emacs-processing-mode-git
pkgdesc = Major mode for Processing 2.0.
- pkgver = 20150609
+ pkgver = 20171023
pkgrel = 1
url = https://github.com/ptrv/processing2-emacs
install = emacs-processing-mode-git.install
@@ -9,9 +9,8 @@ pkgbase = emacs-processing-mode-git
makedepends = git
depends = emacs
provides = emacs-processing-mode
- replaces = emacs-processing-mode
- source =
- md5sums =
+ conflicts = emacs-processing-mode
+ source = git+https://github.com/ptrv/processing2-emacs.git
+ md5sums = SKIP
pkgname = emacs-processing-mode-git
-
diff --git a/PKGBUILD b/PKGBUILD
index c7c3c1d8c988..099ae547c365 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mort Yao <soi@mort.ninja>
-
+# Contributor: Michal Wojdyla < micwoj9292 at gmail dot com >
pkgname=emacs-processing-mode-git
-pkgver=20150609
+pkgver=20171023
pkgrel=1
pkgdesc="Major mode for Processing 2.0."
arch=('any')
@@ -10,31 +10,19 @@ license=('GPL3')
depends=('emacs')
makedepends=('git')
provides=('emacs-processing-mode')
-replaces=('emacs-processing-mode')
+conflicts=('emacs-processing-mode')
install=$pkgname.install
-source=()
-md5sums=()
-
-_gitroot="git://github.com/ptrv/processing2-emacs.git"
+source=(git+https://github.com/ptrv/processing2-emacs.git)
+md5sums=(SKIP)
_gitname="processing2-emacs"
-build() {
- cd $startdir/src
- msg "Connecting to GIT server..."
-
- if [ -d $startdir/src/$_gitname ] ; then
- cd $_gitname && git pull origin
- msg "The local files are updated."
- else
- git clone $_gitroot
- fi
-
- msg "GIT checkout done or server timeout"
+pkgver() {
+ cd $_gitname
+ git log -1 --format='%cd' --date=short | tr -d -- '-'
}
package() {
- cd $startdir/src/$_gitname
-
+ cd $_gitname
mkdir -p $pkgdir/usr/share/emacs/site-lisp/processing-mode
emacs -batch -f batch-byte-compile processing-mode.el
install -Dm644 processing-mode.el processing-mode.elc $pkgdir/usr/share/emacs/site-lisp/processing-mode