summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Vázquez2023-09-16 10:43:46 +0200
committerAntonio Vázquez2023-09-16 10:43:46 +0200
commitb2d98de73c301acbbb8d11e052bb03a2ae0f0f6a (patch)
treeb09a83b234160d21d77588301da30d3cbb466087
parentded6d75af0f24e42cad4d30953048d699132dc13 (diff)
downloadaur-b2d98de73c301acbbb8d11e052bb03a2ae0f0f6a.tar.gz
Initialize submodules
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 93be4cee396a..60e3bf7cf4dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Julio Diez <juliosddr@gmail.com>
pkgname=suscan-git
-pkgver=r1047.dd48ec0
+pkgver=r1108.38d9282
pkgrel=1
pkgdesc="SUScan is a graphical signal analysis tool"
arch=("any")
@@ -22,6 +22,12 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$pkgname"
+ git submodule init
+ git -c protocol.file.allow=always submodule update
+}
+
build() {
cd "$pkgname"