summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2016-06-07 15:05:06 +0200
committerAlexander F Rødseth2016-06-07 15:12:41 +0200
commitb2f597c56b8e7156ab5cf7c087dc98c4978afbd1 (patch)
tree45dc192d1e9db5eef45f178912ab64a8ea4047ea
parent3dfa28b3f5c03122610e477be2c2b0794da36d3f (diff)
downloadaur-b2f597c56b8e7156ab5cf7c087dc98c4978afbd1.tar.gz
Upgrade to 3.6
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD92
-rw-r--r--PKGBUILD.36144
-rw-r--r--PKGBUILD.regular79
-rw-r--r--nethack-x11.patch296
5 files changed, 252 insertions, 382 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64429a2cefd0..95c405a117d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,28 @@
+# Generated by mksrcinfo v8
+# Tue Jun 7 13:11:14 UTC 2016
pkgbase = nethack-x11
- pkgdesc = Single-player roguelike dungeon exploration game
- pkgver = 3.4.3
- pkgrel = 8
- url = http://www.nethack.org/
+ pkgdesc = Single-player roguelike dungeon exploration game (X11 version)
+ pkgver = 3.6.0
+ pkgrel = 1
+ url = http://nethack.org/
arch = x86_64
arch = i686
license = custom
- makedepends = gendesk
makedepends = setconf
+ makedepends = gendesk
depends = libxaw
conflicts = nethack
backup = etc/nethackrc
- source = http://downloads.sourceforge.net/nethack/nethack-343-src.tgz
+ backup = var/games/nethack/logfile
+ backup = var/games/nethack/xlogfile
+ backup = var/games/nethack/perm
+ backup = var/games/nethack/record
+ backup = usr/games/nethack/sysconf
+ source = http://downloads.sourceforge.net/nethack/nethack-360-src.tgz
source = nethack-x11.patch
source = nethack-x11.png::http://bugs.gentoo.org/attachment.cgi?id=86458
- sha256sums = bb39c3d2a9ee2df4a0c8fdde708fbc63740853a7608d2f4c560b488124866fe4
- sha256sums = 1b3857f2c1ae5e418ab26ab2ed5dbb9eb61c506f262b07e15e9464c3c6734452
+ sha256sums = 1ade698d8458b8d87a4721444cb73f178c74ed1b6fde537c12000f8edf2cb18a
+ sha256sums = be227a980243dba79ffc2bf311462f7b7d369899253c89dbb1ada4bedb2a5017
sha256sums = e1e0b059c617af04ee88bed4b03b73c02f022663e001c5485fe9900ca2d76295
pkgname = nethack-x11
diff --git a/PKGBUILD b/PKGBUILD
index 0c119db4eb62..4d760832969d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,57 @@
-# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+# Contributor: Sascha Lüdecke <sascha@meta-x.de>
# Contributor: Jamie <dyscoria@googlemail.com>
pkgname=nethack-x11
-pkgver=3.4.3
-pkgrel=8
-pkgdesc='Single-player roguelike dungeon exploration game'
+pkgver=3.6.0
+pkgrel=1
+pkgdesc='Single-player roguelike dungeon exploration game (X11 version)'
arch=('x86_64' 'i686')
-url='http://www.nethack.org/'
+url='http://nethack.org/'
license=('custom')
depends=('libxaw')
-makedepends=('gendesk' 'setconf')
+makedepends=('setconf' 'gendesk')
conflicts=('nethack')
-backup=('etc/nethackrc')
-source=("http://downloads.sourceforge.net/nethack/nethack-343-src.tgz"
+backup=('etc/nethackrc'
+ 'var/games/nethack/logfile'
+ 'var/games/nethack/xlogfile'
+ 'var/games/nethack/perm'
+ 'var/games/nethack/record'
+ 'usr/games/nethack/sysconf')
+source=("http://downloads.sourceforge.net/nethack/nethack-${pkgver//./}-src.tgz"
'nethack-x11.patch'
'nethack-x11.png::http://bugs.gentoo.org/attachment.cgi?id=86458')
-sha256sums=('bb39c3d2a9ee2df4a0c8fdde708fbc63740853a7608d2f4c560b488124866fe4'
- '1b3857f2c1ae5e418ab26ab2ed5dbb9eb61c506f262b07e15e9464c3c6734452'
+sha256sums=('1ade698d8458b8d87a4721444cb73f178c74ed1b6fde537c12000f8edf2cb18a'
+ 'be227a980243dba79ffc2bf311462f7b7d369899253c89dbb1ada4bedb2a5017'
'e1e0b059c617af04ee88bed4b03b73c02f022663e001c5485fe9900ca2d76295')
prepare() {
- cd "$srcdir/nethack-$pkgver"
+ cd "nethack-$pkgver"
- gendesk -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" --exec nethack \
- --name 'Nethack (X11)' --genericname Nethack
+ gendesk -n -f \
+ --pkgname "$pkgname" \
+ --pkgdesc "$pkgdesc" \
+ --exec nethack \
+ --genericname Nethack \
+ --name 'Nethack (X11)'
+
+ ####
+ ###
+ ## Issues (upstream)
+ #
+ # - the tty mode is somehow not working
+ # - the contents of NETHACKOPTIONS is possibly ignored
+ # - the tile size doubling in Xresources may not work
+ # - custom tile files in sysconf/nethackrc may not work
+ # - ~/.nethackrc is somehow not working
+ ##
+ ###
+ ####
- sh sys/unix/setup.sh
patch -Np1 -i ../nethack-x11.patch
+ sh sys/unix/setup.sh
# Create /etc/nethackrc with OPTIONS=windowtype:X11
- touch nethackrc
setconf -a nethackrc OPTIONS 'windowtype:X11'
# Add two new lines to nethack.sh
@@ -38,32 +60,44 @@ prepare() {
sys/unix/nethack.sh
# Set HACKDIR
- setconf sys/unix/nethack.sh HACKDIR '/usr/share/nethack'
+ setconf sys/unix/nethack.sh HACKDIR '/usr/games/nethack'
# Set NETHACKOPTIONS
setconf sys/unix/nethack.sh NETHACKOPTIONS '@/etc/nethackrc'
+
+ # # Change Nethack.ad settings
+ sed 's/variable/fixed/' -i win/X11/NetHack.ad
+ sed 's/nh10/fixed/' -i win/X11/NetHack.ad
+ sed 's/!NetHack.tile_file/NetHack.tile_file/' -i win/X11/NetHack.ad
}
build() {
- cd "$srcdir/nethack-$pkgver"
+ cd "nethack-$pkgver"
+
+ export CC="gcc"
+ export CFLAGS='-I../include -O2 -fomit-frame-pointer -w'
+ export LFLAGS="-L/usr/lib -L/usr/lib/X11 -Xlinker -soname=_APP_"
+ export LINK="gcc"
- make
+ # MAXIMUM HACK-FORCE, ENGAGED!
+ sh -c "make all -j1"
}
package() {
- cd "$srcdir/nethack-$pkgver"
-
- make PREFIX="${pkgdir}/usr" install
+ cd "nethack-$pkgver"
+ install -d "$pkgdir/var/games/nethack"
+ export CFLAGS="-I../include -O2 -fomit-frame-pointer"
+ setconf Makefile VARDIR "$pkgdir/var/games/nethack"
+ echo -e "install:\n\ttrue" > src/Makefile
+ make -k PREFIX=$pkgdir/usr install
install -Dm644 nethackrc "$pkgdir/etc/nethackrc"
- install -Dm644 dat/license \
- "$pkgdir/usr/share/licenses/$pkgname/license"
- install -Dm644 win/X11/nethack.rc \
- "$pkgdir/usr/share/doc/$pkgname/nethackrc"
- install -Dm644 "$pkgname.desktop" \
- "$pkgdir/usr/share/applications/$pkgname.desktop"
- install -Dm644 "../$pkgname.png" \
- "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm644 dat/license "$pkgdir/usr/share/licenses/$pkgname/license"
+ install -Dm644 win/X11/nethack.rc "$pkgdir/usr/share/doc/$pkgname/nethackrc"
+ install -Dm644 doc/Guidebook.txt "$pkgdir/usr/share/doc/$pkgname/Guidebook.txt"
+ install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "../$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -g games -Dm644 sys/unix/sysconf "$pkgdir/usr/games/nethack/sysconf"
}
# vim:set ts=2 sw=2 et:
diff --git a/PKGBUILD.36 b/PKGBUILD.36
deleted file mode 100644
index 4b4439516740..000000000000
--- a/PKGBUILD.36
+++ /dev/null
@@ -1,144 +0,0 @@
-# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
-# Contributor: Jamie <dyscoria@googlemail.com>
-
-pkgname=nethack-x11
-pkgver=3.6.0
-pkgrel=1
-pkgdesc='Single-player roguelike dungeon exploration game'
-arch=('x86_64' 'i686')
-url='http://nethack.org/'
-license=('custom')
-depends=('libxaw')
-makedepends=('setconf' 'gendesk' 'addinclude') #xorg-server-devel
-conflicts=('nethack')
-backup=('etc/nethackrc')
-source=("http://downloads.sourceforge.net/nethack/nethack-${pkgver//./}-src.tgz"
- 'nethack-x11.png::http://bugs.gentoo.org/attachment.cgi?id=86458')
-sha256sums=('1ade698d8458b8d87a4721444cb73f178c74ed1b6fde537c12000f8edf2cb18a'
- 'e1e0b059c617af04ee88bed4b03b73c02f022663e001c5485fe9900ca2d76295')
-
-prepare() {
- cd "nethack-$pkgver"
-
- gendesk -n -f --pkgname "$pkgname" --pkgdesc "$pkgdesc" --exec nethack \
- --name 'Nethack (X11)' --genericname Nethack
-
- sh sys/unix/setup.sh
-
- echo '' > Makefile.top
- #echo 'GAMEUID=root' > Makefile.top
- #echo 'GAMEGRP=root' >> Makefile.top
- echo 'GAMEDIR=$(PREFIX)/share/$(GAME)' >> Makefile.top
- echo 'SHELLDIR=$(PREFIX)/bin' >> Makefile.top
- echo 'VARDIR=$(PREFIX)/var/games/nethack' >> Makefile.top
- cat Makefile >> Makefile.top
- mv -f Makefile.top Makefile
-
- sed 's/# VARDATND =/VARDATND =/' -i Makefile
- setconf Makefile VARDATND "x11tiles NetHack.ad pet_mark.xbm" # pilemark.xpm rip.xpm
-
- cd include
- sed 's:/* #define X11_GRAPHICS:#define X11_GRAPHICS:' -i unixconf.h
- sed 's:bin/compress:bin/gzip:' -i unixconf.h
- sed 's:".Z":".gz":' -i unixconf.h
- sed 's:/* #define DLB:#define DLB:' -i unixconf.h
- sed 's:games/lib/nethackdir:/share/nethack:' -i unixconf.h
- sed 's:/* #define LINUX:#define LINUX:' -i unixconf.h
- sed 's:/* #define TIMED_DELAY:#define TIMED_DELAY:' -i unixconf.h
-
- sed 's#if !defined(NOTTYGRAPHICS)#ifdef UNIX#' -i config.h
- sed 's#define TTY_GRAPHICS#define X11_GRAPHICS#' -i config.h
- #sed 's#DEFAULT_WINDOW_SYS "tty"#DEFAULT_WINDOW_SYS "X11"#g' -i config.h
- sed 's|#define X11_GRAPHICS||' -i config.h
-
- #addinclude -n global.h '#define DEFAULT_WINDOW_SYS "X11"'
-
- cd ..
-
- #setconf Makefile WINSRC '$(WINTTYSRC) $(WINX11SRC)'
- #setconf Makefile WINOBJ '$(WINTTYOBJ) $(WINX11OBJ)'
- #setconf Makefile WINTTYLIB '-lncurses'
- #setconf Makefile WINLIB '$(WINTTYLIB) $(WINX11LIB)'
-
- setconf Makefile WINSRC '$(WINX11SRC)'
- setconf Makefile WINOBJ '$(WINX11OBJ)'
- setconf Makefile WINLIB '$(WINX11LIB)'
-
- setconf src/Makefile WINSRC '$(WINX11SRC)'
- setconf src/Makefile WINOBJ '$(WINX11OBJ)'
-
- # Bison and Flex > Yacc and Lex
- setconf -a Makefile YACC 'bison -y'
- setconf -a Makefile LEX 'flex'
-
- # Create /etc/nethackrc with OPTIONS=windowtype:X11
- setconf -a nethackrc OPTIONS 'windowtype:X11'
-
- # Add two new lines to nethack.sh
- sed -i \
- 's|export HACKDIR|NETHACKOPTIONS=\nexport NETHACKOPTIONS\nexport HACKDIR|' \
- sys/unix/nethack.sh
-
- # Set HACKDIR
- setconf sys/unix/nethack.sh HACKDIR '/usr/share/nethack'
-
- # Set NETHACKOPTIONS
- setconf sys/unix/nethack.sh NETHACKOPTIONS '@/etc/nethackrc'
-
- # Change Nethack.ad settings
- sed 's/variable/fixed/' -i win/X11/NetHack.ad
- sed 's/nh10/fixed/' -i win/X11/NetHack.ad
- sed 's/!NetHack.tile_file/NetHack.tile_file/' -i win/X11/NetHack.ad
-
- # Fix tty color detection
- #echo '#undef TEXTCOLOR' > sys/share/unixtty.new
- #cat sys/share/unixtty.c >> sys/share/unixtty.new
- #mv -f sys/share/unixtty.new sys/share/unixtty.c
-
- # Fix tty color detection
- #echo '#undef COMPRESS' > src/files.new
- #echo '#undef ZLIB_COMP' >> src/files.new
- #echo '#undef TTY_GRAPHICS' >> src/files.new
- #cat src/files.c >> src/files.new
- #mv -f src/files.new src/files.c
- #addinclude src/files.c stdio
- #echo 'int more() { printf("NOT IMPLEMENTED: more()\n"); return 0; }' >> src/files.c
-}
-
-build() {
- cd "nethack-$pkgver/src"
-
- export CC="gcc"
- export CFLAGS='-I../include -O2 -fomit-frame-pointer -DDEFAULT_WINDOW_SYS=\"X11\" -DX11_GRAPHICS'
- export LFLAGS="-L/usr/lib -L/usr/lib/X11 -Xlinker -soname=_APP_"
- export LINK="gcc"
-
- # MAXIMUM HACK-FORCE, ENGAGED!
- sh -c "make -k || true" || true
- sh -c "gcc -o nethack $CFLAGS -Wl,--unresolved-symbols=ignore-all *.o || true"
- cd ..
- sh -c "make -k || true" || true
- cd src
- sh -c "gcc -o nethack $CFLAGS -Wl,--unresolved-symbols=ignore-all *.o || true"
-}
-
-package() {
- cd "nethack-$pkgver"
-
- mkdir -p "$pkgdir/var/games/nethack"
- echo -e "install:\n\ttrue" > src/Makefile
- export CFLAGS="-I../include -O2 -fomit-frame-pointer"
- setconf Makefile VARDIR "$pkgdir/var/games/nethack"
- make -k PREFIX=$pkgdir/usr install
- install -Dm644 nethackrc "$pkgdir/etc/nethackrc"
- install -Dm644 dat/license \
- "$pkgdir/usr/share/licenses/$pkgname/license"
- install -Dm644 win/X11/nethack.rc \
- "$pkgdir/usr/share/doc/$pkgname/nethackrc"
- install -Dm644 "$pkgname.desktop" \
- "$pkgdir/usr/share/applications/$pkgname.desktop"
- install -Dm644 "../$pkgname.png" \
- "$pkgdir/usr/share/pixmaps/$pkgname.png"
-}
-
-# vim:set ts=2 sw=2 et:
diff --git a/PKGBUILD.regular b/PKGBUILD.regular
deleted file mode 100644
index c0dcd84b4cb5..000000000000
--- a/PKGBUILD.regular
+++ /dev/null
@@ -1,79 +0,0 @@
-# $Id$
-# Maintainer : schuay <jakob.gruber@gmail.com>
-# Contributor : kevin <kevin@archlinux.org>
-# Contributor : Christian Schmidt <mucknert@gmx.net>
-# Contributor : Markus Meissner <markus@meissna.de>
-# Contributor : Nick Erdmann <erdmann@date.upb.de>
-
-pkgname=nethack
-pkgver=3.6.0
-pkgrel=1
-pkgdesc='Single-player roguelike dungeon exploration game'
-arch=('x86_64' 'i686')
-url='http://nethack.org/'
-license=('custom')
-depends=('ncurses' 'gzip' 'libxaw')
-makedepends=('gendesk') #'setconf' 'addinclude' 'xorg-server-devel'
-install=nethack.install
-conflicts=('nethack')
-source=("http://downloads.sourceforge.net/nethack/nethack-${pkgver//.}-src.tgz"
- 'nethack-x11.png::http://bugs.gentoo.org/attachment.cgi?id=86458')
-sha256sums=('1ade698d8458b8d87a4721444cb73f178c74ed1b6fde537c12000f8edf2cb18a'
- 'e1e0b059c617af04ee88bed4b03b73c02f022663e001c5485fe9900ca2d76295')
-
-prepare() {
- cd "$pkgname-$pkgver"
-
- gendesk -n -f --pkgname "$pkgname" --pkgdesc "$pkgdesc" --exec nethack \
- --name 'Nethack (X11)' --genericname Nethack
-
- sed -e 's|^/\* \(#define LINUX\) \*/|\1|' \
- -e 's|^/\* \(#define TIMED_DELAY\) \*/|\1|' -i include/unixconf.h
-
- # we are setting up for setgid games, so modify all necessary permissions
- # to allow full access for groups
-
- sed -e '/^HACKDIR/ s|/games/lib/\$(GAME)dir|/var/games/nethack/|' \
- -e '/^SHELLDIR/ s|/games|/usr/bin|' \
- -e '/^VARDIRPERM/ s|0755|0775|' \
- -e '/^VARFILEPERM/ s|0600|0664|' \
- -e '/^GAMEPERM/ s|0755|02755|' \
- -e 's|\(DSYSCF_FILE=\)\\"[^"]*\\"|\1\\"/var/games/nethack/sysconf\\"|' \
- -e 's|\(DHACKDIR=\)\\"[^"]*\\"|\1\\"/var/games/nethack/\\"|' -i sys/unix/hints/linux
-
- sed -e 's|^#GAMEUID.*|GAMEUID = root|' \
- -e 's|^#GAMEGRP.*|GAMEGRP = games|' \
- -e '/^FILEPERM\s*=/ s|0644|0664|' \
- -e '/^DIRPERM\s*=/ s|0755|0775|' -i sys/unix/Makefile.top
-
- sed -e "/^MANDIR\s*=/s|/usr/man/man6|$pkgdir/usr/share/man/man6|" -i sys/unix/Makefile.doc
-
-}
-
-build(){
- cd "$pkgname-$pkgver/sys/unix"
- sh setup.sh hints/linux
- make -C "$srcdir/$pkgname-$pkgver"
-}
-
-package() {
- cd "$pkgname-$pkgver"
-
- install -dm755 $pkgdir/usr/share/{man/man6,doc/nethack}
- install -dm775 $pkgdir/var/games/
- make PREFIX=$pkgdir -j1 install manpages # Multi-threaded builds fail.
- sed -e "s|HACKDIR=$pkgdir/|HACKDIR=/|" \
- -e 's|HACK=$HACKDIR|HACK=/usr/lib/nethack|' \
- -i $pkgdir/usr/bin/nethack
-
- install -dm755 $pkgdir/usr/lib/nethack
- mv $pkgdir/var/games/nethack/{nethack,recover} $pkgdir/usr/lib/nethack/
-
- # FS#43414: /var/games should be owned by root:games.
- chown -R root:games $pkgdir/var/games/
- chown root:games $pkgdir/usr/lib/nethack/nethack
- #chmod 02755 $pkgdir/usr/lib/nethack/nethack
-
- install -Dm644 doc/Guidebook.txt $pkgdir/usr/share/doc/nethack/Guidebook.txt
- install -Dm644 dat/license $pkgdir/usr/share/licenses/$pkgname/LICENSE
-}
diff --git a/nethack-x11.patch b/nethack-x11.patch
index 74ad2e48c402..3a872b718275 100644
--- a/nethack-x11.patch
+++ b/nethack-x11.patch
@@ -1,161 +1,213 @@
-diff --git a/Makefile b/Makefile
-index 2f11c35..2233f03 100644
---- a/Makefile
-+++ b/Makefile
-@@ -17,8 +17,8 @@
- PREFIX = /usr
- GAME = nethack
- # GAME = nethack.prg
--GAMEUID = games
--GAMEGRP = bin
-+GAMEUID = root
-+GAMEGRP = root
+diff -ru nethack-3.6.0.orig/include/config.h nethack-3.6.0/include/config.h
+--- nethack-3.6.0.orig/include/config.h 2015-11-17 06:58:34.000000000 +0100
++++ nethack-3.6.0/include/config.h 2016-05-08 21:15:56.953494936 +0200
+@@ -43,7 +43,7 @@
+ #if !defined(NOTTYGRAPHICS)
+ #define TTY_GRAPHICS /* good old tty based graphics */
+ #endif
+-/* #define X11_GRAPHICS */ /* X11 interface */
++#define X11_GRAPHICS /* X11 interface */
+ /* #define QT_GRAPHICS */ /* Qt interface */
+ /* #define GNOME_GRAPHICS */ /* Gnome interface */
+ /* #define MSWIN_GRAPHICS */ /* Windows NT, CE, Graphics */
+@@ -113,7 +113,7 @@
+ #endif
- # Permissions - some places use setgid instead of setuid, for instance
- # See also the option "SECURE" in include/config.h
-@@ -35,13 +35,13 @@ DIRPERM = 0755
- # therefore there should not be anything in GAMEDIR that you want to keep
- # (if there is, you'll have to do the installation by hand or modify the
- # instructions)
--GAMEDIR = $(PREFIX)/games/lib/$(GAME)dir
-+GAMEDIR = $(PREFIX)/share/$(GAME)
- VARDIR = $(GAMEDIR)
--SHELLDIR = $(PREFIX)/games
-+SHELLDIR = $(PREFIX)/bin
+ #ifndef DEFAULT_WINDOW_SYS
+-#define DEFAULT_WINDOW_SYS "tty"
++#define DEFAULT_WINDOW_SYS "X11"
+ #endif
- # per discussion in Install.X11 and Install.Qt
--VARDATND =
--# VARDATND = x11tiles NetHack.ad pet_mark.xbm
-+# VARDATND =
-+VARDATND = x11tiles NetHack.ad pet_mark.xbm
- # VARDATND = x11tiles NetHack.ad pet_mark.xbm rip.xpm
- # for Atari/Gem
- # VARDATND = nh16.img title.img GEM_RSC.RSC rip.img
-diff --git a/include/config.h b/include/config.h
-index 3efbfa2..db98440 100644
---- a/include/config.h
-+++ b/include/config.h
-@@ -43,7 +43,7 @@
- * Some combinations make no sense. See the installation document.
+ #ifdef X11_GRAPHICS
+@@ -125,7 +125,7 @@
+ * would allow:
+ * xpmtoppm <x11tiles.xpm | pnmscale 1.25 | ppmquant 90 >x11tiles_big.xpm
*/
- #define TTY_GRAPHICS /* good old tty based graphics */
--/* #define X11_GRAPHICS */ /* X11 interface */
-+#define X11_GRAPHICS /* X11 interface */
- /* #define QT_GRAPHICS */ /* Qt interface */
- /* #define GNOME_GRAPHICS */ /* Gnome interface */
- /* #define MSWIN_GRAPHICS */ /* Windows NT, CE, Graphics */
-@@ -169,8 +169,8 @@
-
- #ifdef UNIX
+-/* # define USE_XPM */ /* Disable if you do not have the XPM library */
++#define USE_XPM /* Disable if you do not have the XPM library */
+ #ifdef USE_XPM
+ #define GRAPHIC_TOMBSTONE /* Use graphical tombstone (rip.xpm) */
+ #endif
+@@ -250,11 +250,11 @@
+
+ #if defined(UNIX) && !defined(ZLIB_COMP) && !defined(COMPRESS)
/* path and file name extension for compression program */
--#define COMPRESS "/usr/bin/compress" /* Lempel-Ziv compression */
--#define COMPRESS_EXTENSION ".Z" /* compress's extension */
-+#define COMPRESS "/bin/gzip" /* Lempel-Ziv compression */
-+#define COMPRESS_EXTENSION ".gz" /* compress's extension */
+-#define COMPRESS "/usr/bin/compress" /* Lempel-Ziv compression */
+-#define COMPRESS_EXTENSION ".Z" /* compress's extension */
++/* #define COMPRESS "/usr/bin/compress" */ /* Lempel-Ziv compression */
++/* #define COMPRESS_EXTENSION ".Z" */ /* compress's extension */
/* An example of one alternative you might want to use: */
- /* #define COMPRESS "/usr/local/bin/gzip" */ /* FSF gzip compression */
- /* #define COMPRESS_EXTENSION ".gz" */ /* normal gzip extension */
-@@ -185,7 +185,7 @@
- * a tar-like file, thus making a neater installation. See *conf.h
- * for detailed configuration.
+-/* #define COMPRESS "/usr/local/bin/gzip" */ /* FSF gzip compression */
+-/* #define COMPRESS_EXTENSION ".gz" */ /* normal gzip extension */
++#define COMPRESS "/usr/bin/gzip" /* FSF gzip compression */
++#define COMPRESS_EXTENSION ".gz" /* normal gzip extension */
+ #endif
+
+ #ifndef COMPRESS
+@@ -298,7 +298,7 @@
+ * a tar-like file, thus making a neater installation. See *conf.h
+ * for detailed configuration.
*/
--/* #define DLB */ /* not supported on all platforms */
-+#define DLB /* not supported on all platforms */
+-/* #define DLB */ /* not supported on all platforms */
++#define DLB /* not supported on all platforms */
/*
- * Defining INSURANCE slows down level changes, but allows games that
-@@ -204,7 +204,7 @@
+ * Defining INSURANCE slows down level changes, but allows games that
+@@ -317,7 +317,7 @@
* otherwise it will be the current directory.
*/
- # ifndef HACKDIR
--# define HACKDIR "/usr/games/lib/nethackdir"
-+# define HACKDIR "/usr/share/nethack"
- # endif
+ #ifndef HACKDIR
+-#define HACKDIR "/usr/games/lib/nethackdir"
++#define HACKDIR "/usr/games/nethack"
+ #endif
/*
-diff --git a/include/unixconf.h b/include/unixconf.h
-index fe1b006..4d0cf48 100644
---- a/include/unixconf.h
-+++ b/include/unixconf.h
-@@ -37,7 +37,7 @@
- #define NETWORK /* if running on a networked system */
- /* e.g. Suns sharing a playground through NFS */
- /* #define SUNOS4 */ /* SunOS 4.x */
--/* #define LINUX */ /* Another Unix clone */
-+#define LINUX /* Another Unix clone */
- /* #define CYGWIN32 */ /* Unix on Win32 -- use with case sensitive defines */
- /* #define GENIX */ /* Yet Another Unix Clone */
- /* #define HISX */ /* Bull Unix for XPS Machines */
-@@ -132,7 +132,7 @@
+@@ -327,7 +327,7 @@
+ * since the user might create files in a directory of his choice.
+ * Of course SECURE is meaningful only if HACKDIR is defined.
+ */
+-/* #define SECURE */ /* do setuid(getuid()) after chdir() */
++#define SECURE /* do setuid(getuid()) after chdir() */
+
+ /*
+ * If it is desirable to limit the number of people that can play Hack
+diff -ru nethack-3.6.0.orig/include/unixconf.h nethack-3.6.0/include/unixconf.h
+--- nethack-3.6.0.orig/include/unixconf.h 2015-11-17 11:54:25.000000000 +0100
++++ nethack-3.6.0/include/unixconf.h 2016-05-08 21:19:25.780412473 +0200
+@@ -36,7 +36,7 @@
+ #define NETWORK /* if running on a networked system */
+ /* e.g. Suns sharing a playground through NFS */
+ /* #define SUNOS4 */ /* SunOS 4.x */
+-/* #define LINUX */ /* Another Unix clone */
++#define LINUX /* Another Unix clone */
+ /* #define CYGWIN32 */ /* Unix on Win32 -- use with case sensitive defines */
+ /* #define GENIX */ /* Yet Another Unix Clone */
+ /* #define HISX */ /* Bull Unix for XPS Machines */
+@@ -101,7 +101,7 @@
+ * If you want the static parts of your playground on a read-only file
+ * system, define VAR_PLAYGROUND to be where the variable parts are kept.
+ */
+-/* #define VAR_PLAYGROUND "/var/lib/games/nethack" */
++#define VAR_PLAYGROUND "/var/games/nethack"
+
+ /*
+ * Define DEF_PAGER as your default pager, e.g. "/bin/cat" or "/usr/ucb/more"
+@@ -128,7 +128,7 @@
* "extra output" method is used, but not all systems provide access to
* a fine-grained timer.
*/
--/* #define TIMED_DELAY */ /* usleep() */
-+#define TIMED_DELAY /* usleep() */
+-/* #define TIMED_DELAY */ /* usleep() */
++#define TIMED_DELAY /* usleep() */
#endif
/*
-diff --git a/src/Makefile b/src/Makefile
-index 29ad99a..0be4a96 100644
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -214,8 +214,8 @@ WINBEOBJ =
+diff -ru nethack-3.6.0.orig/src/invent.c nethack-3.6.0/src/invent.c
+--- nethack-3.6.0.orig/src/invent.c 2015-11-16 06:05:29.000000000 +0100
++++ nethack-3.6.0/src/invent.c 2016-05-12 23:03:28.134734406 +0200
+@@ -2813,6 +2813,7 @@
+ picked_some ? "Other things" : "Things",
+ Blind ? "you feel" : "are");
+ putstr(tmpwin, 0, buf);
++ putstr(tmpwin, 0, ""); /* add a separator */
+ for (; otmp; otmp = otmp->nexthere) {
+ if (otmp->otyp == CORPSE && will_feel_cockatrice(otmp, FALSE)) {
+ felt_cockatrice = TRUE;
+diff -ru nethack-3.6.0.orig/sys/unix/Makefile.src nethack-3.6.0/sys/unix/Makefile.src
+--- nethack-3.6.0.orig/sys/unix/Makefile.src 2015-11-12 08:51:56.000000000 +0100
++++ nethack-3.6.0/sys/unix/Makefile.src 2016-05-08 21:22:05.518161366 +0200
+@@ -222,8 +222,8 @@
#
#
--WINSRC = $(WINTTYSRC)
--WINOBJ = $(WINTTYOBJ)
-+WINSRC = $(WINTTYSRC) $(WINX11SRC)
-+WINOBJ = $(WINTTYOBJ) $(WINX11OBJ)
+-#WINSRC = $(WINTTYSRC)
+-#WINOBJ = $(WINTTYOBJ)
++WINSRC = $(WINTTYSRC) $(WINX11SRC)
++WINOBJ = $(WINTTYOBJ) $(WINX11OBJ)
# on some systems the termcap library is in -ltermcap or -lcurses
# on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
-@@ -230,8 +230,8 @@ WINOBJ = $(WINTTYOBJ)
+@@ -238,14 +238,14 @@
# WINTTYLIB = -ltermcap
# WINTTYLIB = -lcurses
# WINTTYLIB = -lcurses16
-# WINTTYLIB = -lncurses
--WINTTYLIB = -ltermlib
+WINTTYLIB = -lncurses
-+# WINTTYLIB = -ltermlib
+ #WINTTYLIB = -ltermlib
#
# libraries for X11
# If USE_XPM is defined in config.h, you will also need -lXpm here.
-@@ -255,7 +255,7 @@ WINGEMLIB = -le_gem -lgem
+-WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
++# WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
+ # WINX11LIB = -lXaw -lXmu -lXt -lX11
+-# WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11 -lm
++WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11 -lm
+ # WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -lm # BSD/OS 2.0
+ #
+ # libraries for Qt
+@@ -263,7 +263,7 @@
# libraries for BeOS
WINBELIB = -lbe
--WINLIB = $(WINTTYLIB)
+-#WINLIB = $(WINTTYLIB)
+WINLIB = $(WINTTYLIB) $(WINX11LIB)
# any other strange libraries your system needs (for Sysunix only -- the more
# specialized targets should already be right)
-diff --git a/win/X11/NetHack.ad b/win/X11/NetHack.ad
-index d7e9ed3..3682ed5 100644
---- a/win/X11/NetHack.ad
-+++ b/win/X11/NetHack.ad
-@@ -3,13 +3,13 @@
- ! The rip window applies if the GRAPHIC_TOMBSTONE option is turned on, and
- ! requires a 12 pixel font for correct appearance.
- !
--NetHack*font: variable
-+NetHack*font: fixed
- NetHack*display_file*font: fixed
- NetHack*tombstone*font: fixed
- NetHack*text*rip*font: -*-times-medium-r-*-*-12-*-*-*-*-*-*-*
- NetHack*menu*font: fixed
- NetHack*text*font: fixed
--NetHack*map*font: nh10
-+NetHack*map*font: fixed
-
- ! To use full-color tiles for the map, uncomment the tile file name.
- ! If you use a 100dpi (or greater) monitor you may wish to double the
-@@ -19,7 +19,7 @@ NetHack*map*font: nh10
- ! the custom format - to enlarge an XPM file, use processing tools
- ! such as XV or preferably PBMplus.
- !
--!NetHack.tile_file: x11tiles
-+NetHack.tile_file: x11tiles
- !NetHack.double_tile_size: True
- !
- ! The annotation of pets.
+diff -ru nethack-3.6.0.orig/sys/unix/Makefile.top nethack-3.6.0/sys/unix/Makefile.top
+--- nethack-3.6.0.orig/sys/unix/Makefile.top 2015-11-18 21:54:59.000000000 +0100
++++ nethack-3.6.0/sys/unix/Makefile.top 2016-05-08 21:44:50.649427698 +0200
+@@ -20,17 +20,17 @@
+ #PREFIX = /usr
+ GAME = nethack
+ # GAME = nethack.prg
+-#GAMEUID = games
+-#GAMEGRP = bin
++GAMEUID = root
++GAMEGRP = games
+
+ # Permissions - some places use setgid instead of setuid, for instance
+ # See also the option "SECURE" in include/config.h
+-#GAMEPERM = 04755
++GAMEPERM = 04755
+ FILEPERM = 0644
+-# VARFILEPERM = 0644
++VARFILEPERM = 0644
+ EXEPERM = 0755
+ DIRPERM = 0755
+-# VARDIRPERM = 0755
++VARDIRPERM = 0755
+
+ # VARDIR may also appear in unixconf.h as "VAR_PLAYGROUND" else HACKDIR
+ #
+@@ -39,15 +39,16 @@
+ # therefore there should not be anything in HACKDIR that you want to keep
+ # (if there is, you'll have to do the installation by hand or modify the
+ # instructions)
+-#HACKDIR = $(PREFIX)/games/lib/$(GAME)dir
+-#VARDIR = $(HACKDIR)
++HACKDIR = $(PREFIX)/games/$(GAME)
++VARDIR = "/var/games/nethack"
+ # Where nethack.sh in installed. If this is not defined, the wrapper is not used.
+-#SHELLDIR = $(PREFIX)/games
++SHELLDIR = $(PREFIX)/bin
++INSTDIR = $(HACKDIR)
+
+ # per discussion in Install.X11 and Install.Qt
+ #VARDATND =
+ # VARDATND = x11tiles NetHack.ad pet_mark.xbm pilemark.xpm
+-# VARDATND = x11tiles NetHack.ad pet_mark.xbm pilemark.xpm rip.xpm
++VARDATND = x11tiles NetHack.ad pet_mark.xbm pilemark.xbm rip.xpm
+ # for Atari/Gem
+ # VARDATND = nh16.img title.img GEM_RSC.RSC rip.img
+ # for BeOS
+@@ -69,8 +70,8 @@
+ # other permission-related reasons. If that happens, you may want to set the
+ # command to "true", which is a no-op. Note that disabling chown or chgrp
+ # will only work if setuid (or setgid) behavior is not desired or required.
+-#CHOWN = chown
+-#CHGRP = chgrp
++CHOWN = chown
++CHGRP = chgrp
+
+ #
+ # end of configuration