summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuint Guvernator2020-12-13 14:21:55 +0100
committerQuint Guvernator2020-12-13 14:21:55 +0100
commitb305971946a335ee0b8bb4fbc0292a9810eb5a1d (patch)
tree70cc44f170fbe3ccfbf7db845c0fba9b1bd29dd5
parentee90489169a9228e865a5921ca63ba69ed37b4c8 (diff)
downloadaur-b305971946a335ee0b8bb4fbc0292a9810eb5a1d.tar.gz
4.2.10: remove helpfile and app dir patches
-rw-r--r--.SRCINFO10
-rw-r--r--01-package-path.patch38
-rw-r--r--PKGBUILD13
-rw-r--r--hp15c_runner.sh6
4 files changed, 12 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8806e8f0f9c7..27ab0da7d235 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = hp15c
pkgdesc = A simulator for the HP-15C programmable scientific RPN calculator
- pkgver = 4.2.0
+ pkgver = 4.2.10
pkgrel = 1
url = http://hp-15c.homepage.t-online.de/content_web.htm
arch = any
license = GPL3
depends = tcl
depends = tk
- source = hp15c-4.2.0.zip::https://drive.google.com/uc?export=download&id=18bYkLY0hpizN3d2-yOpCTn1GhOIwsi4D
- source = 01-package-path.patch
+ source = hp15c-4.2.10.zip::https://drive.google.com/uc?export=download&id=1zPKq0wBP3wPMUOw_Fp9yDxOZ7sc4AOg0
source = hp15c_runner.sh
source = hp15c.desktop
- md5sums = c3d055f978eb9eba61589fb54204e189
- md5sums = c63c593bb9cc8083c33d54b87fafd2ad
- md5sums = 33588adff38833aa1a2957457d4701b3
+ md5sums = 11ae1e9894488ce38d0709d1e908e0bf
+ md5sums = 28b63da6ff5404acf6f305bdb35ca1b9
md5sums = bab776009feb1db971b92649c839ff1f
pkgname = hp15c
diff --git a/01-package-path.patch b/01-package-path.patch
deleted file mode 100644
index c4e5a9a3e615..000000000000
--- a/01-package-path.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff --git a/src/HP-15C.tcl b/src/HP-15C.tcl
-index f9957a3d809e..762d72d9ae9e 100644
---- a/HP-15C.tcl
-+++ b/HP-15C.tcl
-@@ -63,7 +63,7 @@ array set APPDATA {
- }
-
- set APPDATA(SerialNo) "$APPDATA(build)[string map {. {}} $APPDATA(version)]"
--set APPDATA(basedir) [file dirname [info script]]
-+set APPDATA(basedir) "/usr/lib/hp15c"
- set APPDATA(locale) [mclocale]
-
- # Load language according to current locale
-@@ -3399,22 +3399,7 @@ proc help { topic } {
-
- global APPDATA HP15 errorInfo
-
-- switch $topic {
-- simulator {
--# Differentiate between running from a starpack or from wish
-- if {[info exists ::starkit::topdir]} {
-- set helpdir [file dirname $::starkit::topdir]
-- } else {
-- set helpdir [file dirname $::argv0]
-- }
-- if {$helpdir eq "."} {set helpdir [pwd]}
-- set helpfile "$helpdir/doc/index.htm"
-- }
-- prgm {
-- set helpfile "$HP15(prgmdir)/$HP15(prgmname).htm"
-- }
-- }
-- catch {set helpfile [file nativename [lindex [glob "$helpfile*"] 0]]}
-+ set helpfile "/usr/share/doc/hp15c/index.htm"
-
- if {[string length $HP15(browser)] == 0} {
- set msg [mc help.nobrowser]
----
diff --git a/PKGBUILD b/PKGBUILD
index d706a34491a2..8fe3d41f817d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Pipat Saengow <pay2630@gmail.com>
pkgname=hp15c
-pkgver=4.2.0
+pkgver=4.2.10
pkgrel=1
pkgdesc="A simulator for the HP-15C programmable scientific RPN calculator"
url="http://hp-15c.homepage.t-online.de/content_web.htm"
@@ -10,21 +10,16 @@ arch=('any')
license=('GPL3')
depends=('tcl' 'tk')
source=(
- "$pkgname-$pkgver.zip::https://drive.google.com/uc?export=download&id=18bYkLY0hpizN3d2-yOpCTn1GhOIwsi4D"
- "01-package-path.patch"
+ "$pkgname-$pkgver.zip::https://drive.google.com/uc?export=download&id=1zPKq0wBP3wPMUOw_Fp9yDxOZ7sc4AOg0"
"hp15c_runner.sh"
"hp15c.desktop"
)
-md5sums=('c3d055f978eb9eba61589fb54204e189'
- 'c63c593bb9cc8083c33d54b87fafd2ad'
- '33588adff38833aa1a2957457d4701b3'
+md5sums=('11ae1e9894488ce38d0709d1e908e0bf'
+ '28b63da6ff5404acf6f305bdb35ca1b9'
'bab776009feb1db971b92649c839ff1f')
prepare() {
- # patch location of files to match Arch standards
- patch -p1 -i "$srcdir/01-package-path.patch"
-
# extract icons
unzip icons/HP-15C-logo.zip -d $srcdir/icon_extract
}
diff --git a/hp15c_runner.sh b/hp15c_runner.sh
index 7d4500b66f49..abad9a2f90d3 100644
--- a/hp15c_runner.sh
+++ b/hp15c_runner.sh
@@ -1,4 +1,6 @@
#!/bin/sh
# runs HP-15C tcl script in proper directory
-cd /usr/lib/hp15c
-/usr/bin/wish HP-15C.tcl "$@"
+exec env \
+ -C /usr/lib/hp15c \
+ HP15Cdocdir=/usr/share/doc/hp15c/ \
+ /usr/bin/wish HP-15C.tcl "$@"