summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-28 21:41:49 +0200
committerChristian Hesse2015-06-28 21:41:49 +0200
commitb31577108e9093e805d3c90ce0cd9bda7ff254a2 (patch)
tree1d94b28cabe612b86cb542428200b71d88594ba4
downloadaur-b31577108e9093e805d3c90ce0cd9bda7ff254a2.tar.gz
initial import of nullshell 0.0.6-2
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
-rw-r--r--nullshell.install12
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..428a4f91e62f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = nullshell
+ pkgdesc = do nothing but print keep alive characters, can be used for login shell
+ pkgver = 0.0.6
+ pkgrel = 2
+ url = https://github.com/eworm-de/nullshell
+ install = nullshell.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = markdown
+ conflicts = nullshell-git
+ source = http://www.eworm.de/download/nullshell/nullshell-0.0.6.tar.xz
+ source = http://www.eworm.de/download/nullshell/nullshell-0.0.6.tar.xz.asc
+ sha256sums = 8ed1d29df5a8f6639f559b7a294010791d20140e85106cb0d34e6a1c194b31c9
+ sha256sums = SKIP
+
+pkgname = nullshell
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6d84f6cc312
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=nullshell
+pkgver=0.0.6
+pkgrel=2
+pkgdesc="do nothing but print keep alive characters, can be used for login shell"
+arch=('i686' 'x86_64')
+makedepends=('markdown')
+url="https://github.com/eworm-de/nullshell"
+conflicts=('nullshell-git')
+license=('GPL')
+install=nullshell.install
+validpgpkeys=('BD84DE71F493DF6814B0167254EDC91609BC9183')
+source=("http://www.eworm.de/download/${pkgname}/${pkgname}-${pkgver}.tar.xz"{,.asc})
+sha256sums=('8ed1d29df5a8f6639f559b7a294010791d20140e85106cb0d34e6a1c194b31c9'
+ 'SKIP')
+
+build() {
+ cd ${pkgname}-${pkgver}/
+
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}/
+
+ make DESTDIR="${pkgdir}" install
+}
+
diff --git a/nullshell.install b/nullshell.install
new file mode 100644
index 000000000000..5749d548805d
--- /dev/null
+++ b/nullshell.install
@@ -0,0 +1,12 @@
+post_install() {
+ grep -qe '^/bin/nullshell$' etc/shells || echo '/bin/nullshell' >> etc/shells
+ grep -qe '^/usr/bin/nullshell$' etc/shells || echo '/usr/bin/nullshell' >> etc/shells
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ sed -i -r '/^(\/usr)?\/bin\/nullshell$/d' etc/shells
+}