summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2017-11-14 22:16:31 -0500
committerTed Alff2017-11-14 22:16:31 -0500
commitb317084d42715d9aad9ad8f6048bd605fbad37a4 (patch)
tree2757cf77e83f0215de8653dcc2af1ace01f604c9
downloadaur-b317084d42715d9aad9ad8f6048bd605fbad37a4.tar.gz
Initial commit. thunarx-3 (GTK3) version
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD43
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..49dd3eb31456
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Wed Nov 15 03:16:11 UTC 2017
+pkgbase = thunar-archive-plugin-git
+ pkgdesc = Create and extract archives in Thunar (git checkout)
+ pkgver = 0.3.1.r121.g7d3aa28
+ pkgrel = 1
+ url = http://goodies.xfce.org/projects/thunar-plugins/thunar-archive-plugin
+ arch = i686
+ arch = x86_64
+ groups = xfce4-goodies
+ license = GPL2
+ makedepends = intltool
+ makedepends = xfce4-dev-tools
+ makedepends = git
+ depends = thunar-git
+ depends = hicolor-icon-theme
+ optdepends = file-roller
+ optdepends = ark
+ optdepends = xarchiver
+ optdepends = engrampa-thunar
+ provides = thunar-archive-plugin=0.3.1
+ conflicts = thunar-archive-plugin
+ source = thunar-archive-plugin::git://git.xfce.org/thunar-plugins/thunar-archive-plugin
+ sha256sums = SKIP
+
+pkgname = thunar-archive-plugin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b41ca3a0520
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: twa022 <twa022 at gmail dot com>
+
+_pkgname=thunar-archive-plugin
+pkgname=${_pkgname}-git
+pkgver=0.3.1.r121.g7d3aa28
+pkgrel=1
+pkgdesc="Create and extract archives in Thunar (git checkout)"
+arch=('i686' 'x86_64')
+url="http://goodies.xfce.org/projects/thunar-plugins/thunar-archive-plugin"
+license=('GPL2')
+groups=('xfce4-goodies')
+depends=('thunar-git' 'hicolor-icon-theme')
+makedepends=('intltool' 'xfce4-dev-tools' 'git')
+optdepends=('file-roller'
+ 'ark'
+ 'xarchiver'
+ 'engrampa-thunar')
+provides=("${_pkgname}=${pkgver%\.r*}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git://git.xfce.org/thunar-plugins/thunar-archive-plugin")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed -r "s:^${_pkgname}.::;s/^v//;s/([^-]*-g)/r\1/;s/-/./g"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ ./autogen.sh \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/xfce4 \
+ --localstatedir=/var \
+ --disable-static
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="$pkgdir" install
+}