summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoradiazcaro2018-08-22 17:36:16 -0300
committeradiazcaro2018-08-22 17:36:16 -0300
commitb356c57adf23fe3190f73b76d1bc09eda20a4aa2 (patch)
treefae4267c11a4bb2da96e1b33f8322e9804d00b2f
downloadaur-b356c57adf23fe3190f73b76d1bc09eda20a4aa2.tar.gz
First commit of this package
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD42
-rw-r--r--deb888677.patch30
-rw-r--r--notimer.patch19
4 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e177d2c29914
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = pdfpc-notimer
+ pkgdesc = PDFPC with a patch to not show the timer in the presentations.
+ pkgver = 4.1.2
+ pkgrel = 2
+ url = https://pdfpc.github.io/
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = vala
+ depends = gtk3
+ depends = poppler-glib
+ depends = libgee
+ depends = gstreamer
+ depends = gst-plugins-base
+ optdepends = gst-plugins-good: more codecs for video playback support
+ optdepends = gst-libav: more codecs for video playback support
+ conflicts = pdfpc
+ source = pdfpc-4.1.2.tar.gz::https://github.com/pdfpc/pdfpc/archive/v4.1.2.tar.gz
+ source = deb888677.patch::https://github.com/pdfpc/pdfpc/commit/21e4efb3afe325fe7e2f800d1c22fd1bc28bc3d7.patch
+ source = notimer.patch
+ sha256sums = 0fcacd0deac39d93e21fc152b0cb01279b4ba209934fe385be6811236a03c87d
+ sha256sums = 8546c86cbcbf24491c9f44f7fd294de144b3bee57725cea8827e0006239ebcef
+ sha256sums = 79d728ca0d88c6d2007643d6b528d5a5aa4c144008143f3bd00d7b419256860b
+
+pkgname = pdfpc-notimer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06776345e490
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Alejandro Díaz-Caro <alejandro@diaz-caro.info>
+
+pkgname=pdfpc-notimer
+pkgver=4.1.2
+_pkgver=$pkgver
+pkgrel=2
+pkgdesc='PDFPC with a patch to not show the timer in the presentations.'
+arch=('x86_64')
+url='https://pdfpc.github.io/'
+license=('GPL')
+depends=('gtk3' 'poppler-glib' 'libgee' 'gstreamer' 'gst-plugins-base')
+optdepends=('gst-plugins-good: more codecs for video playback support'
+ 'gst-libav: more codecs for video playback support')
+makedepends=('cmake' 'vala')
+conflicts=('pdfpc')
+source=("pdfpc-$_pkgver.tar.gz::https://github.com/pdfpc/pdfpc/archive/v$_pkgver.tar.gz"
+"deb888677.patch::https://github.com/pdfpc/pdfpc/commit/21e4efb3afe325fe7e2f800d1c22fd1bc28bc3d7.patch"
+"notimer.patch")
+
+sha256sums=('0fcacd0deac39d93e21fc152b0cb01279b4ba209934fe385be6811236a03c87d'
+ '8546c86cbcbf24491c9f44f7fd294de144b3bee57725cea8827e0006239ebcef'
+ '79d728ca0d88c6d2007643d6b528d5a5aa4c144008143f3bd00d7b419256860b')
+
+prepare() {
+ cd "$srcdir/pdfpc-$_pkgver"
+ patch -p1 <../deb888677.patch ## reverse the pr344 to fix video playback
+ patch -Np1 -i "$srcdir/notimer.patch" ## do not print the timer
+ ## see https://bugs.archlinux.org/task/58786
+}
+
+build() {
+ cd "$srcdir/pdfpc-$_pkgver"
+ cmake -DCMAKE_INSTALL_PREFIX="/usr/" -DSYSCONFDIR="/etc" .
+ make
+}
+
+package() {
+ cd "$srcdir/pdfpc-$_pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=4 sw=4 et:
diff --git a/deb888677.patch b/deb888677.patch
new file mode 100644
index 000000000000..8cd7a2a14c55
--- /dev/null
+++ b/deb888677.patch
@@ -0,0 +1,30 @@
+From 21e4efb3afe325fe7e2f800d1c22fd1bc28bc3d7 Mon Sep 17 00:00:00 2001
+From: Andreas Bilke <andreas@bilke.org>
+Date: Wed, 23 May 2018 19:51:00 +0200
+Subject: [PATCH] Fix regression introduced in
+ 13e3b372711fdc94acdb26be69ef0cf1465911ed
+
+See Debian Bug 888677.
+---
+ src/classes/metadata/pdf.vala | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/src/classes/metadata/pdf.vala b/src/classes/metadata/pdf.vala
+index 30493e3..0e3c253 100644
+--- a/src/classes/metadata/pdf.vala
++++ b/src/classes/metadata/pdf.vala
+@@ -442,10 +442,12 @@ namespace pdfpc.Metadata {
+ note_text += "\n";
+ }
+ note_text += a.get_contents();
++
++ // Remove the annotation to avoid its rendering
++ page.remove_annot(a);
++
+ break;
+ }
+- // Remove the annotation to avoid its rendering
+- page.remove_annot(a);
+ }
+ if (note_text != "") {
+ this.notes.set_note(note_text, user_slide, true);
diff --git a/notimer.patch b/notimer.patch
new file mode 100644
index 000000000000..bc3ab48a494b
--- /dev/null
+++ b/notimer.patch
@@ -0,0 +1,19 @@
+diff -ura pdfpc-4.1.2.orig/src/classes/timer_label.vala pdfpc-4.1.2.new/src/classes/timer_label.vala
+--- pdfpc-4.1.2.orig/src/classes/timer_label.vala 2018-08-22 16:32:38.500386644 -0300
++++ pdfpc-4.1.2.new/src/classes/timer_label.vala 2018-08-22 16:33:30.163549315 -0300
+@@ -204,14 +204,7 @@
+ minutes = timeInSecs / 60 % 60;
+ seconds = timeInSecs % 60 % 60;
+
+- this.set_text(
+- "%s%.2u:%.2u:%.2u".printf(
+- prefix,
+- hours,
+- minutes,
+- seconds
+- )
+- );
++ this.set_text("");
+ }
+ }
+