summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2021-11-20 23:45:43 +0200
committerAdrian Perez de Castro2021-11-20 23:45:43 +0200
commitb3620dbfd09e2a335d4f59a91312dd47eee5013b (patch)
tree6f8d2f932429de8ca8ed2563086ae0eea33992c2
parentaf7e7f67a4b582ac64770b73a25b1abeb78cb8b5 (diff)
downloadaur-b3620dbfd09e2a335d4f59a91312dd47eee5013b.tar.gz
Bring up to date, re-add variants
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 36 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b754f6be6dbc..d8aa6255b253 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,25 @@
pkgbase = xcursor-simp1e
pkgdesc = An aesthetic cursor theme
- pkgver = 0.0.20210719
- pkgrel = 2
+ pkgver = 0.0.20211003
+ pkgrel = 1
url = https://gitlab.com/zoli111/simp1e/
arch = any
license = GPL3
makedepends = git
- makedepends = inkscape
+ makedepends = librsvg
makedepends = python-pillow
makedepends = xorg-xcursorgen
- source = xcursor-simp1e::git+https://gitlab.com/zoli111/simp1e/#commit=995f50da41786263c89f10ddb72416a61462c973
+ source = xcursor-simp1e::git+https://gitlab.com/zoli111/simp1e/#commit=6a9e969b0239a58fc96af787c4986c273eb6d0eb
source = builder_script::git+https://github.com/mxre/cursor
sha512sums = SKIP
sha512sums = SKIP
pkgname = xcursor-simp1e
+
+pkgname = xcursor-simp1e-breeze
+
+pkgname = xcursor-simp1e-breeze-snow
+
+pkgname = xcursor-simp1e-dark
+
+pkgname = xcursor-simp1e-solarized
diff --git a/PKGBUILD b/PKGBUILD
index 9e5ad78adf66..f3cf872dd4bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
-pkgname=xcursor-simp1e
+pkgbase=xcursor-simp1e
+pkgname=(xcursor-simp1e{,-breeze{,-snow},-dark,-solarized})
pkgdesc='An aesthetic cursor theme'
-pkgver=0.0.20210719
-pkgrel=2
+pkgver=0.0.20211003
+pkgrel=1
url=https://gitlab.com/zoli111/simp1e/
-_commit=995f50da41786263c89f10ddb72416a61462c973
+_commit=6a9e969b0239a58fc96af787c4986c273eb6d0eb
arch=(any)
-makedepends=(git inkscape python-pillow xorg-xcursorgen)
+makedepends=(git librsvg python-pillow xorg-xcursorgen)
depends=()
license=(GPL3)
source=("${pkgname}::git+${url}#commit=${_commit}"
@@ -25,7 +26,23 @@ build () {
./build.sh
}
-package () {
+_package () {
install -dm755 "${pkgdir}/usr/share/icons"
- cp -a "${pkgbase}/built_themes/Simp1e" "${pkgdir}/usr/share/icons"
+ cp -a "${pkgbase}/built_themes/$1" "${pkgdir}/usr/share/icons"
+}
+
+package_xcursor-simp1e () {
+ _package Simp1e
+}
+package_xcursor-simp1e-dark () {
+ _package Simp1e-dark
+}
+package_xcursor-simp1e-breeze () {
+ _package Simp1e-breeze
+}
+package_xcursor-simp1e-breeze-snow () {
+ _package Simp1e-breeze-snow
+}
+package_xcursor-simp1e-solarized () {
+ _package Simp1e-solarized
}