summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2018-12-25 08:12:19 -0500
committerAndrew Sun2018-12-25 08:12:19 -0500
commitb39508b68fac1377190d3db7534de976fa3dcac3 (patch)
treed7d0caf2fadd05964cf1396084828bc72d98dd80
parent821fdcb56b91f2a5de312674d46ca9768f390b79 (diff)
downloadaur-b39508b68fac1377190d3db7534de976fa3dcac3.tar.gz
mingw-w64-sundials: update to 4.0.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e89f9765e43..b344b9e5a16a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-sundials
pkgdesc = Suite of nonlinear differential/algebraic equation solvers (mingw-w64)
- pkgver = 4.0.0
+ pkgver = 4.0.1
pkgrel = 1
url = https://computation.llnl.gov/casc/sundials/main.html
arch = any
@@ -10,8 +10,8 @@ pkgbase = mingw-w64-sundials
options = !buildflags
options = staticlibs
options = !strip
- source = http://computation.llnl.gov/projects/sundials/download/sundials-4.0.0.tar.gz
- sha256sums = 953dd7c30d25d5e28f6aa4d803c5b6160294a5c0c9572ac4e9c7e2d461bd9a19
+ source = http://computation.llnl.gov/projects/sundials/download/sundials-4.0.1.tar.gz
+ sha256sums = 29e409c8620e803990edbda1ebf49e03a38c08b9187b90658d86bddae913aed4
pkgname = mingw-w64-sundials
diff --git a/PKGBUILD b/PKGBUILD
index bef7704489d1..946585918ceb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrew Sun <adsun701@gmail.com>
pkgname=mingw-w64-sundials
-pkgver=4.0.0
+pkgver=4.0.1
pkgrel=1
pkgdesc="Suite of nonlinear differential/algebraic equation solvers (mingw-w64)"
arch=('any')
@@ -10,13 +10,13 @@ license=('BSD')
depends=('mingw-w64-lapack')
makedepends=('mingw-w64-cmake')
options=('!buildflags' 'staticlibs' '!strip')
-source=("http://computation.llnl.gov/projects/sundials/download/sundials-$pkgver.tar.gz")
-sha256sums=('953dd7c30d25d5e28f6aa4d803c5b6160294a5c0c9572ac4e9c7e2d461bd9a19')
+source=("http://computation.llnl.gov/projects/sundials/download/sundials-${pkgver}.tar.gz")
+sha256sums=('29e409c8620e803990edbda1ebf49e03a38c08b9187b90658d86bddae913aed4')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
- cd "$srcdir"/sundials-${pkgver}
+ cd "${srcdir}/sundials-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake \
@@ -32,12 +32,12 @@ build() {
package() {
for _arch in ${_architectures}; do
- cd "$srcdir"/sundials-${pkgver}/build-${_arch}
- make install DESTDIR="$pkgdir"
- install -d "$pkgdir"/usr/${_arch}/bin/
- mv "$pkgdir"/usr/${_arch}/lib/*.dll "$pkgdir"/usr/${_arch}/bin/
- ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
- ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ cd "${srcdir}/sundials-${pkgver}/build-${_arch}"
+ make install DESTDIR="${pkgdir}"
+ install -d "${pkgdir}"/usr/${_arch}/bin/
+ mv "${pkgdir}"/usr/${_arch}/lib/*.dll "${pkgdir}"/usr/${_arch}/bin/
+ ${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "${pkgdir}"/usr/${_arch}/lib/*.a
done
}