summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-03-30 21:07:38 +0100
committersL1pKn072019-03-30 21:07:38 +0100
commitb3b0c1d020e05a466ff6105a39f7dede7cbe9cf3 (patch)
treec06707699a6cce50dd8684770211b09a6046bc40
downloadaur-b3b0c1d020e05a466ff6105a39f7dede7cbe9cf3.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b333daa6ee03
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Mar 30 20:07:37 UTC 2019
+pkgbase = vapoursynth-plugin-hdr2sdr-git
+ pkgdesc = Plugin for Vapoursynth: hdr2sdr (GIT version)
+ pkgver = r2
+ pkgrel = 1
+ url = https://gist.github.com/4re
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-hdr2sdr
+ conflicts = vapoursynth-plugin-hdr2sdr
+ source = hdr2sdr::git+https://gist.github.com/4re/34ccbb95732c1bef47c3d2975ac62395
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-hdr2sdr-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..929a2184fd71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=hdr2sdr
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r2
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url='https://gist.github.com/4re'
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://gist.github.com/4re/34ccbb95732c1bef47c3d2975ac62395")
+sha256sums=('SKIP')
+
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+ printf "r%s" "$(git rev-list --count HEAD)"
+}
+
+package() {
+ cd "${_plug}"
+ install -Dm644 "${_plug}.py" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+}