summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-11-16 08:32:32 +1300
committercaltlgin2020-11-16 08:32:32 +1300
commitb3c1f0e392f210d056b12cedd7ac68052363ddd3 (patch)
tree46c71ddc1f7ad0112b94a188d5d6d9427dd8c4e7
parent4ff48b858b17be66a754033cff88ddcaa0972909 (diff)
downloadaur-b3c1f0e392f210d056b12cedd7ac68052363ddd3.tar.gz
Fix run script
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD47
-rwxr-xr-xsherlock.sh2
4 files changed, 32 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 680dc45777e5..81c9d7b43646 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sherlock-git
pkgdesc = Hunt down social media accounts by username across social networks
- pkgver = r1276.ca89d12
+ pkgver = r1480.9d824d1
pkgrel = 1
url = https://github.com/sherlock-project/sherlock
arch = any
@@ -19,10 +19,9 @@ pkgbase = sherlock-git
depends = python-stem
depends = python-torrequest
provides = sherlock
- source = sherlock::git+https://github.com/sherlock-project/sherlock.git
- source = sherlock.sh
+ conflicts = sherlock
+ source = git+https://github.com/sherlock-project/sherlock.git
sha256sums = SKIP
- sha256sums = 21c364a2de4c5a491d85c1e6e9ecb4913505a436aa0db75fe98b367209913500
pkgname = sherlock-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4367ae4a50ac
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 96c9ab3912c0..c462adc6d6b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,47 @@
# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
# Contributor: peeweep <peeweep at 0x0 dot ee>
-_pkgname=sherlock
-pkgname=${_pkgname}-git
-pkgver=r1276.ca89d12
+_pkgname='sherlock'
+pkgname="${_pkgname}-git"
+pkgver=r1480.9d824d1
pkgrel=1
pkgdesc='Hunt down social media accounts by username across social networks'
arch=('any')
url='https://github.com/sherlock-project/sherlock'
license=('MIT')
depends=('python'
- 'python-beautifulsoup4'
- 'python-certifi'
- 'python-colorama'
- 'python-lxml'
- 'python-pysocks'
- 'python-requests'
- 'python-requests-futures'
- 'python-soupsieve'
- 'python-stem'
- 'python-torrequest')
+ 'python-beautifulsoup4'
+ 'python-certifi'
+ 'python-colorama'
+ 'python-lxml'
+ 'python-pysocks'
+ 'python-requests'
+ 'python-requests-futures'
+ 'python-soupsieve'
+ 'python-stem'
+ 'python-torrequest')
makedepends=('git' 'python-setuptools')
provides=("${_pkgname}")
-source=("${_pkgname}::git+${url}.git"
- "${_pkgname}.sh")
-sha256sums=('SKIP'
- '21c364a2de4c5a491d85c1e6e9ecb4913505a436aa0db75fe98b367209913500')
+conflicts=("${_pkgname}")
+source=("git+${url}.git")
+sha256sums=('SKIP')
pkgver() {
cd "${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ echo -e "#!/bin/sh\nexec python /usr/share/${_pkgname}/${_pkgname}.py \"\$@\"" > "${_pkgname}.sh"
+}
+
package() {
- install -Dm755 "${_pkgname}.sh" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dvm755 "${_pkgname}.sh" "${pkgdir}/usr/bin/${_pkgname}"
cd "${_pkgname}"
- install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" {removed_sites.md,sites.md,README.md}
- install -Dm644 -t "${pkgdir}/usr/share/licenses/${_pkgname}" 'LICENSE'
- install -dm755 "${pkgdir}/usr/share/${_pkgname}"
- cp -a "${_pkgname}/"* "${pkgdir}/usr/share/${_pkgname}"
+ install -Dvm644 {'removed_sites.md','sites.md','README.md'} -t "${pkgdir}/usr/share/doc/${_pkgname}"
+ install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${_pkgname}"
+ install -dv "${pkgdir}/usr/share/${_pkgname}"
+ cp -afv "${_pkgname}/"* "${pkgdir}/usr/share/${_pkgname}"
}
# vim: ts=2 sw=2 et:
diff --git a/sherlock.sh b/sherlock.sh
deleted file mode 100755
index 788a57c4cc8b..000000000000
--- a/sherlock.sh
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-cd /usr/share/sherlock && exec python sherlock.py "$@"