summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMort Yao2016-03-13 06:35:35 +0100
committerMort Yao2016-03-13 06:35:35 +0100
commitb3c987570a415cdc0aa0f6579342e88be81af118 (patch)
tree2f2dbceb0eb08aeaa778a15c11c7e9cc7d014c20
downloadaur-b3c987570a415cdc0aa0f6579342e88be81af118.tar.gz
twelf 1.7.1
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD28
-rw-r--r--twelf.install13
4 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94e429f7cfb7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Sun Mar 13 05:34:59 UTC 2016
+pkgbase = twelf
+ pkgdesc = An implementation of the logical framework LF
+ pkgver = 1.7.1
+ pkgrel = 1
+ url = http://twelf.org/
+ install = twelf.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = smlnj
+ depends = bash
+ depends = gmp
+ depends = smlnj
+ provides = twelf
+ conflicts = twelf-git
+ source = http://twelf.org/releases/twelf-src-1.7.1.tar.gz
+ md5sums = 1cb556366dd534f8c1c858614dd57e16
+
+pkgname = twelf
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a6289c1c9dbb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+/pkg
+/src
+*-git/
+*.bz2
+*.gz
+*.tar
+*.xz
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de9e985b5c10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Mort Yao <soi@mort.ninja>
+
+pkgname=twelf
+pkgver=1.7.1
+pkgrel=1
+pkgdesc='An implementation of the logical framework LF'
+url='http://twelf.org/'
+license=('BSD')
+arch=('i686' 'x86_64')
+depends=('bash' 'gmp' 'smlnj')
+makedepends=('smlnj')
+provides=('twelf')
+conflicts=('twelf-git')
+install=$pkgname.install
+source=("http://twelf.org/releases/twelf-src-$pkgver.tar.gz")
+md5sums=('1cb556366dd534f8c1c858614dd57e16')
+
+build() {
+ cd "$pkgname"
+ make smlnj
+}
+
+package() {
+ cd "$pkgname"
+ install -d -m755 $pkgdir/opt/twelf $pkgdir/usr/bin
+ cp -r . $pkgdir/opt/twelf
+ ln -s /opt/twelf/bin/twelf-server $pkgdir/usr/bin/twelf-server
+}
diff --git a/twelf.install b/twelf.install
new file mode 100644
index 000000000000..e199d04e3c65
--- /dev/null
+++ b/twelf.install
@@ -0,0 +1,13 @@
+post_install() {
+ cat <<EOF
+*************************************************
+Twelf Emacs Integration
+*************************************************
+Add
+
+(setq twelf-root "/opt/twelf/")
+(load (concat twelf-root "emacs/twelf-init.el"))
+
+to your .emacs file
+EOF
+}