summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2018-12-06 02:55:19 -0200
committerDanilo J. S. Bellini2018-12-06 02:55:19 -0200
commitb3d46e289c2a636489d0f97293523227b2660e46 (patch)
tree294a956ebb886023dca9cafc4192ca7c569369b1
parentd2afc6496c3f4565221d88a875f2f2ab78b6d324 (diff)
downloadaur-b3d46e289c2a636489d0f97293523227b2660e46.tar.gz
v4.4.0-3: Patch to make Human work
The previous patch suffices if one just need to import the library, but not for one who wants to use the axl.Human class This new patch makes the Human class work with prompt_toolkit v2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d49e8df5fadc..1a31cd81a24e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-axelrod
pkgdesc = Research tool for the Iterated Prisoner's Dilemma
pkgver = 4.4.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/Axelrod-Python/Axelrod
arch = any
license = MIT
@@ -16,9 +16,9 @@ pkgbase = python-axelrod
depends = python-tqdm
options = !emptydirs
source = https://github.com/Axelrod-Python/Axelrod/archive/v4.4.0.tar.gz
- source = https://github.com/Axelrod-Python/Axelrod/commit/8dba4c0.patch
+ source = https://github.com/Axelrod-Python/Axelrod/commit/0a7a1b0.patch
sha256sums = 1f8f8386ab292877e9c063aa371e0d5709a969cce9cba828ee95567be1858c7e
- sha256sums = 4d9d11b7d8ccd2074295b92b4961fd76b25e3948cb8e9836acd0123a5b6166f2
+ sha256sums = d7497624ecafa3f9f57e0be82c8f88f3a12e34c1727266fbbbf2e66fd67ce370
pkgname = python-axelrod
diff --git a/PKGBUILD b/PKGBUILD
index f1e41f45260b..2763fbb2efa6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
pkgname=('python-axelrod')
pkgver=4.4.0
-pkgrel=2
+pkgrel=3
pkgdesc="Research tool for the Iterated Prisoner's Dilemma"
arch=('any')
url='https://github.com/Axelrod-Python/Axelrod'
@@ -13,15 +13,15 @@ depends=('python-dask'
'python-tqdm')
options=(!emptydirs)
sha256sums=('1f8f8386ab292877e9c063aa371e0d5709a969cce9cba828ee95567be1858c7e'
- '4d9d11b7d8ccd2074295b92b4961fd76b25e3948cb8e9836acd0123a5b6166f2')
+ 'd7497624ecafa3f9f57e0be82c8f88f3a12e34c1727266fbbbf2e66fd67ce370')
source=("$url/archive/v$pkgver.tar.gz"
- "$url/commit/8dba4c0.patch")
+ "$url/commit/0a7a1b0.patch")
prepare() {
cd "$srcdir/Axelrod-$pkgver"
- # Reverse the 8dba4c0 commit as we have prompt_toolkit v2, not v1
- patch -Rp1 < "$srcdir/8dba4c0.patch"
+ # Apply the 0a7a1b0 commit as we have prompt_toolkit v2, not v1
+ patch -p1 < "$srcdir/0a7a1b0.patch"
# Avoid installing optional/unrequired dependencies
echo > "requirements.txt"