summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-10-18 12:19:20 +0800
committerChocobo12020-10-18 12:19:20 +0800
commitb3e4e5a1b2e775b59cc505b4c6257e440cb71d1a (patch)
treeb220656bb9f4192cbca70809e611f783d75a3e95
parent469f1125e6a54a59920e16e919952262b18a984e (diff)
downloadaur-b3e4e5a1b2e775b59cc505b4c6257e440cb71d1a.tar.gz
upgpkg: libpcap-git 1.10.0.bp.r15.ge13fde1e-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f4f9401e8c1..09ca547efeb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libpcap-git
pkgdesc = A portable C/C++ library for network traffic capture
- pkgver = 1.8.1.r205.g69fcdc66
+ pkgver = 1.10.0.bp.r15.ge13fde1e
pkgrel = 1
url = https://www.tcpdump.org/
arch = i686
@@ -9,10 +9,10 @@ pkgbase = libpcap-git
makedepends = git
makedepends = bluez-libs
depends = glibc
- depends = libnl
- depends = libusbx
depends = dbus
+ depends = libnl
provides = libpcap
+ provides = libpcap.so
conflicts = libpcap
options = staticlibs
source = git+https://github.com/the-tcpdump-group/libpcap.git
diff --git a/PKGBUILD b/PKGBUILD
index d5b7659015da..a1f27a738255 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=libpcap-git
-pkgver=1.8.1.r205.g69fcdc66
+pkgver=1.10.0.bp.r15.ge13fde1e
pkgrel=1
pkgdesc="A portable C/C++ library for network traffic capture"
arch=('i686' 'x86_64')
url="https://www.tcpdump.org/"
license=('BSD')
-depends=('glibc' 'libnl' 'libusbx' 'dbus')
+depends=('glibc' 'dbus' 'libnl')
makedepends=('git' 'bluez-libs')
-provides=('libpcap')
+provides=('libpcap' 'libpcap.so')
conflicts=('libpcap')
options=('staticlibs')
source=("git+https://github.com/the-tcpdump-group/libpcap.git")
@@ -25,7 +25,9 @@ pkgver() {
build() {
cd "libpcap"
- ./configure --prefix="/usr"
+ autoreconf -fi
+ ./configure \
+ --prefix="/usr"
make
}
@@ -39,5 +41,5 @@ package() {
cd "libpcap"
make DESTDIR="$pkgdir" install
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/libpcap/LICENSE"
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/libpcap"
}