summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsoloturn2020-11-17 06:49:30 +0100
committersoloturn2020-11-17 06:49:30 +0100
commitb3f6d6691d406c36bea932162f681dab176ffe4a (patch)
treee054f0864d05a5f7a5c0d1a9906d56fccdf6aa02
parentec9f66275fa44a99cce4c73b64f6a7e106416620 (diff)
downloadaur-b3f6d6691d406c36bea932162f681dab176ffe4a.tar.gz
remove unused patches, incl repl
-rw-r--r--cmark-python38.patch32
-rw-r--r--glibc-includes.patch131
-rw-r--r--repl_swift-dl.patch12
-rw-r--r--sanitizer-glibc2.31.patch46
-rw-r--r--swift-tests-glibc.patch40
-rw-r--r--swiftpm-glibc.patch25
6 files changed, 0 insertions, 286 deletions
diff --git a/cmark-python38.patch b/cmark-python38.patch
deleted file mode 100644
index d10fec717359..000000000000
--- a/cmark-python38.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 68c3a91166347a32a57fb81223750a63cfd92105 Mon Sep 17 00:00:00 2001
-From: John MacFarlane <jgm@berkeley.edu>
-Date: Wed, 27 Nov 2019 22:04:16 -0800
-Subject: [PATCH] normalize.py: use html.escape instead of cgi.escape.
-
-Closes #313.
----
- test/normalize.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/test/normalize.py b/test/normalize.py
-index 6073bf01..f8ece18d 100644
---- a/test/normalize.py
-+++ b/test/normalize.py
-@@ -13,7 +13,7 @@ class HTMLParseError(Exception):
- from html.entities import name2codepoint
- import sys
- import re
--import cgi
-+import html
-
- # Normalization code, adapted from
- # https://github.com/karlcow/markdown-testsuite/
-@@ -66,7 +66,7 @@ def handle_starttag(self, tag, attrs):
- self.output += ("=" + '"' +
- urllib.quote(urllib.unquote(v), safe='/') + '"')
- elif v != None:
-- self.output += ("=" + '"' + cgi.escape(v,quote=True) + '"')
-+ self.output += ("=" + '"' + html.escape(v,quote=True) + '"')
- self.output += ">"
- self.last_tag = tag
- self.last = "starttag"
diff --git a/glibc-includes.patch b/glibc-includes.patch
deleted file mode 100644
index dde6046dca84..000000000000
--- a/glibc-includes.patch
+++ /dev/null
@@ -1,131 +0,0 @@
-diff -rupN a/stdlib/public/Platform/glibc.modulemap.gyb b/stdlib/public/Platform/glibc.modulemap.gyb
---- a/stdlib/public/Platform/glibc.modulemap.gyb 2018-09-12 17:46:19.000000000 -0700
-+++ b/stdlib/public/Platform/glibc.modulemap.gyb 2018-09-24 10:41:46.699830262 -0700
-@@ -333,7 +333,7 @@ module SwiftGlibc [system] {
- export *
- }
- module ioctl {
-- header "${GLIBC_ARCH_INCLUDE_PATH}/sys/ioctl.h"
-+ header "${GLIBC_INCLUDE_PATH}/sys/ioctl.h"
- export *
- }
- module libgen {
-@@ -392,97 +392,97 @@ module SwiftGlibc [system] {
-
- % if CMAKE_SDK in ["LINUX", "FREEBSD", "CYGWIN", "HAIKU"]:
- module file {
-- header "${GLIBC_ARCH_INCLUDE_PATH}/sys/file.h"
-+ header "${GLIBC_INCLUDE_PATH}/sys/file.h"
- export *
- }
- module sem {
-- header "${GLIBC_ARCH_INCLUDE_PATH}/sys/sem.h"
-+ header "${GLIBC_INCLUDE_PATH}/sys/sem.h"
- export *
- }
- % if CMAKE_SDK != "HAIKU":
- module shm {
-- header "${GLIBC_ARCH_INCLUDE_PATH}/sys/shm.h"
-+ header "${GLIBC_INCLUDE_PATH}/sys/shm.h"
- export *
- }
- % end
- module statvfs {
-- header "${GLIBC_ARCH_INCLUDE_PATH}/sys/statvfs.h"
-+ header "${GLIBC_INCLUDE_PATH}/sys/statvfs.h"
- export *
- }
- % end
-
- module ipc {
-- header "${GLIBC_ARCH_INCLUDE_PATH}/sys/ipc.h"
-+ header "${GLIBC_INCLUDE_PATH}/sys/ipc.h"
- export *
- }
- module mman {
-- header "${GLIBC_ARCH_INCLUDE_PATH}/sys/mman.h"
-+ header "${GLIBC_INCLUDE_PATH}/sys/mman.h"
- export *
- }
- module msg {
-- header "${GLIBC_ARCH_INCLUDE_PATH}/sys/msg.h"
-+ header "${GLIBC_INCLUDE_PATH}/sys/msg.h"
- export *
- }
- module resource {
-- header "${GLIBC_ARCH_INCLUDE_PATH}/sys/resource.h"
-+ header "${GLIBC_INCLUDE_PATH}/sys/resource.h"
- export *
- }
- module select {
-- header "${GLIBC_ARCH_INCLUDE_PATH}/sys/select.h"
-+ header "${GLIBC_INCLUDE_PATH}/sys/select.h"
- export *
- }
- % if CMAKE_SDK != "FREEBSD" and CMAKE_SDK != "HAIKU":
- module sendfile {
-- header "${GLIBC_ARCH_INCLUDE_PATH}/sys/sendfile.h"
-+ header "${GLIBC_INCLUDE_PATH}/sys/sendfile.h"
- export *
- }
- % end
- module socket {
-- header "${GLIBC_ARCH_INCLUDE_PATH}/sys/socket.h"
-+ header "${GLIBC_INCLUDE_PATH}/sys/socket.h"
- export *
- }
- module stat {
-- header "${GLIBC_ARCH_INCLUDE_PATH}/sys/stat.h"
-+ header "${GLIBC_INCLUDE_PATH}/sys/stat.h"
- export *
- }
- module time {
-- header "${GLIBC_ARCH_INCLUDE_PATH}/sys/time.h"
-+ header "${GLIBC_INCLUDE_PATH}/sys/time.h"
- export *
- }
- module times {
-- header "${GLIBC_ARCH_INCLUDE_PATH}/sys/times.h"
-+ header "${GLIBC_INCLUDE_PATH}/sys/times.h"
- export *
- }
- module types {
-- header "${GLIBC_ARCH_INCLUDE_PATH}/sys/types.h"
-+ header "${GLIBC_INCLUDE_PATH}/sys/types.h"
- export *
- }
- % if CMAKE_SDK in ["FREEBSD"]:
- module event {
-- header "${GLIBC_ARCH_INCLUDE_PATH}/sys/event.h"
-+ header "${GLIBC_INCLUDE_PATH}/sys/event.h"
- export *
- }
- % end
- module uio {
-- header "${GLIBC_ARCH_INCLUDE_PATH}/sys/uio.h"
-+ header "${GLIBC_INCLUDE_PATH}/sys/uio.h"
- export *
- }
- module un {
-- header "${GLIBC_ARCH_INCLUDE_PATH}/sys/un.h"
-+ header "${GLIBC_INCLUDE_PATH}/sys/un.h"
- export *
- }
- % if CMAKE_SDK in ["LINUX"]:
- module user {
-- header "${GLIBC_ARCH_INCLUDE_PATH}/sys/user.h"
-+ header "${GLIBC_INCLUDE_PATH}/sys/user.h"
- export *
- }
- % end
- module utsname {
-- header "${GLIBC_ARCH_INCLUDE_PATH}/sys/utsname.h"
-+ header "${GLIBC_INCLUDE_PATH}/sys/utsname.h"
- export *
- }
- module wait {
-- header "${GLIBC_ARCH_INCLUDE_PATH}/sys/wait.h"
-+ header "${GLIBC_INCLUDE_PATH}/sys/wait.h"
- export *
- }
- }
diff --git a/repl_swift-dl.patch b/repl_swift-dl.patch
deleted file mode 100644
index cf0b0e8477b2..000000000000
--- a/repl_swift-dl.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -rupN a/tools/repl/swift/CMakeLists.txt b/tools/repl/swift/CMakeLists.txt
---- a/tools/repl/swift/CMakeLists.txt 2019-09-22 09:58:11.416432071 -0700
-+++ b/tools/repl/swift/CMakeLists.txt 2019-09-22 09:58:36.799766163 -0700
-@@ -19,6 +19,8 @@ add_lldb_tool(repl_swift
- main.c
- )
-
-+target_link_libraries(repl_swift PRIVATE dl)
-+
- # The dummy repl executable is a C program, but we always look for a mangled
- # swift symbol (corresponding to main). If we build the repl with debug info,
- # the debugger looks at the frame language (looking up the compile unit) and gets
diff --git a/sanitizer-glibc2.31.patch b/sanitizer-glibc2.31.patch
deleted file mode 100644
index dc4c4178a57a..000000000000
--- a/sanitizer-glibc2.31.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff -rupN a/lib/sanitizer_common/sanitizer_platform_limits_posix.cc b/lib/sanitizer_common/sanitizer_platform_limits_posix.cc
---- a/lib/sanitizer_common/sanitizer_platform_limits_posix.cc 2020-02-27 10:09:15.809898542 -0800
-+++ b/lib/sanitizer_common/sanitizer_platform_limits_posix.cc 2020-02-27 10:17:27.043228236 -0800
-@@ -1129,8 +1129,9 @@ CHECK_SIZE_AND_OFFSET(ipc_perm, uid);
- CHECK_SIZE_AND_OFFSET(ipc_perm, gid);
- CHECK_SIZE_AND_OFFSET(ipc_perm, cuid);
- CHECK_SIZE_AND_OFFSET(ipc_perm, cgid);
--#if !defined(__aarch64__) || !SANITIZER_LINUX || __GLIBC_PREREQ (2, 21)
--/* On aarch64 glibc 2.20 and earlier provided incorrect mode field. */
-+#if !SANITIZER_LINUX || __GLIBC_PREREQ (2, 31)
-+/* glibc 2.30 and earlier provided 16-bit mode field instead of 32-bit
-+ on many architectures. */
- CHECK_SIZE_AND_OFFSET(ipc_perm, mode);
- #endif
-
-diff -rupN a/lib/sanitizer_common/sanitizer_platform_limits_posix.h b/lib/sanitizer_common/sanitizer_platform_limits_posix.h
---- a/lib/sanitizer_common/sanitizer_platform_limits_posix.h 2020-02-27 10:09:15.809898542 -0800
-+++ b/lib/sanitizer_common/sanitizer_platform_limits_posix.h 2020-02-27 10:15:22.723229216 -0800
-@@ -204,26 +204,13 @@ namespace __sanitizer {
- u64 __unused1;
- u64 __unused2;
- #elif defined(__sparc__)
--#if defined(__arch64__)
- unsigned mode;
-- unsigned short __pad1;
--#else
-- unsigned short __pad1;
-- unsigned short mode;
- unsigned short __pad2;
--#endif
- unsigned short __seq;
- unsigned long long __unused1;
- unsigned long long __unused2;
--#elif defined(__mips__) || defined(__aarch64__) || defined(__s390x__)
-- unsigned int mode;
-- unsigned short __seq;
-- unsigned short __pad1;
-- unsigned long __unused1;
-- unsigned long __unused2;
- #else
-- unsigned short mode;
-- unsigned short __pad1;
-+ unsigned int mode;
- unsigned short __seq;
- unsigned short __pad2;
- #if defined(__x86_64__) && !defined(_LP64)
diff --git a/swift-tests-glibc.patch b/swift-tests-glibc.patch
deleted file mode 100644
index 5dbff97d2584..000000000000
--- a/swift-tests-glibc.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff --git a/test/stdlib/POSIX.swift b/test/stdlib/POSIX.swift
-index 91cec1c2e01b..ead9a623554b 100644
---- a/test/stdlib/POSIX.swift
-+++ b/test/stdlib/POSIX.swift
-@@ -69,7 +69,7 @@ POSIXTests.test("sem_open success") {
- let sem = sem_open(semaphoreName, O_CREAT, 0o777, 1)
- expectNotEqual(SEM_FAILED, sem)
-
-- let res = sem_close(sem)
-+ let res = sem_close(sem!)
- expectEqual(0, res)
-
- let res2 = sem_unlink(semaphoreName)
-@@ -83,7 +83,7 @@ POSIXTests.test("sem_open O_EXCL success") {
- let sem = sem_open(semaphoreName, O_CREAT | O_EXCL, 0o777, 1)
- expectNotEqual(SEM_FAILED, sem)
-
-- let res = sem_close(sem)
-+ let res = sem_close(sem!)
- expectEqual(0, res)
-
- let res2 = sem_unlink(semaphoreName)
-@@ -102,7 +102,7 @@ POSIXTests.test("sem_open existing") {
- // difficult.
- expectNotEqual(SEM_FAILED, sem2)
-
-- let res = sem_close(sem)
-+ let res = sem_close(sem!)
- expectEqual(0, res)
-
- let res2 = sem_unlink(semaphoreName)
-@@ -120,7 +120,7 @@ POSIXTests.test("sem_open existing O_EXCL fail") {
- expectEqual(SEM_FAILED, sem2)
- expectEqual(EEXIST, errno)
-
-- let res = sem_close(sem)
-+ let res = sem_close(sem!)
- expectEqual(0, res)
-
- let res2 = sem_unlink(semaphoreName)
diff --git a/swiftpm-glibc.patch b/swiftpm-glibc.patch
deleted file mode 100644
index f3fa8c1815af..000000000000
--- a/swiftpm-glibc.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff --git a/Sources/Basic/Process.swift b/Sources/Basic/Process.swift
-index 2e2efd448..f65702709 100644
---- a/Sources/Basic/Process.swift
-+++ b/Sources/Basic/Process.swift
-@@ -366,7 +366,10 @@ public final class Process: ObjectIdentifierProtocol {
- defer { posix_spawn_file_actions_destroy(&fileActions) }
-
- // Workaround for https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=89e435f3559c53084498e9baad22172b64429362
-- let devNull = strdup("/dev/null")
-+ // Change allowing for newer version of glibc
-+ guard let devNull = strdup("/dev/null") else {
-+ throw SystemError.posix_spawn(0, arguments)
-+ }
- defer { free(devNull) }
- // Open /dev/null as stdin.
- posix_spawn_file_actions_addopen(&fileActions, 0, devNull, O_RDONLY, 0)
-@@ -392,7 +395,7 @@ public final class Process: ObjectIdentifierProtocol {
-
- let argv = CStringArray(arguments)
- let env = CStringArray(environment.map({ "\($0.0)=\($0.1)" }))
-- let rv = posix_spawnp(&processID, argv.cArray[0], &fileActions, &attributes, argv.cArray, env.cArray)
-+ let rv = posix_spawnp(&processID, argv.cArray[0]!, &fileActions, &attributes, argv.cArray, env.cArray)
-
- guard rv == 0 else {
- throw SystemError.posix_spawn(rv, arguments)