summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Jülke2015-12-11 10:03:56 +0100
committerGabriel Jülke2015-12-11 10:03:56 +0100
commitb410414c5f471009f8cd3d45be9beecc964b163b (patch)
treea2be8f7fa9178db527008f63b8c382eff3c59a69
downloadaur-b410414c5f471009f8cd3d45be9beecc964b163b.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD26
-rw-r--r--nitrotasks.install11
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ee031417152
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Fri Dec 11 08:56:36 UTC 2015
+pkgbase = nitrotasks
+ pkgdesc = An eyecandy task managment tool
+ pkgver = 1.5.1
+ pkgrel = 1
+ url = http://nitrotasks.com/
+ install = nitrotasks.install
+ arch = any
+ license = BSD
+ makedepends = python2-distutils-extra
+ makedepends = intltool
+ depends = pygtk
+ depends = python2
+ depends = python2-gobject
+ depends = webkitgtk
+ optdepends = dropbox: Synchronization support [AUR]
+ source = https://launchpad.net/nitrotasks/trunk/1.5.1/+download/nitrotasks_1.5.1.tar.gz
+ md5sums = f5f59a511d18b17dd291fd7498558c28
+
+pkgname = nitrotasks
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dfd8793848ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: pyriand3r
+
+pkgname=nitrotasks
+pkgver=1.5.1
+pkgrel=1
+pkgdesc="An eyecandy task managment tool"
+arch=('any')
+url="http://nitrotasks.com/"
+license=('BSD')
+depends=('pygtk' 'python2' 'python2-gobject' 'webkitgtk')
+makedepends=('python2-distutils-extra' 'intltool')
+optdepends=('dropbox: Synchronization support [AUR]')
+install=$pkgname.install
+source=("https://launchpad.net/${pkgname}/trunk/${pkgver}/+download/${pkgname}_${pkgver}.tar.gz")
+md5sums=('f5f59a511d18b17dd291fd7498558c28')
+
+package() {
+ cd quickly_trunk
+
+ sed -i 's/Unity,\ //;s/launcher.*/pass/' nitrotasks/NitrotasksWindow.py
+
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+
+ find "$pkgdir/" -type f -not -name nitrotasks -exec chmod 644 '{}' \;
+}
diff --git a/nitrotasks.install b/nitrotasks.install
new file mode 100644
index 000000000000..dd695dbeaf13
--- /dev/null
+++ b/nitrotasks.install
@@ -0,0 +1,11 @@
+post_install() {
+ glib-compile-schemas --allow-any-name usr/share/glib-2.0/schemas
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+post_remove() {
+ post_install "$1"
+}