summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHildigerr Vergaray2023-05-02 19:35:28 -0700
committerHildigerr Vergaray2023-05-02 19:35:28 -0700
commitb4175cc51bfbffdb6922afda936e0651617abf7c (patch)
tree6b7fd87708189ec7146828ab94c34bb5b85bbb15
parent731cef1bcc756a725deafeb8e89fba4d8476d1b2 (diff)
downloadaur-b4175cc51bfbffdb6922afda936e0651617abf7c.tar.gz
prepare submodules non-explicitly
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 8 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d42f5fe3e60..63a00f5fc914 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fs2_open-git
pkgdesc = An enhancement of the original Freespace 2 engine - GIT version
pkgver = 22.0.0.r20230502.02a40ae90.0
- pkgrel = 1
+ pkgrel = 2
url = http://scp.indiegames.us
install = fs2_open-git.install
arch = i686
@@ -23,10 +23,6 @@ pkgbase = fs2_open-git
provides = fs2_open
conflicts = fs2_open
source = fs2_open-git::git+https://github.com/scp-fs2open/fs2open.github.com.git
- source = cotire::git+https://github.com/sakra/cotire.git
- source = cmake-modules::git+https://github.com/asarium/cmake-modules.git
- sha256sums = SKIP
- sha256sums = SKIP
sha256sums = SKIP
pkgname = fs2_open-git
diff --git a/PKGBUILD b/PKGBUILD
index 2e46b469448f..1571abca8668 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=fs2_open-git
pkgver=22.0.0.r20230502.02a40ae90.0
-pkgrel=1
+pkgrel=2
pkgdesc="An enhancement of the original Freespace 2 engine - GIT version"
url="http://scp.indiegames.us"
arch=('i686' 'x86_64')
@@ -14,14 +14,14 @@ makedepends=('git' 'cmake' 'freetype2' 'doxygen' 'ffmpeg')
conflicts=('fs2_open')
provides=('fs2_open')
install=fs2_open-git.install
-source=("${pkgname}::git+https://github.com/scp-fs2open/fs2open.github.com.git"
-"cotire::git+https://github.com/sakra/cotire.git"
-"cmake-modules::git+https://github.com/asarium/cmake-modules.git")
+source=("${pkgname}::git+https://github.com/scp-fs2open/fs2open.github.com.git")
-sha256sums=('SKIP'
-'SKIP'
-'SKIP')
+sha256sums=('SKIP')
+prepare() {
+ cd "$srcdir/$pkgname"
+ git submodule update --init --recursive
+}
pkgver () {
cd "$srcdir/$pkgname"
@@ -35,13 +35,6 @@ build()
{
cd "$srcdir/$pkgname"
- git submodule init
- git config submodule.cotire $srcmodule/cotire
- git submodule update
- git submodule init
- git config submodule.cmake-modules $srcmodule/cmake-modules
- git submodule update
-
mkdir build
cd build
cmake ../